Announcement

Collapse
No announcement yet.

Dota 2 Radeon OpenGL vs. Vulkan Performance With Mesa Git, Linux 4.9-rc1

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • ResponseWriter
    replied
    Originally posted by finalzone View Post

    I can help on that part and am willing to test support for CIK and SI as I own a hybrid laptop running on R7 M265DX aka Radeon R6 from the kernel + R5 M230 Jetpro. Using both Mystro256's repository and building a custom kernel due to a bug related on Boot EC, the CIK on kernel 4.8 is fine but the SI side keep on crashing when using amdgpu module.
    Vulkan support is currently broken at the moment
    Code:
    $ vulkaninfo
    ===========
    VULKAN INFO
    ===========
    
    Vulkan API Version: 1.0.26
    
    INFO: [loader] Code 0 : Found manifest file /usr/share/vulkan/explicit_layer.d/VkLayer_image.json, version "1.0.0"
    INFO: [loader] Code 0 : Found manifest file /usr/share/vulkan/explicit_layer.d/VkLayer_unique_objects.json, version "1.0.0"
    INFO: [loader] Code 0 : Found manifest file /usr/share/vulkan/explicit_layer.d/VkLayer_swapchain.json, version "1.0.0"
    INFO: [loader] Code 0 : Found manifest file /usr/share/vulkan/explicit_layer.d/VkLayer_object_tracker.json, version "1.0.0"
    INFO: [loader] Code 0 : Found manifest file /usr/share/vulkan/explicit_layer.d/VkLayer_core_validation.json, version "1.0.0"
    INFO: [loader] Code 0 : Found manifest file /usr/share/vulkan/explicit_layer.d/VkLayer_threading.json, version "1.0.0"
    INFO: [loader] Code 0 : Found manifest file /usr/share/vulkan/explicit_layer.d/VkLayer_parameter_validation.json, version "1.0.0"
    INFO: [loader] Code 0 : Found manifest file /usr/share/vulkan/explicit_layer.d/VkLayer_image.json, version "1.0.0"
    INFO: [loader] Code 0 : Found manifest file /usr/share/vulkan/explicit_layer.d/VkLayer_unique_objects.json, version "1.0.0"
    INFO: [loader] Code 0 : Found manifest file /usr/share/vulkan/explicit_layer.d/VkLayer_swapchain.json, version "1.0.0"
    INFO: [loader] Code 0 : Found manifest file /usr/share/vulkan/explicit_layer.d/VkLayer_object_tracker.json, version "1.0.0"
    INFO: [loader] Code 0 : Found manifest file /usr/share/vulkan/explicit_layer.d/VkLayer_core_validation.json, version "1.0.0"
    INFO: [loader] Code 0 : Found manifest file /usr/share/vulkan/explicit_layer.d/VkLayer_threading.json, version "1.0.0"
    INFO: [loader] Code 0 : Found manifest file /usr/share/vulkan/explicit_layer.d/VkLayer_parameter_validation.json, version "1.0.0"
    INFO: [loader] Code 0 : Found manifest file /etc/vulkan/icd.d/radeon_icd.json, version "1.0.0"
    INFO: [loader] Code 0 : Found manifest file /etc/vulkan/icd.d/anv_icd.json, version "1.0.0"
    
    Instance Extensions:
    ====================
    Instance Extensions count = 3
    VK_KHR_surface : extension revision 25
    VK_KHR_xcb_surface : extension revision 5
    VK_EXT_debug_report : extension revision 3
    /builddir/build/BUILD/Vulkan-LoaderAndValidationLayers-sdk-1.0.26.0/demos/vulkaninfo.c:1418: failed with VK_ERROR_INITIALIZATION_FAILED
    I will test a custom kernel 4.9 when it will be successful to build.
    Same error I had when a vulkan-intel package was installed. See if that package is installed and try removing it if you don't need it.

    Leave a comment:


  • dungeon
    replied
    Originally posted by Michael View Post
    ... as also been reworking to override Talos Principle's habit of resetting defaults on driver/GPU changes.
    Serious Engine and Talos has a lot of cvars... '+prj_bStartupAutoDetection 0' should disable that.

    Leave a comment:


  • finalzone
    replied
    Originally posted by airlied View Post
    I don't have a CIK gpu I don't think, one SI, two VI and one Polaris
    I can help on that part and am willing to test support for CIK and SI as I own a hybrid laptop running on R7 M265DX aka Radeon R6 from the kernel + R5 M230 Jetpro. Using both Mystro256's repository and building a custom kernel due to a bug related on Boot EC, the CIK on kernel 4.8 is fine but the SI side keep on crashing when using amdgpu module.
    Vulkan support is currently broken at the moment
    Code:
    $ vulkaninfo
    ===========
    VULKAN INFO
    ===========
    
    Vulkan API Version: 1.0.26
    
    INFO: [loader] Code 0 : Found manifest file /usr/share/vulkan/explicit_layer.d/VkLayer_image.json, version "1.0.0"
    INFO: [loader] Code 0 : Found manifest file /usr/share/vulkan/explicit_layer.d/VkLayer_unique_objects.json, version "1.0.0"
    INFO: [loader] Code 0 : Found manifest file /usr/share/vulkan/explicit_layer.d/VkLayer_swapchain.json, version "1.0.0"
    INFO: [loader] Code 0 : Found manifest file /usr/share/vulkan/explicit_layer.d/VkLayer_object_tracker.json, version "1.0.0"
    INFO: [loader] Code 0 : Found manifest file /usr/share/vulkan/explicit_layer.d/VkLayer_core_validation.json, version "1.0.0"
    INFO: [loader] Code 0 : Found manifest file /usr/share/vulkan/explicit_layer.d/VkLayer_threading.json, version "1.0.0"
    INFO: [loader] Code 0 : Found manifest file /usr/share/vulkan/explicit_layer.d/VkLayer_parameter_validation.json, version "1.0.0"
    INFO: [loader] Code 0 : Found manifest file /usr/share/vulkan/explicit_layer.d/VkLayer_image.json, version "1.0.0"
    INFO: [loader] Code 0 : Found manifest file /usr/share/vulkan/explicit_layer.d/VkLayer_unique_objects.json, version "1.0.0"
    INFO: [loader] Code 0 : Found manifest file /usr/share/vulkan/explicit_layer.d/VkLayer_swapchain.json, version "1.0.0"
    INFO: [loader] Code 0 : Found manifest file /usr/share/vulkan/explicit_layer.d/VkLayer_object_tracker.json, version "1.0.0"
    INFO: [loader] Code 0 : Found manifest file /usr/share/vulkan/explicit_layer.d/VkLayer_core_validation.json, version "1.0.0"
    INFO: [loader] Code 0 : Found manifest file /usr/share/vulkan/explicit_layer.d/VkLayer_threading.json, version "1.0.0"
    INFO: [loader] Code 0 : Found manifest file /usr/share/vulkan/explicit_layer.d/VkLayer_parameter_validation.json, version "1.0.0"
    INFO: [loader] Code 0 : Found manifest file /etc/vulkan/icd.d/radeon_icd.json, version "1.0.0"
    INFO: [loader] Code 0 : Found manifest file /etc/vulkan/icd.d/anv_icd.json, version "1.0.0"
    
    Instance Extensions:
    ====================
    Instance Extensions    count = 3
        VK_KHR_surface                      : extension revision 25
        VK_KHR_xcb_surface                  : extension revision  5
        VK_EXT_debug_report                 : extension revision  3
    /builddir/build/BUILD/Vulkan-LoaderAndValidationLayers-sdk-1.0.26.0/demos/vulkaninfo.c:1418: failed with VK_ERROR_INITIALIZATION_FAILED
    I will test a custom kernel 4.9 when it will be successful to build.

    Leave a comment:


  • Michael
    replied
    Originally posted by airlied View Post
    anyone know how to get talos from pts to use vulkan? the test doesn't seem to ask like dota2.
    At the moment unfortunately there isn't an automated way, been working on a rewritten test profile for it and hope to have it committed soon. Been doing it manually in the meantime as also been reworking to override Talos Principle's habit of resetting defaults on driver/GPU changes, which at the moment been changing some Lua scripts but hoping for a better way from Croteam.

    Leave a comment:


  • airlied
    replied
    anyone know how to get talos from pts to use vulkan? the test doesn't seem to ask like dota2.

    Leave a comment:


  • Michael
    replied
    Originally posted by airlied View Post
    not sure why 4K doesn't work for Michael here's dota2 results at 4k.
    http://openbenchmarking.org/result/1...HA-RADVDOTA237
    Whenever tried, it always just hangs at the loading screen when at 4K... I don't see anything in dmesg to show like a DRM driver issue and can kill the dota2 process and then it proceeds, but never got past the loading screen when using RADV Vulkan at 4K (works fine with RadeonSI GL, etc). Let me know if any other information would be useful, but yeah doesn't go past the loading screen then and I think I've seen some other people (well, not recalling usernames, but at least someone else) I think mentioned in one of the other threads.

    Leave a comment:


  • airlied
    replied
    not sure why 4K doesn't work for Michael here's dota2 results at 4k.
    http://openbenchmarking.org/result/1...HA-RADVDOTA237

    Leave a comment:


  • geearf
    replied
    Originally posted by Tomin View Post

    It would be useful if there were an easy way to include all USB drivers after using modprobed-db, because even though there would be some drivers that are not needed, there also wouldn't be a situation where there was a driver missing for some USB device*. I haven't compiled too many kernels in my life (just sometimes, usually with way too many drivers), so maybe there is, but I just don't know it.

    *well, ofc there aren't drivers for every single device in the world, but you know what I meant... all the USB devices Linux supports anyway.
    Maybe you can script enabling all *USB* in the config file.

    Leave a comment:


  • geearf
    replied
    Originally posted by bridgman View Post

    When you are working on kernel code you normally do incremental builds, where only the changed files get recompiled. That is much faster than a full kernel build, although building packages is still slower than I would like.
    Oh yes good point!

    Leave a comment:


  • peppercats
    replied
    Originally posted by haagch View Post
    Do you know anyone in the real world using it? I mean the whole "AZDO" thing. Seems to be very nice in theory, but game developers seem to view it as "too complicated".
    For example: http://steamcommunity.com/app/465240...43389009395731
    You just hit the nail on the head why Vulkan exists. It's not that Vulkan is flat out faster than OpenGL, it's that OpenGL is so hindered by legacy.

    Leave a comment:

Working...
X