Announcement

Collapse
No announcement yet.

AMD's Vulkan Driver Will Only Work With The AMDGPU Kernel Driver

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Berniyh
    replied
    Originally posted by haagch View Post
    The last time the question came up the reply was more like "why would you want that?"...
    Well that is a question which up to now was a very good one. But yeah, here might be your answer.

    Leave a comment:


  • Berniyh
    replied
    What's the big deal here? Why are so many people going mad?

    The statement is, that Vulcan support will only be provided on the amdgpu driver and on GCN. That potentially means everything from HD8xxx upwards, if I'm not mistaken.
    Everything else is more than 3 years old, so what's the big deal?
    Originally posted by Nille View Post
    Vulkan was never announced for HD5k and HD6k Cards. There is even no D3D12 Support or Mantle Support for this cards.

    So, Vulkan and D3D12 work only on GCN Cards. Thats fine but now the Problem. The AMDGPU driver support only a very small amount from the GCN Cards. So, can we expect that the driver support in the near future all GCN Cards?
    Experimental support for CI chips is already implemented in amdgpu, SI chips have afaik not been explicitely excluded.
    Since for CI and SI, a driver already exists that is fully functional (radeonsi), it is only to be expected, that they first focus on the chips (VI) which do not yet have a driver when implementing amdgpu.

    So the chances are there, that basically everything from the last three years *might* receive support in amdgpu and therefore potentially Vulcan support. And for CI chips, it actually seems very likely given that there is already experimental support.

    I really don't get what all the fuzz is about.

    Leave a comment:


  • Michael
    replied
    Originally posted by Nille View Post
    So, Vulkan and D3D12 work only on GCN Cards. Thats fine but now the Problem. The AMDGPU driver support only a very small amount from the GCN Cards. So, can we expect that the driver support in the near future all GCN Cards?
    You Can Help Bring Vulkan Support To Older AMD GCN GPUs http://www.phoronix.com/scan.php?page=news_item&px=Help-Bring-Older-GCN-To-AMDGPU

    Leave a comment:


  • drSeehas
    replied
    Originally posted by MaxToTheMax View Post
    ... I'm less likely to pick an API if a significant percentage of my potential customers don't have drivers that support it. ... not supporting Vulkan on that hardware is still a bad decision for AMD because it will hinder Vulkan adoption, and AMD needs Vulkan to catch on.
    ???
    Vulkan won't be available on Windows for pre-VI hardware?
    Where did you get this from?

    Linux is really not a significant percentage of potential customers!

    Leave a comment:


  • haagch
    replied
    Originally posted by agd5f View Post
    You could do theoretically do vulkan on pre-GCN parts, but it you wouldn't gain much over existing APIs.
    Originally posted by agd5f View Post
    just don't expect much of a gain compared to older APIs.
    Have you played some linux games on radeonsi lately?

    On my HD 7970M:
    Here is Caffeine (Unreal 4): https://www.youtube.com/watch?v=J8-RRzBarK4
    Here is Saints Row 4: https://www.youtube.com/watch?v=fgjquxK8mqM

    We are not looking for a gain compared to nvidia's opengl driver, we are looking for a gain compared to the abysmal framerates you get today in many games. Native Counter Strike GO still drops under 60 fps all the time while with gallium nine it stays comfortably above 60 fps all the time on my HD 7970M. There are real deficiencies currently that I expect would be barely there with Vulkan.

    Originally posted by agd5f View Post
    Yes, vulkan support is working already. What we have yet to finalize is the exact manner and timelines in which we roll out support for various asic families.
    At least some good news, thanks.

    Originally posted by bridgman View Post
    Nope, this is a clear message that everyone needs to read the articles more carefully.
    If the answer from AMD had been "we will only ever support Vulkan on the set of GPUs which are enabled by default on upstream amdgpu today" that would be different, but that's not what we said.
    Wait, AMD does think about supporting older GCN GPUs with amdgpu? The last time the question came up the reply was more like "why would you want that?"...

    Leave a comment:


  • Nille
    replied
    Vulkan was never announced for HD5k and HD6k Cards. There is even no D3D12 Support or Mantle Support for this cards.

    So, Vulkan and D3D12 work only on GCN Cards. Thats fine but now the Problem. The AMDGPU driver support only a very small amount from the GCN Cards. So, can we expect that the driver support in the near future all GCN Cards?

    Leave a comment:


  • glxextxexlg
    replied
    I knew it.. I knew AMD had its move to kill vulkan. I wouldn't be surprised if current delay in vulkan's release is because AMD hasn't got a working driver yet. Suckers.

    Leave a comment:


  • eddielinux
    replied
    IMHO, I think in next 3 years so many people will have 4k monitors or tvs and like actual gaming systems everything will be obsolete, sometimes this is the way that technologies moves forward.

    Leave a comment:


  • humbug
    replied
    deleted
    Last edited by humbug; 16 January 2016, 12:58 AM.

    Leave a comment:


  • MaxToTheMax
    replied
    Originally posted by theriddick View Post
    Most developers don't even support those cards in their minimal requirement anymore.
    Not true. Given the way Moore's law has slowed down lately, 5 years isn't really an eternity anymore. You can still buy those cards on Newegg and they do support OpenGL 4.4/D3D 11, so they could easily end up in a budget build.

    Leave a comment:

Working...
X