Announcement

Collapse
No announcement yet.

Ubuntu 18.10's SDL2 Build Will Ship With Vulkan Support Enabled

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Ubuntu 18.10's SDL2 Build Will Ship With Vulkan Support Enabled

    Phoronix: Ubuntu 18.10's SDL2 Build Will Ship With Vulkan Support Enabled

    Released almost exactly one year ago to the day was SDL 2.0.6 that brought with it some Vulkan helpers. Finally with the upcoming Ubuntu 18.10 "Cosmic Cuttlefish" release, those Vulkan bits will be enabled...

    http://www.phoronix.com/scan.php?pag...2-Build-Vulkan

  • #2
    I am running the daily build of 18.10.
    Unfortunately Python 3.7 isn't available, its stuck with 3.6.
    Also, I haven't gotten Atom or VS Code to run.

    Comment


    • #3
      Good, as I discovered the issue in 18.04 when trying to run the Vulkan version of Forsaken: https://www.gamingonlinux.com/articl...-version.12548

      In short, I got in touch with Ryan and Canonical and it seems to have moved forwards

      Comment


      • #4
        Ubuntu 18.10 is likely going to be a great one for gamers, for many things especially on newer hardware Ubuntu 18,04 is just not fit for purpose out of the box.
        Sure 18.04 is great for games, but you typically have to install newer packages then those available in the repo's especially on Vega since 4.15 barely functions and 4.17 and onward have shown to be very stable on the new Vega GPU's.
        And while easy to install with a simple script its not something new Linux users should have to do since they expect steam's proton to work out of the box even though there mesa and kernel may not utilize the newest feature set required for proton. So when it comes to gaming having Ubuntu 18.10 ship with a newer kernel, vulkan libs installed out of the box and hopefully a newer Proton ready mesa version it will be the goto distro for easy linux gaming for many.

        Comment


        • #5
          Originally posted by uid313 View Post
          I am running the daily build of 18.10.
          Unfortunately Python 3.7 isn't available, its stuck with 3.6.
          Also, I haven't gotten Atom or VS Code to run.
          It is stuck in Debian transition at 92% currently.

          https://release.debian.org/transitio...python3.7.html

          Until it lands in Debian Sid completely it won't happen in Ubuntu, same like this Vulkan in SDL2 enabled it is enabled in Debian first and then landed here in Ubuntu

          3.7.0 is very new and it won't be default i guess until at least one year after release, not sure about Ubi 18.10 seems late, but at least for Debian 10 if not default it could be second option.
          Last edited by dungeon; 09-20-2018, 06:29 AM.

          Comment


          • #6
            I don't get it, why did it take Ubuntu a year to compile it with Vulkan helpers enabled?

            Comment


            • #7
              Originally posted by Azpegath View Post
              I don't get it, why did it take Ubuntu a year to compile it with Vulkan helpers enabled?
              I believe that is because Ubuntu users does not understand where is right place to file some bugs It seems it was disabled on one point, but once bug was filled it is enabled::

              https://bugs.debian.org/cgi-bin/bugr...cgi?bug=908842

              Especially for packages from 'universe' repo Canonical does not care much (they do about their main repo) and SDL is in universe of course, thus depends on community effort which in turn mostly means Debian and so on

              In general and sort of for all ubuntu universe packages, bugs/wishlist/etc... can be filled in Debian directly if Ubuntu's community final touch is not involved into problem

              Even Michael from Phoronix does not help to clarify this, as he says here Ubuntu enabled this or that, but that isn't how things goes really
              Last edited by dungeon; 09-20-2018, 09:34 AM.

              Comment


              • #8
                Originally posted by dungeon View Post

                It is stuck in Debian transition at 92% currently.

                https://release.debian.org/transitio...python3.7.html

                Until it lands in Debian Sid completely it won't happen in Ubuntu, same like this Vulkan in SDL2 enabled it is enabled in Debian first and then landed here in Ubuntu

                3.7.0 is very new and it won't be default i guess until at least one year after release, not sure about Ubi 18.10 seems late, but at least for Debian 10 if not default it could be second option.
                Very new? It was released on June 27!

                Comment


                • #9
                  Originally posted by Vistaus View Post
                  Very new? It was released on June 27!
                  Ha, ha, and packages were available same day in Debian . What i meant there that it is probably so new or might be too late to be default maybe for that Ubuntu in question.

                  Originally posted by uid313 View Post
                  I am running the daily build of 18.10.
                  Unfortunately Python 3.7 isn't available, its stuck with 3.6.
                  Are you complaining because maybe it is not default or something else? Packages are available otherwise:

                  https://packages.ubuntu.com/cosmic/python3.7
                  Last edited by dungeon; 09-20-2018, 02:16 PM.

                  Comment


                  • #10
                    Originally posted by uid313 View Post
                    Also, I haven't gotten Atom or VS Code to run.
                    Check out the VS Code flatpak. There are two on flathub -- the build from MS as well as the OSS version compiled from github.

                    Comment

                    Working...
                    X