Sorry for my newbie question, but I don't know where else to ask. I have tried several other forums, but here is my problem.

I have an amd radeon r9 390 gpu. Using Ubuntu 16.04 - kernel: 4.14.6-041406-generic

I am using oibaf's ppa https://launchpad.net/~oibaf/+archiv...aphics-drivers

"glxinfo | grep OpenGL"

Gives the following output:

OpenGL vendor string: X.Org
OpenGL renderer string: AMD HAWAII (DRM 2.50.0 / 4.14.6-041406-generic, LLVM 5.0.1)
OpenGL core profile version string: 4.5 (Core Profile) Mesa 17.4.0-devel
OpenGL core profile shading language version string: 4.50
OpenGL core profile context flags: (none)
OpenGL core profile profile mask: core profile
OpenGL core profile extensions:
OpenGL version string: 3.0 Mesa 17.4.0-devel
OpenGL shading language version string: 1.30
OpenGL context flags: (none)
OpenGL extensions:
OpenGL ES profile version string: OpenGL ES 3.1 Mesa 17.4.0-devel
OpenGL ES profile shading language version string: OpenGL ES GLSL ES 3.10
OpenGL ES profile extensions:


--------------------------------------------------------------------

lspci -k | grep -EA3 'VGA|3D|Display'
Gives the following output:
VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Hawaii PRO [Radeon R9 290/390] (rev 80)
Subsystem: Micro-Star International Co., Ltd. [MSI] Hawaii PRO [Radeon R9 290]
Kernel driver in use: radeon
Kernel modules: radeon, amdgpu


My gpu is not supporting the amdgpu driver.
When I type vulkaninfo, I get the following output

===========
VULKAN INFO
===========

Vulkan API Version: 1.0.42

INFO: [loader] Code 0 : Found manifest file /home/simon/.local/share/vulkan/implicit_layer.d/steamoverlay_i386.json, version "1.0.0"
INFO: [loader] Code 0 : Found manifest file /home/simon/.local/share/vulkan/implicit_layer.d/steamoverlay_x86_64.json, version "1.0.0"
INFO: [loader] Code 0 : Found ICD manifest file /usr/share/vulkan/icd.d/radeon_icd.x86_64.json, version "1.0.0"
INFO: [loader] Code 0 : Found ICD manifest file /usr/share/vulkan/icd.d/intel_icd.x86_64.json, version "1.0.0"

Instance Extensions:
====================
Instance Extensions count = 6
VK_KHR_get_physical_device_properties2: extension revision 1
VK_KHR_surface : extension revision 25
VK_KHR_wayland_surface : extension revision 6
VK_KHR_xcb_surface : extension revision 6
VK_KHR_xlib_surface : extension revision 6
VK_EXT_debug_report : extension revision 9
/build/vulkan-IbLrZR/vulkan-1.0.42.0+dfsg1/demos/vulkaninfo.c:1523: failed with VK_ERROR_INITIALIZATION_FAILED


Can someone please help me with this? I have now tried for several months. I can't get it to work.