Announcement

Collapse
No announcement yet.

OpenGL 4.3 Support Lands In R600 Gallium3D Driver

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • OpenGL 4.3 Support Lands In R600 Gallium3D Driver

    Phoronix: OpenGL 4.3 Support Lands In R600 Gallium3D Driver

    In between hacking on the RADV Vulkan driver, David Airlie has found the time to land his patches enabling OpenGL 4.3 and GLSL 430 support within Mesa 17.4-dev Git for the R600g driver...

    http://www.phoronix.com/scan.php?pag...Lands-In-R600g

  • #2
    GREAT work, Dave and Gert!

    Comment


    • #3
      Great to see this open source support for 8 year old hardware.

      Comment


      • #4
        Ah, some nice and shiny pre-Christmas gifts!
        Thanks, developers!
        Stop TCPA, stupid software patents and corrupt politicians!

        Comment


        • #5
          From what I remember series HD5000 and HD6000 can reach OpenGL 4.5 not just 4.4...

          Comment


          • #6
            Impressive work!

            Doesn't that also mean that R600g-supported hardware such as the HD 5000/6000 series could theoretically be made to support Vulkan as well? I realize that this Terascale generation hardware would require completely different Vulkan drivers than those developed for GCN hardware, but wouldn't it be technically feasible?

            From what I had understood, any graphics hardware advanced enough to support Compute Shaders (OpenGL 4.3 or OpenGL ES 3.1 and higher) would suffice, right? Given how Vulkan drivers are lower level and require less overhead than OpenGL, such support could perhaps provide some advantages even in older hardware.

            Also, I don't believe FP64 capabilities would be a prerequisite for Vulkan support, right?

            Comment


            • #7
              Originally posted by xpris View Post
              From what I remember series HD5000 and HD6000 can reach OpenGL 4.5 not just 4.4...
              They do with fglrx.

              Comment


              • #8
                How's Aruba or the Richland APUs a decade old? I reckon Richland was introduced in 2013 thus was actively sold max 3 years ago...

                It doesn't sound crazy to me to work on 3-4 year old hardware. Maybe I'm too old, dunno.

                Comment


                • #9
                  Well, Alien Isolation and Tomb Raider now work nicely on my 6870 on normal settings (obviously with MESA_GL_VERSION_OVERRIDE=4.3), but with TR one should disable tesselation, because it kills performance.

                  Comment


                  • #10
                    Originally posted by xpris View Post
                    From what I remember series HD5000 and HD6000 can reach OpenGL 4.5 not just 4.4...
                    https://mesamatrix.net/

                    r600 has most of what it needs for 4.5. Hopefully, someone knowledgeable can comment how much work needs to be done to achieve it, or whether it's feasible to force 4.5 advertisement once 4.4 is supported.

                    Comment

                    Working...
                    X