Announcement

Collapse
No announcement yet.

Mesa 17.1 Now Available On Ubuntu 16.04/17.04 Via X-Updates

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Mesa 17.1 Now Available On Ubuntu 16.04/17.04 Via X-Updates

    Phoronix: Mesa 17.1 Now Available On Ubuntu 16.04/17.04 Via X-Updates

    If you want the Mesa 17.1 graphics driver stack in a semi-official manner on Ubuntu 16.04 LTS or 17.04 Zesty, X-Updates has been updated to this new stable release of Mesa that features many exciting changes...

    http://www.phoronix.com/scan.php?pag...-X-Updates-PPA

  • #2
    Looking at the benchmarks, it seems I shouldn't upgrade my xenial system that's on 4.10?

    Edit: oh, those were mesa git benches. 17.1 is ok?
    Last edited by Otus; 05-17-2017, 05:01 PM.

    Comment


    • #3
      Any idea if this will (finally) (fully) support the full OpenCL stack for GCN1.0 cards like mine 280x?

      Still getting this error on standard 17.04:

      Code:
      [opencl_init] could not find opencl runtime library 'libOpenCL'
      [opencl_init] could not find opencl runtime library 'libOpenCL.so'
      [opencl_init] found opencl runtime library 'libOpenCL.so.1'
      [opencl_init] opencl library 'libOpenCL.so.1' found on your system and loaded
      [opencl_init] found 1 platform
      [opencl_init] found 1 device
      [opencl_init] discarding device 0 `AMD TAHITI (DRM 2.49.0 / 4.10.0-21-generic, LLVM 4.0.0)' due to missing image support.
      [opencl_init] no suitable devices found.
      [opencl_init] FINALLY: opencl is NOT AVAILABLE on this system.
      [opencl_init] initial status of opencl enabled flag is OFF.

      Comment


      • #4
        Any idea if this combination will (finally) enable the (full) OpenCL stack on GCN1.0 (280x) cards?

        Darktable on vanilla 17.04 still results in:

        [opencl_init] could not find opencl runtime library 'libOpenCL'
        [opencl_init] could not find opencl runtime library 'libOpenCL.so'
        [opencl_init] found opencl runtime library 'libOpenCL.so.1'
        [opencl_init] opencl library 'libOpenCL.so.1' found on your system and loaded
        [opencl_init] found 1 platform
        [opencl_init] found 1 device
        [opencl_init] discarding device 0 `AMD TAHITI (DRM 2.49.0 / 4.10.0-21-generic, LLVM 4.0.0)' due to missing image support.
        [opencl_init] no suitable devices found.
        [opencl_init] FINALLY: opencl is NOT AVAILABLE on this system.
        [opencl_init] initial status of opencl enabled flag is OFF.

        Comment

        Working...
        X