Announcement

Collapse
No announcement yet.

HITMAN Now Available For Linux

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • HITMAN Now Available For Linux

    Phoronix: HITMAN Now Available For Linux

    HITMAN: The Complete First Season is now available for Linux...

    http://www.phoronix.com/scan.php?pag...Linux-Released

  • #2
    The trailer looks really captivating, I am a total NOOB to the Hitman series.

    I'm stoked but a bit myffd after writing on the Civ 6 steamboard regarding my intent to gift a copy of Civ 6. Apparantly freedom of speech and using the words like "bullshit" is punishable by temp bans - but eloquent passive agressive speech cryptically designed to insult with intent to harm is okay.

    Some people want to see the internet conform to their own personal idea of morality, be it religiously based, or otherwise. (The Amish might see the internet as a aborition alltogether and see it dismantled if they had the power for example).

    Other's see the danger in taking away freedom of speech. We live in a world where classism and socioecconomics control what words are deemed good & bad - okay and unacceptable.

    The rich have their own vocabulary to eloquently demean others like perfidious women. Meanwhile taking a persons home away and making them homeless is "just business" while saying fuck, shit, ass is a crime.

    Firing an employee who makes a high salery and has loyally given 30 years to a company is "businses" but calling someone out on their bullshit at work is "a crime".

    We live in a world where the criminals have set the standard of good and bad and are intelligent to weaponize religions, and morality in whatever way possible to reinforce their cause and install their ideas into the vulnerable minds who don't think for themselves.

    / Rant

    I'm very interested in the HITMAN series, I wonder if it'll play like Splinter Cell, or MGS, etc... I think I'm going to wait for people to get back on performance on RX 480 before I buy though since IMO it could be hit/miss - I'm hoping at least 30-40 FPS @ 1080p, Ideally 60+

    If anyone has any screenshots, game videos to share that'd be great - the 10 Trailers on the Steam page confuse me about what I should actually expect in terms of gameplay.

    Comment


    • #3
      Originally posted by ElectricPrism View Post
      / Rant
      Off topic, yes. But a damn good rant!

      Comment


      • #4
        Linux version... check
        AMD mesa supported... check
        On sale... check

        ... Will buy when I get back home

        I hope you'll be able to run some automated tests Michael.

        Comment


        • #5
          Bought Downloading :'(

          Comment


          • #6
            Is it playable?
            I ended up finishing the deus ex game on my windows partition because I couldn't keep a stable 20 FPS, I maintain 60 FPS on the same settings in windows...

            Comment


            • #7
              Windows needs at least: NVIDIA GTX 660
              Linux needs at least: Nvidia GTX 680


              Windows recommended: NVIDIA GTX 770
              Linux recommended: Nvidia GTX 970
              WTF?! 680 is 2x over 660
              970 is 1.3x over 770

              Windows space needed: 50GB
              Linux space needed: 67GB
              WTF?! Why is the Linux version 33% larger?
              Last edited by Licaon; 02-16-2017, 06:02 PM.

              Comment


              • #8
                Michael

                Where you get these requirements from?

                Feral recommends at least a GeForce 600 series GPU, Radeon HD 6000 series or newer, or Intel Iris Pro.
                Originally posted by Licaon View Post
                WTF?! Why is the Linux version 33% larger?
                Probably because it known even to the Feral that port is 30%ish slower Basically you raise requirements and fix and issue, so you are informed before buying that port require more, so no one could complain after as it is known it is slower, etc...

                That kind of logic i guess
                Last edited by dungeon; 02-16-2017, 06:12 PM.

                Comment


                • #9
                  Feral recommends at least a GeForce 600 series GPU, Radeon HD 6000 series
                  No, they don't.

                  There's a big difference between what Michael said (600 series), and the actual minimum Feral give of a 680. Please, Michael, in future be more clear.

                  Comment


                  • #10
                    Originally posted by gutigone View Post
                    No, they don't.

                    There's a big difference between what Michael said (600 series), and the actual minimum Feral give of a 680. Please, Michael, in future be more clear.
                    Article also say "Intel Iris Pro" supported, while on Feral site "Intel GPUs are not supported at this time."

                    Probably OK... Michael probably wrongly copy/pasted something else

                    Comment

                    Working...
                    X