Announcement

Collapse
No announcement yet.

ARB_enhanced_layouts Lands In Mesa Git, Rounds Out OpenGL 4.4 For RadeonSI

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • #11
    For those that are interested:
    https://www.khronos.org/adopters

    Comment


    • #12
      Ah that is cheap, Vulkan is most expensive

      Comment


      • #13
        With all that money, how are the open source projects supposed to get compliant?
        Intel could flip the bill for their drivers. What foundation or donor company is flipping the bill for the rest of Mesa?

        Comment


        • #14
          Well, soon mesamatrix should show an all-green on radeonsi. Neat, very neat. The only bad thing about this is that I lack money to get myself a real card (Polaris) that uses mesa radeonsi. Til then I'll enjoy OpenGL 4.5 soon on my Kabinis... ;-)
          I still hope that I'll have the money once Vega hits the markets.
          Stop TCPA, stupid software patents and corrupt politicians!

          Comment


          • #15
            Originally posted by lunarcloud View Post
            What foundation or donor company is flipping the bill for the rest of Mesa?
            I can only bet that last one will be Microsoft to pay for conformant Nine

            Comment


            • #16
              I'm still getting OpenGL 4.3 with my R7 360.
              Code:
              Extended renderer info (GLX_MESA_query_renderer):
                  Vendor: X.Org (0x1002)
                  Device: AMD BONAIRE (DRM 2.45.0 / 4.7.7, LLVM 4.0.0) (0x665f)
                  Version: 12.1.0
                  Accelerated: yes
                  Video memory: 2048MB
                  Unified memory: no
                  Preferred profile: core (0x1)
                  Max core profile version: 4.3
                  Max compat profile version: 3.0
                  Max GLES1 profile version: 1.1
                  Max GLES[23] profile version: 3.1
              OpenGL vendor string: X.Org
              OpenGL renderer string: Gallium 0.4 on AMD BONAIRE (DRM 2.45.0 / 4.7.7, LLVM 4.0.0)
              OpenGL core profile version string: 4.3 (Core Profile) Mesa 12.1.0-devel (git-e6a693c)
              OpenGL core profile shading language version string: 4.30
              However, this changes to 4.4 if I force GLSL to 4.40.
              Code:
              Extended renderer info (GLX_MESA_query_renderer):
                  Vendor: X.Org (0x1002)
                  Device: AMD BONAIRE (DRM 2.45.0 / 4.7.7, LLVM 4.0.0) (0x665f)
                  Version: 12.1.0
                  Accelerated: yes
                  Video memory: 2048MB
                  Unified memory: no
                  Preferred profile: core (0x1)
                  Max core profile version: 4.4
                  Max compat profile version: 3.0
                  Max GLES1 profile version: 1.1
                  Max GLES[23] profile version: 3.1
              OpenGL vendor string: X.Org
              OpenGL renderer string: Gallium 0.4 on AMD BONAIRE (DRM 2.45.0 / 4.7.7, LLVM 4.0.0)
              OpenGL core profile version string: 4.4 (Core Profile) Mesa 12.1.0-devel (git-e6a693c)
              OpenGL core profile shading language version string: 4.40

              Comment


              • #17
                Originally posted by chrisr View Post
                I'm still getting OpenGL 4.3 with my R7 360.
                As was mentioned, the driver can't claim 4.4 or higher support until it has passed the OGL CTS.

                Comment


                • #18
                  Originally posted by agd5f View Post

                  As was mentioned, the driver can't claim 4.4 or higher support until it has passed the OGL CTS.
                  I think that should be "AMD is choosing not to claim 4.4 or higher support until it has passed the OGL CTS."

                  And Intel is doing the same, apparently. I highly doubt Nouveau or any community developed driver is going to hold off on tests they can't afford to get access to.

                  Comment


                  • #19
                    Originally posted by agd5f View Post
                    As was mentioned, the driver can't claim 4.4 or higher support until it has passed the OGL CTS.
                    Ah, sorry. As I read the article, I assumed that only OpenGL 4.5 couldn't be advertised yet.

                    Comment


                    • #20
                      Code:
                      $ MESA_GLSL_VERSION_OVERRIDE=450 glxinfo
                      ...
                      Extended renderer info (GLX_MESA_query_renderer):
                          Vendor: X.Org (0x1002)
                          Device: AMD BONAIRE (DRM 2.45.0 / 4.7.7, LLVM 4.0.0) (0x665f)
                          Version: 12.1.0
                          Accelerated: yes
                          Video memory: 2048MB
                          Unified memory: no
                          Preferred profile: core (0x1)
                          Max core profile version: 4.5
                          Max compat profile version: 3.0
                          Max GLES1 profile version: 1.1
                          Max GLES[23] profile version: 3.1
                      OpenGL vendor string: X.Org
                      OpenGL renderer string: Gallium 0.4 on AMD BONAIRE (DRM 2.45.0 / 4.7.7, LLVM 4.0.0)
                      OpenGL core profile version string: 4.5 (Core Profile) Mesa 12.1.0-devel (git-e6a693c)
                      OpenGL core profile shading language version string: 4.50
                      ...
                      Yay!

                      Comment

                      Working...
                      X