Announcement

Collapse
No announcement yet.

Grand Theft Auto Running On Direct3D Natively On Linux Shows Gallium3D Potential

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • #91
    Originally posted by LiquidAcid View Post
    Check if you've set a offloadsink and if that doesn't help, file a bugreport.

    How can I forget so quickly?

    Anyway, it does work, so yea, thanks.

    Comment


    • #92
      So in general DRI2 PRIME works, but as others have said with nine it doesn't. I tried skyrim and the fullscreen window just doesn't display skyrim. Interestingly if I have two screens enabled, it renders a garbled copy of the second screen in the skyrim fullscreen window with a few seconds delay. But the GPU is working at 25% according to radeontop, so maybe it would actually render the right thing, if it was displayed, I don't know but probably not, since it didn't get to the menu music. At my first try I did get to the music, but then I had hyperz enabled (which doesn't crash with wine+skyrim+opengl) and got a hard lockup of the whole system after a few seconds.

      Comment


      • #93
        Marek,

        normal Wine did crash because I did change SI_NUM_VERTEX_BUFFERS to 32 in si_state.h.

        With nine, I get that error with SI_NUM_VERTEX_BUFFERS = 32 :
        Code:
        ....
        LLVM triggered Diagnostic Handler: SIInstrInfo::storeRegToStackSlot - Can't spill VGPR!
        LLVM triggered Diagnostic Handler: SIInstrInfo::loadRegToStackSlot - Can't retrieve spilled VGPR!
        LLVM triggered Diagnostic Handler: SIInstrInfo::storeRegToStackSlot - Can't spill VGPR!
        LLVM triggered Diagnostic Handler: SIInstrInfo::loadRegToStackSlot - Can't retrieve spilled VGPR!
        radeon_llvm_compile: Processing Diag Flag
        LLVM failed to compile shader
        EE si_state.c:2195 si_shader_select - Failed to build shader variant (type=1) 1
        fixme:wtsapi:WTSRegisterSessionNotification Stub 0x1005e 0x00000000

        Comment


        • #94
          Originally posted by Pontostroy View Post
          unigine valley (wine nine,opengl,wined3d) vs native opengl
          http://www.gearsongallium.com/?p=1406

          nine - 985
          opengl - 937
          wd3d - 482
          native - 940
          Pretty cool test! Any chance you can benchmark Wine with CSMT?

          Comment


          • #95
            I packaged gallium-nine for Ubuntu, see here.

            Comment


            • #96
              Originally posted by Pontostroy View Post
              unigine valley (wine nine,opengl,wined3d) vs native opengl
              http://www.gearsongallium.com/?p=1406

              nine - 985
              opengl - 937
              wd3d - 482
              native - 940
              I wonder how fast D3D9 on Windows would be on your PC with the same settings. Looks like it's a +100% speed up for D3D on Wine.

              Comment


              • #97
                Originally posted by Pontostroy View Post
                Does it run with noveau only or also with r600/radeonSI?

                can this be mixed with your mesa from http://download.opensuse.org/reposit...SUSE_Factory/?

                should one of them get a higher priority?
                Last edited by tomtomme; 01 August 2014, 09:09 AM.

                Comment


                • #98
                  Originally posted by tomtomme View Post
                  Does it run with noveau only or also with r600/radeonSI?

                  can this be mixed with your mesa from http://download.opensuse.org/reposit...SUSE_Factory/?

                  should one of them get a higher priority?
                  More specifically: Did someone test this with HD 7950 radeonSI?

                  Comment


                  • #99
                    Originally posted by tomtomme View Post
                    Does it run with noveau only or also with r600/radeonSI?

                    can this be mixed with your mesa from http://download.opensuse.org/reposit...SUSE_Factory/?

                    should one of them get a higher priority?
                    On r600 gallium-nine works, on radeonsi i got segfaults.

                    Must be mixed with http://download.opensuse.org/reposit...ntostroy:/X11/ (mesa and wine from homeontostroy:branches:homeontostroy:X11 all other packages from pontostroy:X11 )
                    For now mesa in pontostroy:/X11/openSUSE_Factory can be broken, i switched to llvm 3.6 but OBS rebuild packages for factory very slow.

                    Comment


                    • Originally posted by Pontostroy View Post
                      On r600 gallium-nine works, on radeonsi i got segfaults.

                      Must be mixed with http://download.opensuse.org/reposit...ntostroy:/X11/ (mesa and wine from homeontostroy:branches:homeontostroy:X11 all other packages from pontostroy:X11 )
                      For now mesa in pontostroy:/X11/openSUSE_Factory can be broken, i switched to llvm 3.6 but OBS rebuild packages for factory very slow.
                      Thanks for the info.
                      If I can help by testing wine-nine on my hardware (HD 7950) let me know. I do not own GTA, but could test a bunch of other steam-games.

                      Anyway, I?ll wait until you can confirm your main mesa-repo working again :P
                      And until then I?ll switch from tumbleweed to this fresh rolling factory with good old llvm3.4

                      Comment

                      Working...
                      X