Announcement

Collapse
No announcement yet.

AMD Publishes New OpenGL 4.4 Extensions

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • AMD Publishes New OpenGL 4.4 Extensions

    Phoronix: AMD Publishes New OpenGL 4.4 Extensions

    AMD published two new OpenGL extensions today that the graphics giant has developed...

    http://www.phoronix.com/vr.php?view=MTY1MzY

  • #2
    I do not see either of those extensions here:

    http://cgit.freedesktop.org/mesa/mesa/tree/docs/GL3.txt

    Comment


    • #3
      Originally posted by halfmanhalfamazing View Post
      I do not see either of those extensions here:

      http://cgit.freedesktop.org/mesa/mesa/tree/docs/GL3.txt
      Um, maybe because they were just published and are nowhere close to being in core yet?

      Comment


      • #4
        Originally posted by halfmanhalfamazing View Post
        I do not see either of those extensions here:

        http://cgit.freedesktop.org/mesa/mesa/tree/docs/GL3.txt
        That link doesn't list any extensions at all, unless they are in the core profile - and therefore approved by amd, nvidia, and everyone else in the khronos group.

        So what's your point?

        If anyone was going to post some snark here, i thought it would be that fglrx doesn't even support 4.4 yet, and they are already working on extensions based on that spec rather than the 4.3 version they do support.

        Comment


        • #5
          The misunderstanding is mine - I thought these were a part of OpenGL 4.4.

          Comment


          • #6
            Originally posted by halfmanhalfamazing View Post
            The misunderstanding is mine - I thought these were a part of OpenGL 4.4.
            Nope, they are based off of OpenGL 4.4. You could implement them prior to OpenGL 4.4 support, but if AMD says "OpenGL 4.4" then there's gotta be SOME reason they picked it. Maybe the extensions are based off of existing 4.4 extensions? Maybe there's some assumption that only holds true on 4.4+ systems? Or maybe they just only tested it against a 4.4 conforming driver, who knows.

            Comment


            • #7
              Actualy the first extension requires OpenGL 4.0 while the second only requires transform_feedback3 so it could be implemented on top of existing mesa. The fact that it's writen against 4.4 means that they took into account interactions with all the extensions mandated by OpenGL 4.4 (core)

              Comment

              Working...
              X