Announcement

Collapse
No announcement yet.

How to contact MESA devs on some pesky performance bug?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • tarceri
    replied
    I already explained what you need to do. Install Fedora 19 or 20 and downgrade Mesa to 9.1 and see if you still have a problem.

    Here is a step by step guide:
    ------------------------------------------------------------------
    Install git:
    $ yum install git

    Clone the Mesa repository:
    $ git clone git://anongit.freedesktop.org/mesa/mesa

    Chekout the 9.1 branch:
    $ git checkout 9.1

    You may need to install some build dependencies. I needed to install this:
    $ sudo yum-builddep mesa

    Rather than overwrite your distros Mesa install it is recommended you create a new directory. The one we will be using is /opt/xorg this way you can switch back to a stable version of Mesa.

    Configure and build Mesa
    $ ./autogen.sh --prefix=/opt/xorg --enable-texture-float --with-dri-drivers="i965" --with-llvm-shared-libs --enable-debug --with-gallium-drivers=""
    $ make

    Install Mesa to the new directory you have created:
    $ make install

    Now configure your system to use the 9.1 version of Mesa you just built:

    First create a new text file:
    $ sudo gedit /etc/ld.so.conf.d/a-local-xorg.conf

    Add your mesa direcory (the line below) to the text file and save it:
    /opt/xorg/lib

    Then update /etc/environment to add new environment variable that tells libgl where to look for dri driver:
    $ sudo gedit /etc/environment

    Add the following line:
    LIBGL_DRIVERS_PATH=/opt/xorg/lib/dri/

    Then run ldconfig as root to update the linker cache to point to the version of mesa you just built.
    $ sudo ldconfig

    You can then check the version of Mesa using glxinfo
    $ glxinfo

    Now it it says you are using Mesa 9.1 restart your computer and tell us if you still see the issue with Gnome.
    --------------------------------------------------------------------------------------------------------------------------------------------------------------

    To switch back to the default version of Mesa just delete /etc/ld.so.conf.d/a-local-xorg.conf
    $ sudo rm /etc/ld.so.conf.d/a-local-xorg.conf

    and remove the line you added to the environment file and rerun ldconfig as root

    Leave a comment:


  • Bucic
    replied
    Still same. Gnome isolated as the culprit.

    Leave a comment:


  • Bucic
    replied

    Leave a comment:


  • Bucic
    replied
    Originally posted by archibald View Post
    Definitely. If you don't, who will?

    The developers will be able to give you instructions on what to try in order to track it down, or they will be able to give you pointers to the right place to look. In any case, you can come back here and ask for help if you're not sure of something that they're asking.
    By the looks of it many did (on redhat, freedesktop, gnome and other bugzillas) and they were given an indirect middle finger apparently.

    Well, for starters, if you're still here, you could tell me how to update MESA in one blow. Like I said - I'll install Fedora 17 and confirm the culprit is in MESA by updating just this component. So, is
    Code:
    su -c 'yum update mesa*'
    enough?

    Leave a comment:


  • archibald
    replied
    Originally posted by Bucic View Post
    Now, is there a point in not so savvy guy like me filing a bug report against a pet-bug that's been there for a year, despite affecting thousands of linux users (it doesn't usually bother linux devs, this much I know, see the 2.6+ kernel power issues galore)?
    Definitely. If you don't, who will?

    The developers will be able to give you instructions on what to try in order to track it down, or they will be able to give you pointers to the right place to look. In any case, you can come back here and ask for help if you're not sure of something that they're asking.

    Leave a comment:


  • Bucic
    replied
    There's virtually no point for me to digg into all of that. I'll just install a fresh Fedora 17 and update MESA. It should confirm what I've found out - it's yet another problem with some linux stack many people suffer from, and not fixed for many months. A sorry-ass petbug regarding tearing issues.
    I found it by looking up this CLUTTER_PAINT=disable-clipped-redraws:disable-culling, which has been proposed by someone in one of the Gnome tweak guides. Thanks to this line I've traced it down.




    Few days ago I got an update to the MESA 9.2. -Something- has changed for better but it's still not as good as it used to be, to say the least.

    Now, is there a point in not so savvy guy like me filing a bug report against a pet-bug that's been there for a year, despite affecting thousands of linux users (it doesn't usually bother linux devs, this much I know, see the 2.6+ kernel power issues galore)?
    Last edited by Bucic; 25 September 2013, 06:25 PM.

    Leave a comment:


  • Bucic
    replied
    Thank you!

    Leave a comment:


  • tarceri
    replied
    Originally posted by Bucic View Post
    Thank you! Will try. Just to make sure - the first thing I need to check is:
    problem goes away with older* mesa installed => it is caused by mesa ?
    (otherwise - it's not mesa to blame)
    *e.g. from fedora 17 times
    Yes thats right. I would try finding out what the version on Mesa was used in Fedora 18 before you saw the bug.
    typing glxinfo in the command line should tell you this. Then I would try using that version under Fedora 19. I didnt look at your videos so I'm now sure exacly sure what the issue you were having was. I assumed it was laggyness with the Gnome shell in which case it could have been an update to Gnome that is causing the slowdown or something else in between. Anyway the first step should be to rule out or confirm if its a Mesa issue.

    Good luck.

    Leave a comment:


  • Bucic
    replied
    Thank you! Will try. Just to make sure - the first thing I need to check is:
    problem goes away with older* mesa installed => it is caused by mesa ?
    (otherwise - it's not mesa to blame)
    *e.g. from fedora 17 times

    I'd like to pint out one more thing. You told me to try it on my own BUT you provided me with an overview I can follow. This aspect is often neglected, both in "try to do it yourself" and in "here are instructions on how to do it" situations.

    Leave a comment:


  • tarceri
    replied
    Originally posted by Bucic View Post
    Thank you for answering my call.

    What I did so far was:

    Aaand 18+updates - not smooth.

    It's lame, I know. I'm afraid isolating the commit to blame is beyond my skills. As far as I remember setting up a github tree (?, to install some program from sources available there) was beyond my reach.
    The only way to improve your skills it to give it a go. There is a lot of people in these forums that can help with questions you might have along the way. But if you dont put in some effort I doubt the devs will go to much effort for you. You said you would be happy to put some hours into this.

    To start you off. Install git using yum then create a directory call git_repos in your home dir somewhere and type this: git clone git://anongit.freedesktop.org/mesa/mesa

    This will download a clone of the git repository to your pc. Then follow my instructions in my first post. You may need to google some stuff (or ask here) if you dont understand but its all part of learning. I think in the end you will be surprised how easy it is.
    Last edited by tarceri; 18 September 2013, 05:00 PM.

    Leave a comment:

Working...
X