Announcement

Collapse
No announcement yet.

Mesa 7.11 Release Candidate 1 Arrives

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • phoronix
    started a topic Mesa 7.11 Release Candidate 1 Arrives

    Mesa 7.11 Release Candidate 1 Arrives

    Phoronix: Mesa 7.11 Release Candidate 1 Arrives

    While this is non-news for many Phoronix readers that are Mesa Git followers and already onto tracking Mesa 7.12-devel after using Mesa 7.11-devel for months already, for everyone else, the first release candidate of Mesa 7.11 is now available...

    http://www.phoronix.com/vr.php?view=OTY1MA

  • bwat47
    replied
    Does this have any good changes for intel graphics? (i'm running ironlake on arch linux, so I will probably get this not too long after it goes stable)

    Leave a comment:


  • ahlaht
    replied
    Originally posted by kraftman View Post
    Thanks, but it was easier than I thought. I had to change CPU scaling governor from ondemand to performance and OpenArena just flies.
    Thanks, that's very useful information. Just yesterday I noticed I may also have that problem. At least there is something shady about it. I didn't properly test it yet, because I also found some other bugs (sigh). I wonder if there is never end to these bugs...

    Leave a comment:


  • kraftman
    replied
    Originally posted by ahlaht View Post
    Right. With only 1 power state the file is disabled.
    Thanks, but it was easier than I thought. I had to change CPU scaling governor from ondemand to performance and OpenArena just flies.

    Leave a comment:


  • 69acid69
    replied
    can't compile r300g with latest LLVM!

    Hi,

    for a few weeks I can't compile r300g drivers, using latest LLVM 3.0 (2.9.99.svn20110711-32.1). At the end of compiling I've got error message like this:
    r300_dri.so.tmp: undefined reference to `LLVMAddTypeName'

    So, any patch or help!?

    Thanks.

    Leave a comment:


  • ahlaht
    replied
    Originally posted by kraftman View Post
    then it doesn't work.
    Right. With only 1 power state the file is disabled. But you could still enable it if you wanted. Just move these 3 lines:

    Code:
    diff --git a/drivers/gpu/drm/radeon/radeon_pm.c b/drivers/gpu/drm/radeon/radeon_pm.c
    index aaa19dc..d3ef691 100644
    --- a/drivers/gpu/drm/radeon/radeon_pm.c
    +++ b/drivers/gpu/drm/radeon/radeon_pm.c
    @@ -608,6 +608,10 @@ int radeon_pm_init(struct radeon_device *rdev)
    
            INIT_DELAYED_WORK(&rdev->pm.dynpm_idle_work, radeon_dynpm_idle_work_handler);
    
    +       if (radeon_debugfs_pm_init(rdev)) {
    +               DRM_ERROR("Failed to register debugfs file for PM!\n");
    +       }
    +
            if (rdev->pm.num_power_states > 1) {
                    /* where's the best place to put these? */
                    ret = device_create_file(rdev->dev, &dev_attr_power_profile);
    @@ -621,10 +625,6 @@ int radeon_pm_init(struct radeon_device *rdev)
                    rdev->acpi_nb.notifier_call = radeon_acpi_event;
                    register_acpi_notifier(&rdev->acpi_nb);
     #endif
    -               if (radeon_debugfs_pm_init(rdev)) {
    -                       DRM_ERROR("Failed to register debugfs file for PM!\n");
    -               }
    -
                    DRM_INFO("radeon: power management initialized\n");
            }
    If you try this be prepared for a crash once you read the file, but I suspect it has been disabled unnecessarily.

    Leave a comment:


  • kraftman
    replied
    Originally posted by ahlaht View Post
    It should be enough if your kernel has CONFIG_DEBUG_FS=y.
    Yes, the option is enabled.

    Leave a comment:


  • ahlaht
    replied
    Originally posted by kraftman View Post
    If it's enough to do: mount -t debugfs none /sys/kernel/debug

    then it doesn't work. I suppose my graphic card doesn't support the feature.
    It should be enough if your kernel has CONFIG_DEBUG_FS=y.

    From what I remember from the code I think radeon_pm_info should be available even if power management is disabled. (But I might be wrong too.)

    Leave a comment:


  • kraftman
    replied
    Originally posted by whizse View Post
    Make sure you have debugfs mounted.
    If it's enough to do: mount -t debugfs none /sys/kernel/debug

    then it doesn't work. I suppose my graphic card doesn't support the feature.

    Leave a comment:


  • whizse
    replied
    Originally posted by kraftman View Post
    Thanks, but it seems I don't have such option - there's no such file or directory
    Make sure you have debugfs mounted.

    Leave a comment:

Working...
X