Announcement

Collapse
No announcement yet.

Updated and Optimized Ubuntu Free Graphics Drivers

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Originally posted by questioneer View Post
    thanks for the packages for precise.

    whats the reason that the new xserver-xorg-video packages are hold back?
    Time and motivation to work on something I don't use (I am still on natty).

    Comment


    • Originally posted by oibaf View Post
      Time and motivation to work on something I don't use (I am still on natty).

      uhm sorry, did i sound rude or something? wasnt meant that way. i was just curious if this was just some kind of bug on my system or if it was meant to be that way.

      Comment


      • Originally posted by questioneer View Post
        uhm sorry, did i sound rude or something? wasnt meant that way. i was just curious if this was just some kind of bug on my system or if it was meant to be that way.
        No problem, I pushed them now, so precise is completely supported now.

        Comment


        • Originally posted by unknown2 View Post
          Hi oibaf,

          is is possible to test this bug?

          https://bugs.freedesktop.org/show_bug.cgi?id=45880

          "in mesa, src/gallium/winsys/radeon/drm/radeon_drm_winsys.c
          change all assignments of r600_virtual_address to FALSE
          ws->info.r600_virtual_address = FALSE;"
          Version 8.1~git1202111943.c565ff~gd with that change is building now. Let me know what you get so that I can eventually revert it.

          Comment


          • i appreciate your efforts very much.

            thank you.

            Comment


            • Originally posted by oibaf View Post
              Version 8.1~git1202111943.c565ff~gd with that change is building now. Let me know what you get so that I can eventually revert it.
              downloaded and tested ok. i will not update my system for a while

              i hope that developer will not ask me to test any more workaround

              Comment


              • Hi, multiarch version (i386) of your packages on x86_64 system not working. Here is ouput from i386 glxinfo:

                Code:
                $ LIBGL_DEBUG=verbose ./glxinfo
                libGL: OpenDriver: trying /usr/lib/i386-linux-gnu/dri/tls/r600_dri.so
                libGL: OpenDriver: trying /usr/lib/i386-linux-gnu/dri/r600_dri.so
                libGL error: dlopen /usr/lib/i386-linux-gnu/dri/r600_dri.so failed (/usr/lib/i386-linux-gnu/dri/r600_dri.so: undefined symbol: radeon_surface_init)
                libGL: OpenDriver: trying /usr/lib/dri/tls/r600_dri.so
                libGL: OpenDriver: trying /usr/lib/dri/r600_dri.so
                libGL error: dlopen /usr/lib/dri/r600_dri.so failed (/usr/lib/dri/r600_dri.so: cannot open shared object file: No such file or directory)
                libGL: OpenDriver: trying /usr/lib/i386-linux-gnu/dri-alternates/tls/r600_dri.so
                libGL: OpenDriver: trying /usr/lib/i386-linux-gnu/dri-alternates/r600_dri.so
                libGL error: dlopen /usr/lib/i386-linux-gnu/dri-alternates/r600_dri.so failed (/usr/lib/i386-linux-gnu/dri-alternates/r600_dri.so: cannot open shared object file: No such file or directory)
                libGL: OpenDriver: trying /usr/lib/dri-alternates/tls/r600_dri.so
                libGL: OpenDriver: trying /usr/lib/dri-alternates/r600_dri.so
                libGL error: dlopen /usr/lib/dri-alternates/r600_dri.so failed (/usr/lib/dri-alternates/r600_dri.so: cannot open shared object file: No such file or directory)
                libGL: OpenDriver: trying /usr/lib32/dri/tls/r600_dri.so
                libGL: OpenDriver: trying /usr/lib32/dri/r600_dri.so
                libGL error: dlopen /usr/lib32/dri/r600_dri.so failed (/usr/lib32/dri/r600_dri.so: undefined symbol: _mesa_enable_imaging_extensions)
                libGL: OpenDriver: trying /usr/lib32/dri-alternates/tls/r600_dri.so
                libGL: OpenDriver: trying /usr/lib32/dri-alternates/r600_dri.so
                libGL error: dlopen /usr/lib32/dri-alternates/r600_dri.so failed (/usr/lib32/dri-alternates/r600_dri.so: cannot open shared object file: No such file or directory)
                libGL error: unable to load driver: r600_dri.so
                libGL error: driver pointer missing
                libGL error: failed to load driver: r600
                libGL: OpenDriver: trying /usr/lib/i386-linux-gnu/dri/tls/swrast_dri.so
                libGL: OpenDriver: trying /usr/lib/i386-linux-gnu/dri/swrast_dri.so
                ...
                OpenGL vendor string: VMware, Inc.
                OpenGL renderer string: Gallium 0.4 on llvmpipe (LLVM 0x209)
                OpenGL version string: 2.1 Mesa 8.0-devel (git-c565ff6 oneiric-oibaf-ppa)
                OpenGL shading language version string: 1.20
                ...
                I have correctly installed both 64 and 32bit packages, 64bit version working, but 32bit not.

                Comment


                • the drivers wont work on precise anymore, cause they depend on the virtual package xorg-video-abi-11
                  but the xserver on xorg-edgers only provides xorg-video-abi-12 and 16

                  Comment


                  • Originally posted by unknown2 View Post
                    downloaded and tested ok. i will not update my system for a while

                    i hope that developer will not ask me to test any more workaround
                    Hi oibaf.

                    the developer provide a fix now.

                    http://cgit.freedesktop.org/mesa/mes...31cd66d1b53e23
                    https://bugs.freedesktop.org/show_bug.cgi?id=45880

                    Can you rollback the virtual address workaround and merge the fix? thank you

                    Comment


                    • Originally posted by pali View Post
                      Hi, multiarch version (i386) of your packages on x86_64 system not working. Here is ouput from i386 glxinfo:

                      Code:
                      $ LIBGL_DEBUG=verbose ./glxinfo
                      libGL: OpenDriver: trying /usr/lib/i386-linux-gnu/dri/tls/r600_dri.so
                      libGL: OpenDriver: trying /usr/lib/i386-linux-gnu/dri/r600_dri.so
                      libGL error: dlopen /usr/lib/i386-linux-gnu/dri/r600_dri.so failed (/usr/lib/i386-linux-gnu/dri/r600_dri.so: undefined symbol: radeon_surface_init)
                      libGL: OpenDriver: trying /usr/lib/dri/tls/r600_dri.so
                      libGL: OpenDriver: trying /usr/lib/dri/r600_dri.so
                      libGL error: dlopen /usr/lib/dri/r600_dri.so failed (/usr/lib/dri/r600_dri.so: cannot open shared object file: No such file or directory)
                      libGL: OpenDriver: trying /usr/lib/i386-linux-gnu/dri-alternates/tls/r600_dri.so
                      libGL: OpenDriver: trying /usr/lib/i386-linux-gnu/dri-alternates/r600_dri.so
                      libGL error: dlopen /usr/lib/i386-linux-gnu/dri-alternates/r600_dri.so failed (/usr/lib/i386-linux-gnu/dri-alternates/r600_dri.so: cannot open shared object file: No such file or directory)
                      libGL: OpenDriver: trying /usr/lib/dri-alternates/tls/r600_dri.so
                      libGL: OpenDriver: trying /usr/lib/dri-alternates/r600_dri.so
                      libGL error: dlopen /usr/lib/dri-alternates/r600_dri.so failed (/usr/lib/dri-alternates/r600_dri.so: cannot open shared object file: No such file or directory)
                      libGL: OpenDriver: trying /usr/lib32/dri/tls/r600_dri.so
                      libGL: OpenDriver: trying /usr/lib32/dri/r600_dri.so
                      libGL error: dlopen /usr/lib32/dri/r600_dri.so failed (/usr/lib32/dri/r600_dri.so: undefined symbol: _mesa_enable_imaging_extensions)
                      libGL: OpenDriver: trying /usr/lib32/dri-alternates/tls/r600_dri.so
                      libGL: OpenDriver: trying /usr/lib32/dri-alternates/r600_dri.so
                      libGL error: dlopen /usr/lib32/dri-alternates/r600_dri.so failed (/usr/lib32/dri-alternates/r600_dri.so: cannot open shared object file: No such file or directory)
                      libGL error: unable to load driver: r600_dri.so
                      libGL error: driver pointer missing
                      libGL error: failed to load driver: r600
                      libGL: OpenDriver: trying /usr/lib/i386-linux-gnu/dri/tls/swrast_dri.so
                      libGL: OpenDriver: trying /usr/lib/i386-linux-gnu/dri/swrast_dri.so
                      ...
                      OpenGL vendor string: VMware, Inc.
                      OpenGL renderer string: Gallium 0.4 on llvmpipe (LLVM 0x209)
                      OpenGL version string: 2.1 Mesa 8.0-devel (git-c565ff6 oneiric-oibaf-ppa)
                      OpenGL shading language version string: 1.20
                      ...
                      I have correctly installed both 64 and 32bit packages, 64bit version working, but 32bit not.
                      Does reverting to official ubuntu packages work?

                      Comment

                      Working...
                      X