No announcement yet.

Updated and Optimized Ubuntu Free Graphics Drivers

  • Filter
  • Time
  • Show
Clear All
new posts

  • oscar Done
    Roza Edalb I should have be fixed it, but cannot upload any more packages since the PPA is full. Retry updating tomorrow...


    • Sure thanks😉👍 oibaf


      • Originally posted by Roza Edalb View Post
        Sure thanks😉👍 oibaf
        Pushed the fix, can try again? Thanks


        • oibaf Oh I'm so sorry man. Thank you so much for fixing it but unfortunately I am not at home right now and won't be for some time. Can anyone else kindly try the fix?


          • I was experiencing the symtpoms here yesterday evening, but this morning I was able to
            apt --fix-broken install
            to resolve.

            Thank you for the fix


            • I wanted to get back to you about my graphics problem. I was able to solve it, but there are still some unanswered questions about how it could happen.

              I also removed the PPA and used the default driver, but the error still remained.

              Backed up my entire home directory. I reinstalled the system and the error did not occur. I copied my backed up home directory back to my home directory, but the error occurred again after booting. I deleted the file ~/.config/xfce4/xfconf/xfce-perchannel-xml/displays.xml, the error was still there.

              I also tried to delete the complete config directory, the error still remained after booting.

              After I copied my home directory manually, i.e. config, local and other files, it worked. I did not copy all the files I had backed up into my home directory, because otherwise the error would probably have occurred again.

              I can only explain that some update had a bug and changed a file.​


              • Originally posted by oibaf View Post

                Pushed the fix, can try again? Thanks
                Also I got home yesterday and updated it again like msfisher here and it works, thanks for the fix oibaf !


                • Originally posted by lorn10 View Post
                  Roza Edalb
                  Last Wine version which had worked on non-OGL2 compliant hardware was most likely Wine 4.0. This is confirmed in this thread here, - it's in German.

                  Wine 5.0 and upwards seems to require at least OGL 2 compatible hardware. So as said, your GMA 950 is simply too old. And playing around with the d3d9.dll file is also not helpful. What would theoretically resolve the problem would be a Shader 2.0 compliant version of Gallium Nine. This would allow you to use Direct3D directly from Linux without WineD3D.

                  However, the support for Shader model 2.0​ hardware was long ago dropped from Gallium Nine because nobody has such old stuff in use. Ergo Gallium Nine needs at least a Shader 3.0 (​OGL 2) compatible GPU and even with that class hardware it currently doesn't work well because most "vintage" Linux drivers are not fully adjusted to work with it.
                  @Iorn10, Hello! It's been some time and I hope you're doing well.

                  I've followed your steps, installed wine staging 3.12 version from the commendsarnex ppa. It didn't work except from enhancing the performance a bit and making the Direct3D9 test box in dxdiag look normal.

                  The games run as usual with the same dark contrast.

                  I then installed the wine-d3d9 package(wine4.0) again from the same sarnex ppa. Same results. I then enabled gallium nine and got the error, this error also happens whenever I try to enable gallium nine via wine staging or the standalone package and try to run a game via the command line.

                  Here is the error: gpureport2.txt

                  Gallium nine switches to dri2 upon lack of dri3. Incase you forgot I already enabled the option for dri3 via the 20-intel.conf file. Also the "export Mesa" commands you've told me some posts ago were also active while my PC was running.

                  I guess this means it's the end of the road, eh?
                  Attached Files
                  Last edited by Roza Edalb; 13 August 2023, 07:04 AM.


                  • Roza Edalb
                    Yes, it really looks that this is somehow the end of the road. I simply don't see any more options for that old hardware. It is not even capable to use OGL2 and also not Gallium Nine. If a downgrade to Wine 4.x doesn't help then you are out of luck.


                    • @Iorn10 I apologize deeply for the late reply, but thanks for everything. You've been of great help to me. I guess I have no choice but to buy new hardware, I'll plan to buy sometime in the near future.
                      Thanks again