Announcement

Collapse
No announcement yet.

Updated and Optimized Ubuntu Free Graphics Drivers

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Originally posted by oscar View Post
    thanks for enabling d3d12 stuff!
    sorry for asking again but can reconsider now enabling dozen?
    I don't have time to look at it, but patches are welcome!

    Comment


    • Hi,
      oibaf where/how to send patches?
      also do you plan enabling new "rusticl" OpenCL 3.0 driver on oibaf builds?
      (https://www.phoronix.com/news/Mesa-22.3-Rusticl-Merged) seems supports even images, never supported by Clover..

      Comment


      • Originally posted by oscar View Post
        Hi,
        oibaf where/how to send patches?
        also do you plan enabling new "rusticl" OpenCL 3.0 driver on oibaf builds?
        (https://www.phoronix.com/news/Mesa-22.3-Rusticl-Merged) seems supports even images, never supported by Clover..


        Hi, I am a bit busy lately, so I don't have time to look at rusticl myself​.
        You can send patches using to mail (see changelogs of the package), or posting on pastebin or similar and link it there.
        I already had a look at enabling d3d12 (but it was missing something IIRC), you'll find some commented code in my package source.

        Comment


        • Hi,
          no problem thanks.. I'm lazy these days, but will probably try to test rusticl by building myself and providing patches after that..
          also sorry for asking too many things lately but asked for llvmpipe /lavapipe atomic float extensions support.. and has been merged (https://cgit.freedesktop.org/mesa/me...a8eb181173787c) but requires LLVM >=15.0..
          are you updating your builds to LLVM 15.0(.1?) soon?
          thanks..

          Comment


          • I'll update llvm to 15 probably the first days of October.

            Comment


            • Updated mesa with llvm 15, only on kinetic, because Canonical won't build llvm 15 on i386 / jammy. Hopefully they'll enable it (it usually happens after some time), than I could use llvm 15 also on jammy.

              Comment


              • oibaf
                Please update libva to a newer version. It is still at 2.12.0 and latest is 2.16.0. This is super important for the crocus driver because VA-API support is only available in 2.14.0 and newer. Thanks!

                Currently I have (at my Radeon GPU):
                HTML Code:
                [email protected]:~$ vainfo
                libva info: VA-API version 1.14.0
                libva info: Trying to open /usr/lib/x86_64-linux-gnu/dri/r600_drv_video.so
                libva info: Found init function __vaDriverInit_1_14
                libva info: va_openDriver() returns 0
                vainfo: VA-API version: 1.14 (libva 2.12.0)
                vainfo: Driver version: Mesa Gallium driver 22.3.0-devel for AMD TURKS (DRM 2.50.0 / 5.15.0-50-generic, LLVM 14.0.6)
                vainfo: Supported profile and entrypoints
                     VAProfileMPEG2Simple            : VAEntrypointVLD
                     VAProfileMPEG2Main              : VAEntrypointVLD
                     VAProfileVC1Simple              : VAEntrypointVLD
                     VAProfileVC1Main                : VAEntrypointVLD
                     VAProfileVC1Advanced            : VAEntrypointVLD
                     VAProfileH264ConstrainedBaseline: VAEntrypointVLD
                     VAProfileH264Main               : VAEntrypointVLD
                     VAProfileH264High               : VAEntrypointVLD
                     VAProfileNone                   : VAEntrypointVideoProc

                Comment


                • I have added libva 2.16 to kinetic.
                  I won't do it in jammy because since 2.15 there is this change:
                  * debian/libva2.symbols: Remove va_fool symbols
                  They are not used by any reverse dependency in the archive.​
                  which may don't break any Debian app, but someone already noticed it breaks Steam.

                  Comment


                  • ​Thanks for the answer. Final question, version 2.14 should work also in jammy aka 22.04, right? When ever possible please update the builds to this version because the next LTS version will be 24.04 so in quite a while. This will ensure that also all crocus users​ will have VA-API support until then.

                    Comment


                    • Originally posted by oibaf View Post
                      I have added libva 2.16 to kinetic.
                      I won't do it in jammy because since 2.15 there is this change:

                      which may don't break any Debian app, but someone already noticed it breaks Steam.
                      Ahhm, Debian unstable has libva 2.16, what is the problem with Steam? It is working here without any issue.

                      Comment

                      Working...
                      X