Announcement

Collapse
No announcement yet.

Updated and Optimized Ubuntu Free Graphics Drivers

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • I'm wrong about this PPA being the cause of the problem. Turns out it's because I use RealVNC to connect to my Linux machines and that prevents Wine from working. Soon as I disconnect from it, Wine works fine.

    Comment


    • Thanks for the update!

      Comment


      • Hello there, I'm seeking a bit of assistance with a problem that I've definitely created for myself. A while back I was trying to solve a problem with X on machine with new equipment. At some point I tried using the oibaf PPA for Ubuntu 18.04, but it didn't seem to solve the problem for me. At any rate, I removed the PPA but didn't do it properly (I didn't use ppa-purge). At any rate, I've just discovered in the course of trying to upgrade to the latest version of Ubuntu that my machine still has the oibaf driver installed, and I can't seem to remove it. Using "ppa-purge ppaibaf/graphics-drivers" doesn't work, the resulting message is "Warning: Could not find package list for PPA: oibaf graphics-drivers". I've tried reinstalling the PPA, but that doesn't seem to do anything.

        I'm wondering if perhaps part of the issue is that the bionic PPA has been removed? Nothing complained when I re-added the PPA, but that doesn't mean that any packages got added, I suppose. I've done a fair amount of searching and can't seem to find any answers that don't involve doing what I've already done.
        oibaf
        Senior Member
        oibaf I don't suppose you know of anything I could do to resolve this, do you? Does anyone else?

        Comment


        • Holiday greetings! Tell me where you can get oibaf packages for older versions of Ubuntu 16.04 LTS? (radeonSI)

          Really needed!




          Comment


          • Originally posted by oibaf View Post
            PPA also provides zink driver now.
            Do the ARM64 PPA packages provide it? I was just trying to test Zink on my Raspberry Pi, and the regular method of changing a program's driver is saying that it can't find zink_dri.so

            I love this PPA, by the way! Great work.

            Comment


            • Originally posted by mangeek View Post

              Do the ARM64 PPA packages provide it? I was just trying to test Zink on my Raspberry Pi, and the regular method of changing a program's driver is saying that it can't find zink_dri.so

              I love this PPA, by the way! Great work.
              Also added to arm*. Building now, try updating the packages in a hour or so...

              Comment


              • Originally posted by oibaf View Post

                Also added to arm*. Building now, try updating the packages in a hour or so...
                Thank you! Works beautifully!

                Comment


                • DFDFDFadfrt4rt
                  Junior Member
                  DFDFDFadfrt4rt
                  duggum
                  Junior Member
                  duggum
                  Only 20.04 and later are supported. If you still have installed older packages you need to play with dpkg to remove them and then reinstall the proper ones.

                  Comment


                  • Hi,

                    Just a heads up, I noticed that since some versions ago the oibaf mesa drivers does not support vaapi correctly, at least on my end. OBS will always fail with the following errors when trying to stream or record:

                    Code:
                    [h264_vaapi @ 0x558583d97e80] Driver does not support some wanted packed headers (wanted 0xd, found 0x1).
                    [h264_vaapi @ 0x558583d97e80] Failed to create encode pipeline configuration: 25 (an invalid/unsupported value was supplied).
                    warning: [FFMPEG VAAPI encoder: 'streaming_h264'] Failed to open VAAPI codec: Input/output error
                    My GPU is a Radeon Vega 56.

                    Comment


                    • Since editing is not available, I wanted to add some more things to my previous post:
                      1. My distro is Ubuntu 20.04.2 LTS x64.
                      2. I am however running the HWE 5.8.0 Low Latency kernel.
                      3. This is also happening on a second machine with a Navi-based Radeon RX 5600 GPU.

                      Comment

                      Working...
                      X