Announcement

Collapse
No announcement yet.

Updated and Optimized Ubuntu Free Graphics Drivers

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • I think there is an archive here: https://launchpad.net/~oibaf/+archiv...ld_state=built
    Also Ubuntu provides this newer mesa: https://packages.ubuntu.com/source/xenial-updates/mesa

    Comment


    • Originally posted by oibaf View Post
      I think there is an archive here: https://launchpad.net/~oibaf/+archiv...ld_state=built
      Also Ubuntu provides this newer mesa: https://packages.ubuntu.com/source/xenial-updates/mesa
      Thanks, but that's the version of mesa that's already used on travis. With those, libegl1-mesa-dev:i386 cannot be installed, because it depends on libxkbcommon-dev:i386 which conflicts with libxkbcommon-dev...

      I just used *cough* some force to work around it for now though... https://github.com/iXit/wine-nine-st...4d762f2d93932e

      Comment


      • It turns out that despite being in the Mesa sourcecode, the R200 driver is not a "valid" option with Meson, which is the cause of the RV200 not using radeon, as the driver simply isn't there (I had tried compiling Mesa on Solus).
        I had already posted a bug report about this.

        Comment


        • Originally posted by dhewg View Post

          Thanks, but that's the version of mesa that's already used on travis. With those, libegl1-mesa-dev:i386 cannot be installed, because it depends on libxkbcommon-dev:i386 which conflicts with libxkbcommon-dev...

          I just used *cough* some force to work around it for now though... https://github.com/iXit/wine-nine-st...4d762f2d93932e
          I didn't know the PPA was also used for this. Unfortunately I won't be able to reupload xenial packages. Nice that you found a workaround anyway.

          Comment


          • I'm getting this when I try to update. Why is that?

            Code:
            The following packages have been kept back:
            libegl-mesa0 libegl-mesa0:i386 libgbm1 libgbm1:i386 libgl1-mesa-dri:i386 libgl1-mesa-dri
            libgl1-mesa-glx:i386 libgl1-mesa-glx libglapi-mesa:i386 libglapi-mesa libglx-mesa0
            libglx-mesa0:i386 mesa-vulkan-drivers mesa-vulkan-drivers:i386

            Comment


            • Originally posted by Dukenukemx View Post
              I'm getting this when I try to update. Why is that?

              Code:
              The following packages have been kept back:
              libegl-mesa0 libegl-mesa0:i386 libgbm1 libgbm1:i386 libgl1-mesa-dri:i386 libgl1-mesa-dri
              libgl1-mesa-glx:i386 libgl1-mesa-glx libglapi-mesa:i386 libglapi-mesa libglx-mesa0
              libglx-mesa0:i386 mesa-vulkan-drivers mesa-vulkan-drivers:i386
              If you are on disco, the build is broken here, ATM.

              Comment


              • Originally posted by oibaf View Post

                If you are on disco, the build is broken here, ATM.
                Thanks, I already see it working again.

                Comment


                • Can you elaborate?

                  Comment


                  • mesa builds for disco still look broken:
                    sbuild-build-depends-mesa-dummy : Depends: libva-dev (>= 1.6.0) but it is not going to be installed

                    Comment


                    • Originally posted by ernstp View Post
                      mesa builds for disco still look broken:
                      sbuild-build-depends-mesa-dummy : Depends: libva-dev (>= 1.6.0) but it is not going to be installed
                      I know, but I don't have time to look at it. Working patches are welcome!

                      Comment

                      Working...
                      X