Announcement

Collapse
No announcement yet.

Updated and Optimized Ubuntu Free Graphics Drivers

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Originally posted by ernstp View Post
    mesa builds for disco still look broken:
    sbuild-build-depends-mesa-dummy : Depends: libva-dev (>= 1.6.0) but it is not going to be installed
    I know, but I don't have time to look at it. Working patches are welcome!

    Comment


    • Originally posted by oibaf View Post

      I know, but I don't have time to look at it. Working patches are welcome!
      You have a public git repo with scripts somewhere I can send a pull request or... ? Sorry if this is already posted somewhere, couldn't find the info.

      Comment


      • I don't have a public repo, the source is in the PPA.
        Open https://launchpad.net/~oibaf/+archiv...vers/+packages and click on the package, the source is under that.
        For example the latest mesa disco (failed build) is this: https://launchpad.net/~oibaf/+archiv...oibaf~d.tar.xz

        Thanks for your interest.

        Comment


        • Originally posted by oibaf View Post
          I don't have a public repo, the source is in the PPA.
          Open https://launchpad.net/~oibaf/+archiv...vers/+packages and click on the package, the source is under that.
          For example the latest mesa disco (failed build) is this: https://launchpad.net/~oibaf/+archiv...oibaf~d.tar.xz

          Thanks for your interest.
          I imagined a repo with you script to manage stuff and deltas and stuff. But right, a debdiff or something... Does it have to work for all b-c-d at the same time or just disco?

          Comment


          • Inside the xz there is a debian directory. I use the same source for disco, cosmic and bionic, just change the version number inside debian/changelog. (xenial required a different debian dir, but I no longer support it)
            It fails to build just on disco, but it builds fine on bionic and cosmic.

            Comment


            • The issue on disco is fixed now (with no PPA code change...).

              Comment


              • Originally posted by oibaf View Post
                The issue on disco is fixed now (with no PPA code change...).
                Great :-D

                Comment


                • Hi hope somebody can help me with my issue.
                  Ubuntu 18.10 (non-lts, normal) on top of ESXi box, RX590, gives messages
                  Code:
                  [    5.154978] amdgpu 0000:13:00.0: BAR 6: can't assign [??? 0x00000000 flags 0x20000000] (bogus alignment)
                  [    5.432083] amdgpu 0000:13:00.0: Direct firmware load for amdgpu/polaris10_k_mc.bin failed with error -2
                  lspci shows:
                  Code:
                  13:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Ellesmere [Radeon RX 470/480/570/570X/580/580X] (rev e1) (prog-if 00 [VGA controller])
                      Subsystem: Sapphire Technology Limited Nitro+ Radeon RX 580 4GB
                  Added this repository and nothing changed. Can't install AMDGPU-PRO as only 18.04 is supported.
                  Windows 10 is doing ok, recognizing as RX590.
                  Maybe I need to update amdgpu, haven't found how.

                  Comment


                  • So the fix was to upgrade to disco, great.

                    Comment


                    • Problem is, I dumped Ubuntu & installed Debian, latest firmware-amd package looks to be 15 days outdated in debian. Now it just shows black screen with mouse pointer.

                      Comment

                      Working...
                      X