Announcement

Collapse
No announcement yet.

Updated and Optimized Ubuntu Free Graphics Drivers

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • I am having same issues, the current set of packages is breaking the system

    I cant install 'wine' or 'crossover' i get these errors:

    libdrm-nouveau2 : Breaks: libdrm-nouveau2:i386 (!= 2.4.85+git1710271830.33dcc2~gd~x) but 2.4.85+git1710251830.61ff97~gd~x is to be installed.
    libdrm-nouveau2:i386 : Breaks: libdrm-nouveau2 (!= 2.4.85+git1710251830.61ff97~gd~x) but 2.4.85+git1710271830.33dcc2~gd~x is installed.
    libdrm-amdgpu1 : Breaks: libdrm-amdgpu1:i386 (!= 2.4.85+git1710271830.33dcc2~gd~x) but 2.4.85+git1710251830.61ff97~gd~x is to be installed.
    libdrm-amdgpu1:i386 : Breaks: libdrm-amdgpu1 (!= 2.4.85+git1710251830.61ff97~gd~x) but 2.4.85+git1710271830.33dcc2~gd~x is installed.
    libdrm2 : Breaks: libdrm2:i386 (!= 2.4.85+git1710271830.33dcc2~gd~x) but 2.4.85+git1710251830.61ff97~gd~x is to be installed.
    libdrm2:i386 : Breaks: libdrm2 (!= 2.4.85+git1710251830.61ff97~gd~x) but 2.4.85+git1710271830.33dcc2~gd~x is installed.
    libdrm-intel1 : Breaks: libdrm-intel1:i386 (!= 2.4.85+git1710271830.33dcc2~gd~x) but 2.4.85+git1710251830.61ff97~gd~x is to be installed.
    libdrm-intel1:i386 : Breaks: libdrm-intel1 (!= 2.4.85+git1710251830.61ff97~gd~x) but 2.4.85+git1710271830.33dcc2~gd~x is installed.
    libdrm-radeon1 : Breaks: libdrm-radeon1:i386 (!= 2.4.85+git1710271830.33dcc2~gd~x) but 2.4.85+git1710251830.61ff97~gd~x is to be installed.
    libdrm-radeon1:i386 : Breaks: libdrm-radeon1 (!= 2.4.85+git1710251830.61ff97~gd~x) but 2.4.85+git1710271830.33dcc2~gd~x is installed.

    Comment


    • libdrm-nouveau2 : Breaks: libdrm-nouveau2:i386 (!= 2.4.85+git1710271830.33dcc2~gd~x) but 2.4.85+git1710251830.61ff97~gd~x is to be installed.
      libdrm-nouveau2:i386 : Breaks: libdrm-nouveau2 (!= 2.4.85+git1710251830.61ff97~gd~x) but 2.4.85+git1710271830.33dcc2~gd~x is installed.
      libdrm-amdgpu1 : Breaks: libdrm-amdgpu1:i386 (!= 2.4.85+git1710271830.33dcc2~gd~x) but 2.4.85+git1710251830.61ff97~gd~x is to be installed.
      libdrm-amdgpu1:i386 : Breaks: libdrm-amdgpu1 (!= 2.4.85+git1710251830.61ff97~gd~x) but 2.4.85+git1710271830.33dcc2~gd~x is installed.
      libdrm2 : Breaks: libdrm2:i386 (!= 2.4.85+git1710271830.33dcc2~gd~x) but 2.4.85+git1710251830.61ff97~gd~x is to be installed.
      libdrm2:i386 : Breaks: libdrm2 (!= 2.4.85+git1710251830.61ff97~gd~x) but 2.4.85+git1710271830.33dcc2~gd~x is installed.
      libdrm-intel1 : Breaks: libdrm-intel1:i386 (!= 2.4.85+git1710271830.33dcc2~gd~x) but 2.4.85+git1710251830.61ff97~gd~x is to be installed.
      libdrm-intel1:i386 : Breaks: libdrm-intel1 (!= 2.4.85+git1710251830.61ff97~gd~x) but 2.4.85+git1710271830.33dcc2~gd~x is installed.
      libdrm-radeon1 : Breaks: libdrm-radeon1:i386 (!= 2.4.85+git1710271830.33dcc2~gd~x) but 2.4.85+git1710251830.61ff97~gd~x is to be installed.
      libdrm-radeon1:i386 : Breaks: libdrm-radeon1 (!= 2.4.85+git1710251830.61ff97~gd~x) but 2.4.85+git1710271830.33dcc2~gd~x is installed.

      Comment


      • Originally posted by ErronerousBosch View Post
        I encountered this same error with Ubuntu 17.10 on a fresh install. My AskUbuntu post summarizes my experience, but in short, there is a conflict with the version of libdrm-amd-gpu provided by the PPA and the one provided by libdrm-common which breaks the drivers and several core packages to xorg and wayland. Ubuntu will not allow the PPA to override this library. I did solve the problem with the following steps:
        1. Code:
          sudo dpkg --purge libdrm-common
        2. Code:
          sudo apt update
        3. Code:
          sudo apt upgrade
        I did disable the PPA before the dpkg, then reenabled before the update, but this shouldn't actually make a difference, I was digging through a lot of things to try and solve this. But now apt no longer tries to uninstall GNOME.
        libdrm-nouveau2 : Breaks: libdrm-nouveau2:i386 (!= 2.4.85+git1710271830.33dcc2~gd~x) but 2.4.85+git1710251830.61ff97~gd~x is to be installed.
        libdrm-nouveau2:i386 : Breaks: libdrm-nouveau2 (!= 2.4.85+git1710251830.61ff97~gd~x) but 2.4.85+git1710271830.33dcc2~gd~x is installed.
        libdrm-amdgpu1 : Breaks: libdrm-amdgpu1:i386 (!= 2.4.85+git1710271830.33dcc2~gd~x) but 2.4.85+git1710251830.61ff97~gd~x is to be installed.
        libdrm-amdgpu1:i386 : Breaks: libdrm-amdgpu1 (!= 2.4.85+git1710251830.61ff97~gd~x) but 2.4.85+git1710271830.33dcc2~gd~x is installed.
        libdrm2 : Breaks: libdrm2:i386 (!= 2.4.85+git1710271830.33dcc2~gd~x) but 2.4.85+git1710251830.61ff97~gd~x is to be installed.
        libdrm2:i386 : Breaks: libdrm2 (!= 2.4.85+git1710251830.61ff97~gd~x) but 2.4.85+git1710271830.33dcc2~gd~x is installed.
        libdrm-intel1 : Breaks: libdrm-intel1:i386 (!= 2.4.85+git1710271830.33dcc2~gd~x) but 2.4.85+git1710251830.61ff97~gd~x is to be installed.
        libdrm-intel1:i386 : Breaks: libdrm-intel1 (!= 2.4.85+git1710251830.61ff97~gd~x) but 2.4.85+git1710271830.33dcc2~gd~x is installed.
        libdrm-radeon1 : Breaks: libdrm-radeon1:i386 (!= 2.4.85+git1710271830.33dcc2~gd~x) but 2.4.85+git1710251830.61ff97~gd~x is to be installed.
        libdrm-radeon1:i386 : Breaks: libdrm-radeon1 (!= 2.4.85+git1710251830.61ff97~gd~x) but 2.4.85+git1710271830.33dcc2~gd~x is installed.

        Comment


        • EDIT: should be fixed now.
          Last edited by oibaf; 11-01-2017, 07:47 AM.

          Comment


          • The issue on 17.10 should be fixed now.

            Comment


            • To artful/17.10 users: I just uploaded updated, rebased mesa packages, I disabled some stuff which probably isn't very useful nowadays: XvMC and OpenMAX video drivers, optional classic swrast and broken gallium i915.
              Please test and let me know.

              Comment


              • I encountered no issues enabling and after a few days purging your ppa on 17.10 went quite smooth both ways. Nice work
                Those who would give up Essential Liberty to purchase a little Temporary Safety,deserve neither Liberty nor Safety.
                Ben Franklin 1755

                Comment


                • Hello, I just updated the drivers, and a wild flicker appeared. Apparently the previous versions are no longer in the PPA so I can't revert?

                  I think these are the relevant packages, so one of them probably has the issue. After these updates my game started showing huge graphical glitches. The main menu flickers (but it stops flickering briefly if I adjust graphical settings). The game itself is an unplayable mess. There's something about shaders.

                  Anyway, grepped apt's history log with "oibaf":

                  Code:
                  libgles2-mesa:amd64 (17.4~git1711021930.529cdc~oibaf~x, 17.4~git1711121930.4a9aad~oibaf~x)
                  xserver-xorg-video-nouveau:amd64 (1:1.0.15+git1706131933.69aecd~gd~x, 1:1.0.15+git1711031457.69aecd~oibaf~x)
                  libdrm-nouveau2:amd64 (2.4.87+git1711010826.b617f0~gd~x, 2.4.88+git1711110630.218858~oibaf~x)
                  libdrm-nouveau2:i386 (2.4.87+git1711010826.b617f0~gd~x, 2.4.88+git1711110630.218858~oibaf~x)
                  libglapi-mesa:amd64 (17.4~git1711021930.529cdc~oibaf~x, 17.4~git1711121930.4a9aad~oibaf~x)
                  libglapi-mesa:i386 (17.4~git1711021930.529cdc~oibaf~x, 17.4~git1711121930.4a9aad~oibaf~x)
                  libxatracker2:amd64 (17.4~git1711021930.529cdc~oibaf~x, 17.4~git1711121930.4a9aad~oibaf~x)
                  libegl1-mesa:amd64 (17.4~git1711021930.529cdc~oibaf~x, 17.4~git1711121930.4a9aad~oibaf~x)
                  libgbm1:amd64 (17.4~git1711021930.529cdc~oibaf~x, 17.4~git1711121930.4a9aad~oibaf~x)
                  libdrm-amdgpu1:amd64 (2.4.87+git1711010826.b617f0~gd~x, 2.4.88+git1711110630.218858~oibaf~x)
                  libdrm-amdgpu1:i386 (2.4.87+git1711010826.b617f0~gd~x, 2.4.88+git1711110630.218858~oibaf~x)
                  libllvm5.0:amd64 (1:5.0-1~gd~x, 1:5.0.1~+rc1-1~exp1~oibaf~x)
                  libllvm5.0:i386 (1:5.0-1~gd~x, 1:5.0.1~+rc1-1~exp1~oibaf~x)
                  xserver-xorg-video-intel:amd64 (2:2.99.917+git1707181934.e436cf~gd~x, 2:2.99.917+git1711090734.37a682~oibaf~x)
                  libwayland-egl1-mesa:amd64 (17.4~git1711021930.529cdc~oibaf~x, 17.4~git1711121930.4a9aad~oibaf~x)
                  libdrm2:amd64 (2.4.87+git1711010826.b617f0~gd~x, 2.4.88+git1711110630.218858~oibaf~x)
                  libdrm2:i386 (2.4.87+git1711010826.b617f0~gd~x, 2.4.88+git1711110630.218858~oibaf~x)
                  libgl1-mesa-dri:amd64 (17.4~git1711021930.529cdc~oibaf~x, 17.4~git1711121930.4a9aad~oibaf~x)
                  libgl1-mesa-dri:i386 (17.4~git1711021930.529cdc~oibaf~x, 17.4~git1711121930.4a9aad~oibaf~x)
                  libosmesa6:amd64 (17.4~git1711021930.529cdc~oibaf~x, 17.4~git1711121930.4a9aad~oibaf~x)
                  libosmesa6:i386 (17.4~git1711021930.529cdc~oibaf~x, 17.4~git1711121930.4a9aad~oibaf~x)
                  libgl1-mesa-glx:amd64 (17.4~git1711021930.529cdc~oibaf~x, 17.4~git1711121930.4a9aad~oibaf~x)
                  libgl1-mesa-glx:i386 (17.4~git1711021930.529cdc~oibaf~x, 17.4~git1711121930.4a9aad~oibaf~x)
                  libdrm-intel1:amd64 (2.4.87+git1711010826.b617f0~gd~x, 2.4.88+git1711110630.218858~oibaf~x)
                  libdrm-intel1:i386 (2.4.87+git1711010826.b617f0~gd~x, 2.4.88+git1711110630.218858~oibaf~x)
                  libdrm-radeon1:amd64 (2.4.87+git1711010826.b617f0~gd~x, 2.4.88+git1711110630.218858~oibaf~x)
                  libdrm-radeon1:i386 (2.4.87+git1711010826.b617f0~gd~x, 2.4.88+git1711110630.218858~oibaf~x)
                  mesa-vdpau-drivers:amd64 (17.4~git1711021930.529cdc~oibaf~x, 17.4~git1711121930.4a9aad~oibaf~x)

                  Comment


                  • Ubuntu 17.10 running on an Intel 8700K with iGPU(i915) and updated yesterday and it completely broke Wayland. Major pixelation and flicker (stops momentarily if I move my mouse). I'm able to switch to Xorg and login fine though, so it's Wayland specific. Following packages were updated:

                    libgl1-mesa libgbm1 libgl1-mesa-dri libgl1-mesa-glx libglapi-mesa
                    libgles2-mesa libwayland-egl1-mesa libxtracker2 mesa-va-drivers
                    mesa-vdpau-drivers

                    Any ideas?

                    Comment


                    • Originally posted by Rich_S View Post
                      Ubuntu 17.10 running on an Intel 8700K with iGPU(i915) and updated yesterday and it completely broke Wayland. Major pixelation and flicker (stops momentarily if I move my mouse). I'm able to switch to Xorg and login fine though, so it's Wayland specific. Following packages were updated:

                      libgl1-mesa libgbm1 libgl1-mesa-dri libgl1-mesa-glx libglapi-mesa
                      libgles2-mesa libwayland-egl1-mesa libxtracker2 mesa-va-drivers
                      mesa-vdpau-drivers

                      Any ideas?
                      Well, today's update fixed it.

                      Comment

                      Working...
                      X