Announcement

Collapse
No announcement yet.

Updated and Optimized Ubuntu Free Graphics Drivers

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Well I purged the PPA and did a dist-update and this is what installed. So did the Mint guys update the graphics drivers? I see llvm5.0 which seems relatively new for Ubuntu 16.04. Could that be the cause of problems with this PPA?

    Code:
    The following NEW packages will be installed:
      libllvm5.0
    The following packages will be upgraded:
      dolphin-emu-data-master dolphin-emu-master kodi kodi-x11 libdrm-amdgpu1 libdrm-intel1 libdrm-nouveau2
      libdrm-radeon1 libdrm2 libegl1-mesa libegl1-mesa-drivers libgbm1 libgl1-mesa-dri libgl1-mesa-glx
      libglapi-mesa:i386 libglapi-mesa libgles1-mesa libgles2-mesa libosmesa6 libosmesa6:i386 libwayland-cursor0
      libwayland-cursor0:i386 libwayland-egl1-mesa libwayland-server0 libwayland-server0:i386 libxatracker2 libxfont1
      mesa-vdpau-drivers xserver-xorg-video-amdgpu xserver-xorg-video-intel
    30 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
    Need to get 67.3 MB of archives.
    After this operation, 79.1 MB of additional disk space will be used.

    Comment


    • It may be... Try updating the packages and then add again the PPA, let's see what's happens.

      Comment


      • Same result. Here's a pastebin of a fresh try with the PPA. Says it's trying to overwrite /usr/share/libdrm/amdgpu.ids , but I checked that location and there's nothing there. libdrm is empty.

        https://pastebin.com/LTpv0S56

        Comment


        • OK, probably this error was due to an update of the system libdrm, that file went in a different package than mine. I temporarily removed it from libdrm-amdgpu1 package, building updated libdrm now. Please try updating again when the build is finished (some minutes).

          Comment


          • Thanks, that's working.

            Comment


            • Trying to get Vuklan working on my Mint 18 setup with Radeon HD 7850 and when I run Dolphin with Vulkan I get the message "No Vulkan Physical Devices available". I installed vulkan-utils and mesa-vulkan-drivers. Do I need to enable AMDGPU to get Vulkan?

              **EDIT**

              Nevermind, I got it working by switching over to the AMDGPU driver. Apparently Radeon has no Vulkan, only AMDGPU.
              Last edited by Dukenukemx; 01-21-2018, 05:00 PM.

              Comment


              • oibaf Do you provide debug packages? I don't see really those and GDB show /usr/lib/x86_64-linux-gnu/dri/nouveau_dri.so has no debug symbols...

                Comment


                • Yesterday I updated my Mint 18 and couldn't boot the machine into a UI. I had to ppa-purge the PPA to get it to boot back up. Am I the only person who uses Mint with this PPA, cause I feel like I'm the only one running into these problems.

                  **EDIT**

                  Tried again and same Xserver error. Ppa-purge to fix it.
                  Last edited by Dukenukemx; 02-07-2018, 02:10 PM.

                  Comment


                  • Originally posted by debianxfce View Post

                    If you are using Debian testing based mint, OIbaf ppa is not compatible with Debian testing or sid because of nvidias GLVND package, libegl1.
                    https://packages.debian.org/buster/libegl1

                    Oibaf, is there any change that you could produce Debian testing or sid packages too. Is it a big job and possible if I get a uhbuntu one account and modify your repo to work with Debian testing?
                    The launchpad PPA only builds against the Ubuntu versions, there is no way to build against Debian version from what I know. Some Ubuntu versions somewhat match against other Debian versions and it could work, but when using rolling distro like testing or sid problems may arise. You may want to set up a PPA and backport from Debian some packages like libegl1 and rebuild my packages.
                    I don't have time to look into it myself.

                    Comment


                    • Originally posted by debianxfce View Post

                      If you are using Debian testing based mint, OIbaf ppa is not compatible with Debian testing or sid because of nvidias GLVND package, libegl1.
                      https://packages.debian.org/buster/libegl1

                      Oibaf, is there any change that you could produce Debian testing or sid packages too. Is it a big job and possible if I get a uhbuntu one account and modify your repo to work with Debian testing?
                      I'm using Mint 18.3 x64 with Cinnamon. It's the one based on Ubuntu.

                      Comment

                      Working...
                      X