Announcement

Collapse
No announcement yet.

Updated and Optimized Ubuntu Free Graphics Drivers

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • I was wondering, does this archive on Xenial link against the HWE versions or standard versions for packages not included.

    Also, could you simply include the whole Xorg System to resolve this problem? It has a nasty tendency to create dependency hell otherwise.

    Comment


    • Originally posted by Ruediix View Post
      I was wondering, does this archive on Xenial link against the HWE versions or standard versions for packages not included.

      Also, could you simply include the whole Xorg System to resolve this problem? It has a nasty tendency to create dependency hell otherwise.
      I suppose it links against original packages that are managed by launchpad PPA. I prefer don't modify that since it may cause other issues that I cannot debug not having a xenial system to test. You may want to upgrade to a newer Ubuntu to get updated packages.

      Comment


      • Originally posted by oibaf View Post

        I suppose it links against original packages that are managed by launchpad PPA. I prefer don't modify that since it may cause other issues that I cannot debug not having a xenial system to test. You may want to upgrade to a newer Ubuntu to get updated packages.
        Yeah, the only problem is the AMDGPU driver now requires a newer XOrg version than is in the older packages. It only properly works with the version that would be in the HWE version. Hence you probably should link Xenial against the HWE version in the Xenial PPA set.

        I'm sure you are aware how HWE versions are used in the LTS releases. Starting around the xx.03 version they switch to use HWE by default, hence you should probably switch your Xenial version to link to those if you aren't packaging your own.

        Comment


        • Originally posted by Ruediix View Post

          Yeah, the only problem is the AMDGPU driver now requires a newer XOrg version than is in the older packages. It only properly works with the version that would be in the HWE version. Hence you probably should link Xenial against the HWE version in the Xenial PPA set.

          I'm sure you are aware how HWE versions are used in the LTS releases. Starting around the xx.03 version they switch to use HWE by default, hence you should probably switch your Xenial version to link to those if you aren't packaging your own.
          If someone send me a patch for the package(s) I can apply it. Unfortunately I don't have free time to do this myself currently.

          Comment


          • Originally posted by oibaf View Post

            If someone send me a patch for the package(s) I can apply it. Unfortunately I don't have free time to do this myself currently.
            I've currently got a bad toothache (one more filling and it should be fixed) and backed housework keeping me from getting productive work done. I might add it to my "possible project" list. It would be a good one to get under my belt.

            Comment


            • Just a heads up to anyone trying to install the ppa from a clean install of Artful 17.10 daily. Ubuntu seems to have added an extra dependency to libdrm2 that can leave the upgrade broken.
              From apt-cache show :
              Code:
              Package: libdrm2
              Architecture: amd64
              Version: 2.4.82-1
              Multi-Arch: same
              Priority: standard
              Section: libs
              Source: libdrm
              Origin: Ubuntu
              Maintainer: Ubuntu Developers <[email protected]>
              Original-Maintainer: Debian X Strike Force <[email protected]>
              Bugs: https://bugs.launchpad.net/ubuntu/+filebug
              Installed-Size: 110
              Depends: libdrm-common (>= 2.4.82-1), libc6 (>= 2.17)
              Filename: pool/main/libd/libdrm/libdrm2_2.4.82-1_amd64.deb
              sudo dpkg --purge libdrm-common will allow the upgrade to continue as oibaf's libdrm2 only depends on libc6.
              Those who would give up Essential Liberty to purchase a little Temporary Safety,deserve neither Liberty nor Safety.
              Ben Franklin 1755

              Comment


              • Originally posted by DarkFoss View Post
                Just a heads up to anyone trying to install the ppa from a clean install of Artful 17.10 daily. Ubuntu seems to have added an extra dependency to libdrm2 that can leave the upgrade broken.
                From apt-cache show :
                Code:
                Package: libdrm2
                Architecture: amd64
                Version: 2.4.82-1
                Multi-Arch: same
                Priority: standard
                Section: libs
                Source: libdrm
                Origin: Ubuntu
                Maintainer: Ubuntu Developers <[email protected]>
                Original-Maintainer: Debian X Strike Force <[email protected]>
                Bugs: https://bugs.launchpad.net/ubuntu/+filebug
                Installed-Size: 110
                Depends: libdrm-common (>= 2.4.82-1), libc6 (>= 2.17)
                Filename: pool/main/libd/libdrm/libdrm2_2.4.82-1_amd64.deb
                sudo dpkg --purge libdrm-common will allow the upgrade to continue as oibaf's libdrm2 only depends on libc6.
                I rebased my packages, they should be build in a hour and this issue should hopefully be fixed.

                Comment


                • Thanks for the quick response. New error trying to install libdrm-common without purging first:
                  Code:
                  $ sudo apt-get install libdrm-common
                  Reading package lists... Done
                  Building dependency tree      
                  Reading state information... Done
                  The following NEW packages will be installed:
                    libdrm-common
                  0 upgraded, 1 newly installed, 0 to remove and 2 not upgraded.
                  Need to get 0 B/13.1 kB of archives.
                  After this operation, 38.9 kB of additional disk space will be used.
                  (Reading database ... 151739 files and directories currently installed.)
                  Preparing to unpack .../libdrm-common_2.4.83+git1709261752.7c7118~gd~a_all.deb ...
                  Unpacking libdrm-common (2.4.83+git1709261752.7c7118~gd~a) ...
                  dpkg: error processing archive /var/cache/apt/archives/libdrm-common_2.4.83+git1709261752.7c7118~gd~a_all.deb (--unpack):
                   trying to overwrite '/usr/share/libdrm/amdgpu.ids', which is also in package libdrm-amdgpu1:amd64 2.4.83+git1709261752.7c7118~gd~a
                  Errors were encountered while processing:
                   /var/cache/apt/archives/libdrm-common_2.4.83+git1709261752.7c7118~gd~a_all.deb
                  E: Sub-process /usr/bin/dpkg returned an error code (1)
                  *edit ppa purged with the help of apt --fix-broken install drm-common is re-installed on default ubuntu . I will check upgrading once mesa build is completed sucessfully.
                  Last edited by DarkFoss; 09-26-2017, 04:47 PM.
                  Those who would give up Essential Liberty to purchase a little Temporary Safety,deserve neither Liberty nor Safety.
                  Ben Franklin 1755

                  Comment


                  • I reverted to the old libdrm package. For some reason mesa doesn't build with the updated libdrm.

                    Comment


                    • OK, I updated to Zesty and am STILL getting some awful dependency hell trying to install this PPA.

                      I didn't have this issue in the past, it started a few months ago.

                      If you could walk me through finding the problem it would be helpful.
                      Last edited by Ruediix; 10-03-2017, 03:29 AM. Reason: more info

                      Comment

                      Working...
                      X