Announcement

Collapse
No announcement yet.

Updated and Optimized Ubuntu Free Graphics Drivers

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • oibaf :

    Up until now your policy was that you do not support Ubuntu LTS versions that have been upgraded with the LTS Hardware Enablement (HWE) stacks that come with point releases x.04.2, x.04.3, x.04.4, x.04.5, correct?

    Would there be any chance you could change this policy and actually do support LTS versions with HWE?

    This would make sense, because, users who install the Oibaf PPA want the latest graphics drivers, so they probably would also appreciate the new kernel and xorg-server that comes with the HWE.

    So, any chance you could start to support HWE once 16.04.2 with 16.10 kernel + xorg-server is being released?

    That way Xenial users could upgrade to the 16.10, 17.04, 17.10, 18.04 kernel + xorg-server and still use the Oibaf PPA to get the latest graphics driver upgrades.

    Any chance you could do that?

    Comment


    • I uploaded packages for yakkety. Who want to use the latest may upgrade to it, rather than using xenial HWE. I also don't have time for it, but maybe if someone is interested can set up a PPA for xenial HWE.

      Comment


      • I have a ASUS Radeon R7 360 on Ubuntu 16.04.

        I installed the packages, but the highest OpenGL version I get is OpenGL 3. I need a higher version (because I need at least GLSL 1.40).

        GLX gives me:

        GLX version: 1.4
        Max core profile version: 4.3
        Max compat profile version: 3.0
        Max GLES1 profile version: 1.1
        Max GLES[23] profile version: 3.1
        OpenGL core profile version string: 4.3 (Core Profile) Mesa 12.1.0-devel
        OpenGL core profile shading language version string: 4.30
        OpenGL version string: 3.0 Mesa 12.1.0-devel
        OpenGL shading language version string: 1.30


        OpenGL renderer string: Gallium 0.4 on AMD BONAIRE (DRM 2.43.0 / 4.4.0-43-generic, LLVM 3.9.0)
        Is there no driver out there for my card that supports OpenGL 3.1+?

        Comment


        • Originally posted by surGeonGG View Post
          Is there no driver out there for my card that supports OpenGL 3.1+?
          huh? The code you quoted show OpenGL 4.3...

          Comment


          • Originally posted by agd5f View Post

            huh? The code you quoted show OpenGL 4.3...
            So the Max core profile version shows me the OpenGL version I have? I thought it was the Max compat profile version. What is that then?

            glxgears -info gives me this:
            GL_RENDERER = Gallium 0.4 on AMD BONAIRE (DRM 2.43.0 / 4.4.0-43-generic, LLVM 3.9.0)
            GL_VERSION = 3.0 Mesa 12.1.0-devel
            GL_VENDOR = X.Org
            Is GL_VERSION here not the OpenGL version?

            In that case, why am I getting:
            Message: 0:1(10): error: GLSL 1.40 is not supported. Supported versions are: 1.10, 1.20, 1.30, 1.00 ES, 3.00 ES, 3.10 ES, and 3.20 ES
            0:1(10): error: GLSL 1.40 is not supported. Supported versions are: 1.10, 1.20, 1.30, 1.00 ES, 3.00 ES, 3.10 ES, and 3.20 ES
            ... when trying to compile my vertex shader? GLSL 1.30 works fine and that is OpenGL 3. Strange.

            Sorry if this is unrelated to the drivers.



            Comment


            • Mesa does not support compatibility profiles, only core profiles. If you need a compatibility profile, you are limited to OpenGL 3.0. If you need OpenGL 3.1 or newer, you need to use a core profile.

              Comment


              • Originally posted by agd5f View Post
                Mesa does not support compatibility profiles, only core profiles. If you need a compatibility profile, you are limited to OpenGL 3.0. If you need OpenGL 3.1 or newer, you need to use a core profile.
                Yup. I was using compatibility profile in my glfw context. Fixed it now. Thanks and God bless.

                For God so loved the world, that he gave his only begotten Son, that whosoever believeth in him should not perish, but have everlasting life.

                Comment


                • Hi oibaf! I have a problem, my laptop freezes when gaming with your drivers. Its random, sometimes with Minecraft, sometimes with just browsing, but i can reproduce it when changing shadow settings in Star Conflict. When it happens, nothing responds, brightness keys died, ctrl + alt + f3 died, everything stops, i need to force shutdown it... Why this happening? Intel HD3000, Ubuntu 16.10

                  Comment


                  • Hi, oibaf,

                    Looks like your build is broken since https://cgit.freedesktop.org/mesa/me...3c57837da6ea77. LLVM probably needs to be updated.

                    Comment


                    • There is a patch on mesa-dev list fixing it, hopefully they'll commit it soon.

                      Comment

                      Working...
                      X