No announcement yet.

Updated and Optimized Ubuntu Free Graphics Drivers

  • Filter
  • Time
  • Show
Clear All
new posts

  • Code:
    [    32.211] (II) [KMS] drm report modesetting isn't supported.
    [    32.211] (EE) open /dev/dri/card0: No such file or directory
    No kernel driver. I don't understand how dmesg can have nothing logged yet though. Are you sure you ran dmesg as a command ?

    You can check on blacklisting by going into /etc/modprobe.d folder and running " grep radeon * " (without the spaces at start and end, I just added them to make it easier to read). You may get hits for radeonfb but should not see any for radeon.

    The .drirc messages are not a problem, and the other libGL messages look OK (not what you want to see, but reasonable under the circumstances).
    Test signature


    • Originally posted by bridgman View Post
      [ 32.211] (II) [KMS] drm report modesetting isn't supported.
      [ 32.211] (EE) open /dev/dri/card0: No such file or directory
      No kernel driver. I don't understand how dmesg can have nothing logged yet though. Are you sure you ran dmesg as a command ?
      Ah no, I misunderstood and just checked the dmesg log in /var/log/

      Thanks to your suggestion that the problem was kernel related and the lines you highlighted I did find the problem though. "nomodeset" was set in grub, stopping the kernel from figuring it out the card for it self. This is what I did to fix it if anyone else have a similar problem:
      sudo vi /etc/default/grub
      Find the line "GRUB_CMDLINE_LINUX_DEFAULT" remove nomodeset and save.
      Update grub and reboot.
      sudo update-grub
      sudo reboot
      After that it worked like a charm. I have had problems with her computer having long startup times and I think that was part of an attempt to fix it and then I forgot about it. Thank you bridgman for the help. I was totally stuck before your insights.


      • Great... glad to hear it's working.
        Test signature


        • A few updates ago I have noticed low performance in some of my games, namely Bioshock Infinite and Tomb Raider (both on Steam). Neither of those games run higher than 30fps, despite being able to game smoothly at 50-60fps a few weeks ago with the same settings. It's like the games are being capped at 30fps. Turning off vsync in the games does not solve this either. I have not tried turning off vsync and swapbuffers wait in the driver, but other games (Half Life 2 and Xonotic) work fine. Anyone have been experiencing something similar?


          • This may be the same as the "290 slowdown" bug... seems to have effect when fps would normally be under 60 Hz. Don't think the root cause is understood yet but has been bisected to a page-flip commit:

            Test signature


            • Just a note I upgraded llvm in the ppa to 3.9.


              • Hi, I had previously installed your PPA on my copy of Kubuntu 14.04 (Trusty Tahir), and at some point, the repo stopped updating itself. I didn't think much of it until now when I went to try to upgrade my system to 16.04. I can't upgrade it because the upgrade manager can't calculate the dependencies. I figured maybe one of the causes was any extra repos I had, so I removed the other ones I had installed, but I ran into an issue with the oibaf PPA.
                I can remove the repo, but there's no easy way to downgrade the packages back to the original versions- using ppa-purge gives me this:

                sudo ppa-purge ppaibaf/graphics-drivers
                Updating packages lists
                PPA to be removed: oibaf graphics-drivers
                Warning: Could not find package list for PPA: oibaf graphics-drivers

                There doesn't appear to be packages for the oibaf graphics PPA before 16.04 now, which might be why ppa-purge doesn't work.
                It looks like the only way to reset the packages to the original versions is to do it manually, bit by bit:
                Is there a better way to do this, or is this the only way?


                • Hello.

                  Thought I'd give a warning - latest update(s) of mesa-vdpau-drivers has broken UVD (VDPAU, hardware video decoding) for me.
                  MPV and Xine couldn't use hwdec anymore complaining about the kernel rejecting the Command Stream (CS).

                  While trying to decode video using VDPAU, dmesg repeatedly showed errors:
                  [14049.006274] [drm:radeon_uvd_cs_parse [radeon]] *ERROR* Handle 0x61d40001 already in use!
                  [14049.006304] [drm:radeon_cs_ioctl [radeon]] *ERROR* Invalid command stream !

                  The earliest version to blame: mesa-vdpau-drivers_12.1~git1609280730.8d8c44~gd~x_amd64.deb (yesterdays)

                  Downgrading to mesa-vdpau-drivers_12.1~git1609180730.073129~gd~x_amd64.deb restored VDPAU to working order.

                  GPU: Cape Verde XT Radeon HD 7770
                  Kernel version: Tried with Ubuntu's 4.4 and 4.8


                  • I just enabled the recently merged block I/O, network I/O and lmsensor stats as well power sensor support.


                    • Hello!
                      Firstly, thanks for all your work!

                      It seems tho that these changes didn't help in my case. Only the error message has changed slightly:
                      [ 68.810156] [drm:radeon_uvd_cs_parse [radeon]] *ERROR* invalid reloc offset 831000!
                      [ 68.810180] [drm:radeon_cs_ioctl [radeon]] *ERROR* Invalid command stream !

                      Guess I'll have to hold on to this mesa-vdpau version for some time. Cheers anyway!