Announcement

Collapse
No announcement yet.

Updated and Optimized Ubuntu Free Graphics Drivers

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Thanks for the explanation.

    Urgh... Glad I asked then before installing. An ounce of prevention...

    (Is LTS really that much of a kludge? Yikes.)
    Last edited by mrmoocow; 02-25-2016, 10:00 AM.

    Comment


    • HI! Is 16.04 officially supported by oibaf yet?
      I found it unable to boot with oibaf on my R9 380.
      How can I help debugging or finding the cause?

      Comment


      • Hello! I'm terribly sorry for the whole first post is giant thing.

        I've been using these drivers alongside CommendSarnex's Winedri3 to run Guild Wars 2 for a while. Sometime around December I stopped logging into Linux, and didn't update. I logged in yesterday March 4th and updated from the ppa using apt-get update and apt-get upgrade. Since then, Guild Wars 2 freezes after launch with Gallium-nine enabled in winecfg. I've tried downgrading from wine 1.9 back to wine 1.7 which I was using before but it still doesn't work with Gallium enabled it freezes the desktop, Gnome still responds and after a minute a dialog window appears saying the program froze and I can force quit. Waiting it out doesn't seem to help.

        I'll include the terminal readout with Gallium enabled http://pastebin.com/p2dEKSHc

        And Gallium disabled in winecfg/staging http://pastebin.com/fxxL5yg9

        I don't know what any of the 'fixme' errors mean. Without Gallium the game launches but is unplayable at around ~5fps.

        I found a comment on WineHQ that sounds like it's related as well: https://appdb.winehq.org/commentview...ThreadId=96414

        I honestly have no idea where to go from here, I'm a pretty basic user, so I don't know how to use an older version of the drivers, or what information I can give you that would help. I've tried a handful of other games with/without Gallium, and they seem to work fine, I don't know if it's the drivers, or if Guild Wars updated something. There's really only a couple games keeping me tied to Windows, and this is one of them. If someone could point out what went wrong, or anything I can do to help, that would be much appreciated.

        My system has:
        AMD Phenom(tm) II X6 1090T Processor × 6
        8 GB RAM
        AMD R9 290, Ubuntu Details says this under 'Graphics': Gallium 0.4 on AMD HAWAII (DRM 2.43.0, LLVM 3.8.0))
        Ubuntu 15.10 64-bit (Ubuntu Gnome)
        uname -a returns "Linux Graknaw 4.2.0-30-generic #36-Ubuntu SMP Fri Feb 26 00:58:07 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux"

        Comment


        • Just a couple notes:
          1) mesa package no longer builds, I'll have a look at it once I found some time (or if someone send me a patch );
          2) because of very few free time and the release of xenial/16.04, I'll soon definitively disable trusty/14.04 support.

          Comment


          • Originally posted by Omega Jimes View Post
            Hello! I'm terribly sorry for the whole first post is giant thing.

            I've been using these drivers alongside CommendSarnex's Winedri3 to run Guild Wars 2 for a while. Sometime around December I stopped logging into Linux, and didn't update. I logged in yesterday March 4th and updated from the ppa using apt-get update and apt-get upgrade. Since then, Guild Wars 2 freezes after launch with Gallium-nine enabled in winecfg. I've tried downgrading from wine 1.9 back to wine 1.7 which I was using before but it still doesn't work with Gallium enabled it freezes the desktop, Gnome still responds and after a minute a dialog window appears saying the program froze and I can force quit. Waiting it out doesn't seem to help.

            I'll include the terminal readout with Gallium enabled http://pastebin.com/p2dEKSHc

            And Gallium disabled in winecfg/staging http://pastebin.com/fxxL5yg9

            I don't know what any of the 'fixme' errors mean. Without Gallium the game launches but is unplayable at around ~5fps.

            I found a comment on WineHQ that sounds like it's related as well: https://appdb.winehq.org/commentview...ThreadId=96414

            I honestly have no idea where to go from here, I'm a pretty basic user, so I don't know how to use an older version of the drivers, or what information I can give you that would help. I've tried a handful of other games with/without Gallium, and they seem to work fine, I don't know if it's the drivers, or if Guild Wars updated something. There's really only a couple games keeping me tied to Windows, and this is one of them. If someone could point out what went wrong, or anything I can do to help, that would be much appreciated.

            My system has:
            AMD Phenom(tm) II X6 1090T Processor × 6
            8 GB RAM
            AMD R9 290, Ubuntu Details says this under 'Graphics': Gallium 0.4 on AMD HAWAII (DRM 2.43.0, LLVM 3.8.0))
            Ubuntu 15.10 64-bit (Ubuntu Gnome)
            uname -a returns "Linux Graknaw 4.2.0-30-generic #36-Ubuntu SMP Fri Feb 26 00:58:07 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux"
            Things you can try:
            1) Version upgrade Ubuntu and PPA.
            2) Remove native DX9 libraries.
            3) Enable or Disable DRI3.
            4) Rename game intro Videos.
            5) Buy Intel CPU.

            Comment


            • Hi all!

              I'm Ubuntu user(16.04 64bit) and i'm using Oibaf repo to be up to date with latest improvements in FLOSS drivers. I have two graphics card(hybrid): Intel HD4000 and Radeon HD7670M(i have to use FLOSS driver, because AMD drop support for my card with latest fglrx). Recent update(which enabled DRI3 for Radeon card) broke Dynamic Power Management to hybrid graphics. Before update this command:
              Code:
              sudo cat /sys/kernel/debug/vgaswitcheroo/switch
              shows me this output:
              Code:
              0:IGD:+:Pwr:0000:00:02.0
              1:DIS: :DynOff:0000:01:00.0
              After update i get this output:
              Code:
              0:IGD:+:Pwr:0000:00:02.0
              1:DIS: :Pwr:0000:01:00.0
              As you can see, dedicated card is powered. Before update it was powered down automatically by OS, now i have to power it down manually. How i can bring back Dynamic Power Management? I don't want to delete Oibaf PPA and use mesa from Ubuntu repo, because i really want to use Oibaf drivers.

              Sorry for mistakes in post, English isn't my first language.

              Comment


              • I had to do reinstall of system. Linux mint 17.3. Any idea why r9 290 exposed only 4.1? It has 4.3 before.

                Comment


                • The latest update borked my Xorg, which falls back to failsafe and the fbdev-driver, but eventually dies. I get a screen warning me about low graphics settings and that's pretty much it.
                  It started on 14.04 (even upgraded to the Xenial kernel) and I eventually did a clean install of 16.04 just in case support had been dropped for the former, but still no-go. Works fine with the stock FOSS drivers.
                  The log files show both a Xorg.0.log and a Xorg.log.failsafe with similar timestamps.
                  I use a R9 280 (Basically HD7950 GE)
                  P.S. I also use the Gallium9 PPA
                  Last edited by PsynoKhi0; 06-04-2016, 05:51 PM.

                  Comment


                  • Today's update killed my Xorg too. Stuck in failsafe for the moment and waiting for a further update.

                    Comment


                    • Same here with 390x

                      Comment

                      Working...
                      X