Announcement

Collapse
No announcement yet.

Updated and Optimized Ubuntu Free Graphics Drivers

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • I uploaded llvm 3.8 and rebuilt mesa and libclc with it.

    Comment


    • Having a problem running PCSX2 with the Oibaf PPA. Have two machines, one with Oibaf PPA and one with whatever came with Mint 17.3. The Mint 17.3 without Oibaf PPA has no problem running PCSX2. Mint with Oibaf PPA gives this output error.

      Are those graphic features really not supported?
      Code:
       ATTENTION: default value of option vblank_mode overridden by environment.
      glX-Version 1.4 with Direct Rendering
      OpenGL information. GPU: Gallium 0.4 on AMD CEDAR (DRM 2.43.0, LLVM 3.8.0). Vendor: X.Org. Driver: Mesa 11.2.0-devel (git-71b9dfb 2016-02-10 trusty-oibaf-ppa+gallium-nine)
      Buggy driver detected. Geometry shaders will be disabled
      Buggy driver detected, GL_ARB_separate_shader_objects will be disabled
      
      INFO: GL_EXT_texture_filter_anisotropic is available
      INFO: GL_ARB_gpu_shader5 is NOT SUPPORTED
      INFO: GL_ARB_draw_buffers_blend is available
      INFO: GL_ARB_separate_shader_objects is NOT SUPPORTED
      INFO: GL_ARB_shader_image_load_store is NOT SUPPORTED
      INFO: GL_ARB_copy_image is available
      INFO: GL_ARB_buffer_storage is available
      INFO: GL_ARB_clear_texture is NOT SUPPORTED
      INFO: GL_ARB_clip_control is available
      INFO: GL_ARB_direct_state_access is NOT SUPPORTED
      INFO: GL_ARB_texture_barrier is available
      DSA is not supported. Replacing the GL function pointer to emulate it

      Comment


      • With 17.3, you can now add ppa:tigerite/mint-xorg-update and simply run

        apt-get update
        apt-get upgrade
        apt-get install xorg-update

        After that, you can enable the Oibaf PPA for newer versions of everything except the xorg-server-video-* files. I'll keep those up-to-date as much as possible (they are currently in-sync).

        If any packages get held back, other than xorg-server-video- ones, you should be able to apt-get install them separately (such as cups and dpkg). I don't know why it doesn't bring them in automatically, they're not broken packages.

        Comment


        • WoW, thanks Tigerite. That will certainly make things easier. I'll test it and report what happens.

          Comment


          • Hello!
            On Fedora 23 (test update xorg-x11-drv-intel-2.99.917-19.20151206.fc23 ) by default was enabled DRI3. Will be enabled DRI3 on the Ubuntu ppaoibaf ? Video driver Intel HD 4600.
            Last edited by tuxnotess; 02-22-2016, 06:03 PM.

            Comment


            • I've changed the default to DRI3 in my PPA, but I don't think it makes much difference; the i965 driver still uses DRI2:

              [ 9370.866] (II) intel(0): SNA compiled for use with valgrind
              [ 9370.866] (--) intel(0): Integrated Graphics Chipset: Intel(R) HD Graphics 5000
              [ 9370.866] (--) intel(0): CPU: x86-64, sse2, sse3, ssse3, sse4.1, sse4.2, avx, avx2; using a maximum of 2 threads
              [ 9370.866] (II) intel(0): Creating default Display subsection in Screen section
              "Default Screen Section" for depth/fbbpp 24/32
              [ 9370.866] (==) intel(0): Depth 24, (--) framebuffer bpp 32
              [ 9370.866] (==) intel(0): RGB weight 888
              [ 9370.866] (==) intel(0): Default visual is TrueColor
              [ 9370.866] (**) intel(0): Option "DRI" "3"

              ...

              [ 9370.882] (II) intel(0): [DRI2] Setup complete
              [ 9370.882] (II) intel(0): [DRI2] DRI driver: i965
              [ 9370.882] (II) intel(0): [DRI2] VDPAU driver: va_gl
              [ 9370.882] (II) intel(0): direct rendering: DRI2 DRI3 enabled

              ...

              [ 9370.892] (II) AIGLX: Loaded and initialized i965
              [ 9370.892] (II) GLX: Initialized DRI2 GL provider for screen 0

              Comment


              • You can check what DRI is used by running "LIBGL_DEBUG=verbose glxgears" (string "libGL: Using DRI3 for screen 0").

                Comment


                • Hi oibaf!

                  First i want say thanks for the drivers, i have +20-25FPS, so this is better a lot than OS X/Windows. I have found a problem, and it looks like driver bug. When i boot the laptop, the Gnome shell crashes after 5-10 minutes, after this, it works without problems for days. Here is the log: http://pastebin.com/sg8zNV5Z

                  And my other question: How to check that the drivers are installed correctly? glxinfo | grep OpenGL:

                  OpenGL vendor string: Intel Open Source Technology Center
                  OpenGL renderer string: Mesa DRI Intel(R) Sandybridge Mobile
                  OpenGL core profile version string: 3.3 (Core Profile) Mesa 11.3.0-devel (git-4b7e219 2016-02-24 wily-oibaf-ppa)
                  OpenGL core profile shading language version string: 3.30
                  OpenGL core profile context flags: (none)
                  OpenGL core profile profile mask: core profile
                  OpenGL core profile extensions:
                  OpenGL version string: 3.0 Mesa 11.3.0-devel (git-4b7e219 2016-02-24 wily-oibaf-ppa)
                  OpenGL shading language version string: 1.30
                  OpenGL context flags: (none)
                  OpenGL extensions:
                  OpenGL ES profile version string: OpenGL ES 3.0 Mesa 11.3.0-devel (git-4b7e219 2016-02-24 wily-oibaf-ppa)
                  OpenGL ES profile shading language version string: OpenGL ES GLSL ES 3.00
                  OpenGL ES profile extensions:

                  Specs:

                  I3 2310M
                  Intel HD3000
                  4Gb DDR3 RAM (Single channel)
                  Ubuntu 15.10 with Gnome 3.18

                  Edit: Can i change the frequency up/down threshold for GPU usage? When i play, the GPU downclocks itself, the cooling is good. In OSX i can configure that, 50% GPU usage = 1100Mhz, 40% usage = the frequency slowly steps down to 650Mhz. Is this possible on Linux?

                  Thanks for reply.
                  Last edited by UDPSendToFailed; 02-24-2016, 03:06 PM.

                  Comment


                  • I'm currently running 14.04.4 -- as this update isn't "supported" (only up through 14.04.1 is) does that mean that the drivers won't work, or just they're "unsupported" in the sense of "don't ask for help, you're on your own until the next LTS 16.04 is official." Thanks.

                    Comment


                    • Originally posted by mrmoocow View Post
                      I'm currently running 14.04.4 -- as this update isn't "supported" (only up through 14.04.1 is) does that mean that the drivers won't work, or just they're "unsupported" in the sense of "don't ask for help, you're on your own until the next LTS 16.04 is official." Thanks.
                      The reason for this is quite complicated, I'll try to explain. On 14.04.0 and 14.04.1, the graphics stack was unchanged, and based on X.org 1.15.1, which has ABI version 15. You can tell this because, for instance, the xserver-xorg-video-intel package in Trusty (not -updates) depends on xorg-video-abi-15. The problem is, starting with 14.04.2 (and on to .3 and now .4) Ubuntu created the concept of LTS package suffixes, to bring in changes from Utopic, Vivid and now Wily. I'm not 100% on Utopic (EDIT: Ok I checked, it had yet another ABI, ths time 18) but certainly Vivid and Wily's X.org is 1.17.1 (or 2 in Wily's case) which now has ABI version 19. So, xserver-xorg-video-intel and so forth now rely on xorg-video-abi-19 and so are not compatible with the old versions.

                      Now Oibaf's problem is that to keep compatibility with the older Trusty releases, you have to compile (in Launchpad) those xserver-xorg-video-* (and xserver-xorg-input-*, plus virtualbox-guest-x11 but that's another story) against the old X.org development package, otherwise it won't install on 14.04.0 and 1 due to the ABI. But this means they aren't installable on 14.04.2 and onward. Not only that but the LTS packages conflict with the older versions anyway, so even if the ABI versions were the same you wouldn't be able to install them due to dpkg.

                      There are further complications too, because X.org 1.16 onward (so all of the LTS releases) provide glamoregl, and actually conflict with the old versions for that reason. So that means the control file changed for xserver-xorg-video-ati (which also provides -radeon) and xserver-xorg-video-intel, and again if Oibaf changed those in his PPA, they wouldn't then install on 14.04.0 and 14.04.1.

                      So.. yeah, it's a bit of a mess. That's only really scratching the surface too..
                      Last edited by Tigerite; 02-25-2016, 07:09 AM.

                      Comment

                      Working...
                      X