Announcement

Collapse
No announcement yet.

Updated and Optimized Ubuntu Free Graphics Drivers

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Just installed your OpenCL package for AMD gpus and I'm unable to compile anything opencl related. Make states that cl.h is not a header that exists on my system. I'm running Ubuntu 15.04, kernel version 3.19.0-28-generic, and I am using an r9 390 Grenada PRO. I've been trying to get opencl running on my system for many frustrating weeks, and this is the closest that I've come. Here's the output of clinfo: http://pastebin.com/9sphqd9d

    Comment


    • Originally posted by Maratus View Post
      Just installed your OpenCL package for AMD gpus and I'm unable to compile anything opencl related. Make states that cl.h is not a header that exists on my system. I'm running Ubuntu 15.04, kernel version 3.19.0-28-generic, and I am using an r9 390 Grenada PRO. I've been trying to get opencl running on my system for many frustrating weeks, and this is the closest that I've come. Here's the output of clinfo: http://pastebin.com/9sphqd9d
      Did you install "opencl-headers" package?

      Comment


      • Originally posted by maxis11 View Post
        Did you install "opencl-headers" package?
        I actually just did that before checking on here after finding out about apt-file and searching for the headers. Installed the opencl headers and the dev files and now everything runs great!

        Comment


        • Hello there, just registered and subscribed to this ppa. This is a great idea: if the Ubuntu main guys are continuously asleep with both eyes open, and only think they have to give us yesteryear's driver support, other people will have to jump in and get things going.

          However, it should be noted that installing this drivers is not for the faint of heart at all!!
          Had I used the normal way via APT, it would have uninstalled me 600 MB (!) of programs because so much stuff depends on those Mesa drivers.

          Then, I had a major conflict:

          Code:
          [email protected]:~$ sudo dpkg -i Downloads/libllvm3.6_3.6-2ubuntu1~trusty1_i386.deb
          Selecting previously unselected package libllvm3.6:i386.
          dpkg: regarding .../libllvm3.6_3.6-2ubuntu1~trusty1_i386.deb containing libllvm3.6:i386:
           libllvm3.6v5:i386 conflicts with libllvm3.6
            libllvm3.6:i386 (version 1:3.6-2ubuntu1~trusty1) is to be installed.
          Though I am able so solve such conflicts on my own (had to downgrade to 3.6 compiled with gcc < 5), it should at least be mentioned that llvm3.6 cannot co-exist with llvm3.6v5.
          The "v5" means that it is compiled with gcc 5.
          So I can't deny that it would be better if mesa didn't depend that extremely on LLVM stuff, because this is the only major conflict I've run in.

          Last question: where is libXvMCnouveau.so in the standard (non-PPA) repos? It must be somewhere, as nouveau is shipped in standard Ubuntu, and if VDPAU fails, the user ought to be able to revert to XvMC support.
          Last edited by andyman; 09-27-2015, 06:50 PM.

          Comment


          • Originally posted by andyman View Post
            it should at least be mentioned that llvm3.6 cannot co-exist with llvm3.6v5. The "v5" means that it is compiled with gcc 5.
            There is no support for Wily yet.

            Comment


            • Originally posted by RussianNeuroMancer View Post
              There is no support for Wily yet.
              That's what you're saying But on olbaf's PPA main page, I found Wily mentioned indeed. (I may look again where exactly I read it, if need be.)

              Comment


              • Originally posted by andyman View Post
                That's what you're saying But on olbaf's PPA main page, I found Wily mentioned indeed. (I may look again where exactly I read it, if need be.)
                There is only 1 package, and seems unrelated to Mesa: https://launchpad.net/~oibaf/+archiv...es_filter=wily

                Comment


                • Granted. Would be a silly idea to argue about that longer than one minute
                  Moving on ...

                  As you said "Mesa": yes this is another thing I am concerned about.
                  On nouveau's official page, they say that the reason for MPlayer's most common error message (Failed to open VDPAU backend libnvidia_vdpau.so...) is because the distro-shipped versions of the Mesa driver lacked the vdpau state tracker.
                  Fair enough, but why do I still get that very same error message even though I've installed olbaf's git versions of Mesa v11?

                  I'm about to run out of ideas...
                  Last edited by andyman; 09-28-2015, 04:03 PM.

                  Comment


                  • Originally posted by andyman View Post
                    Fair enough, but why do I still get that very same error message even though I've installed olbaf's git versions of Mesa v11?
                    Please post output of "glxinfo | grep string" command.

                    Comment


                    • Sure...
                      Code:
                      server glx vendor string: SGI
                      server glx version string: 1.4
                      client glx vendor string: Mesa Project and SGI
                      client glx version string: 1.4
                      OpenGL vendor string: VMware, Inc.
                      OpenGL renderer string: Gallium 0.4 on llvmpipe (LLVM 3.6, 128 bits)
                      OpenGL version string: 3.0 Mesa 11.1.0-devel (git-d6a41b5 2015-09-27 trusty-oibaf-ppa)
                      OpenGL shading language version string: 1.30

                      Comment

                      Working...
                      X