Announcement

Collapse
No announcement yet.

Updated and Optimized Ubuntu Free Graphics Drivers

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Originally posted by oibaf View Post
    Added to mesa xbmc-nv12-transcode branch from https://github.com/chadversary/mesa/...nv12-transcode
    Github returns 404 Page not found on https://github.com/chadversary/mesa/...nv12-transcode URL?

    Comment


    • latest mesa radeonsi has ARB_gpu_shader_fp64 + ARB_vertex_attrib_64bit support since a day..
      but using latest oibaf build isn't present..
      is due to needed updated llvm libraries?
      can you update your llvm to see if changes?

      Comment


      • Originally posted by SystemCrasher View Post
        Github returns 404 Page not found on https://github.com/chadversary/mesa/...nv12-transcode URL?
        Removed since it was obsoleted, an updated version will be in mesa soon.

        Comment


        • Originally posted by oscar View Post
          latest mesa radeonsi has ARB_gpu_shader_fp64 + ARB_vertex_attrib_64bit support since a day..
          but using latest oibaf build isn't present..
          is due to needed updated llvm libraries?
          can you update your llvm to see if changes?
          Too busy with vacation and paid work, sorry.

          Comment


          • Ubuntu utopic is EOL. I'll remove the packages from the PPA next week. Make sure to purge the PPA before upgrading to vivid.

            Comment


            • Tessellation is working in Unigine Heaven 4.0 benchmark! Running "MESA_GL_VERSION_OVERRIDE=4.0 ./heaven" in the Heaven folder do the trick.

              So for now the radeonsi driver still didn't advertise OpenGL4, but the functionality is there.

              I'm using a R9 290, Kernel 4.1.3.

              But Steam don't want to start with the version override, so I can't test if Metro Redux or Bioshock Infinity are working yet.

              Comment


              • It would be worthwhile to mention on your ppa page that the ppa is for 14.04 or 14.04.1 not any of the 14.04 lts versions (14.04.2, 14.04.3, ect.

                Comment


                • Originally posted by mc3man View Post
                  It would be worthwhile to mention on your ppa page that the ppa is for 14.04 or 14.04.1 not any of the 14.04 lts versions (14.04.2, 14.04.3, ect.
                  Done, thanks!

                  Comment


                  • Any prevision when LLVM 3.7 will be adopted? I got everything updated but still didn't get OpenGL 4.0 in radeonsi.

                    Comment


                    • Hello,

                      oibaf first of all thank you very much for the awesome work! I'm trying to use ubuntu as my main OS and graphics drivers are a must have since I'm working on a cross-platform 3D engine (https://github.com/aerys/minko).

                      For a few months it worked just great. The performance boost is just amazing (Intel HD 5500).

                      But for the past few days (2 weeks maybe), the updates provided by ppaibaf/graphics-driver make my Ubuntu 14.04 64bit config crash. The problem is about undefined symbols : _glapi_dispatch or _glapi_tls_dispatch. It's so bad unity won't run, X crashes and gets me back to the login screen whenever I try to login.

                      To fix this, I've cloned Mesa's git and compiled it myself. I then use the compiled ligGL.so.1.2.0 to replace the one provided by your ppa. And then things just work. It's really strange since I'm guessing the libGL provided by the ppa should be the same as the one I compile myself.

                      Any idea how I could fix this and make your ppa work without any additional steps?
                      How could I help diagnose the issue?

                      Thank you,

                      Comment

                      Working...
                      X