Announcement

Collapse
No announcement yet.

Updated and Optimized Ubuntu Free Graphics Drivers

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • What just happened with it? No graphics acceleration at all, getting:

    Code:
    [email protected]:~$ glxinfo | grep renderer
    libGL error: unable to load driver: r600_dri.so
    libGL error: driver pointer missing
    libGL error: failed to load driver: r600
    libGL error: unable to load driver: swrast_dri.so
    libGL error: failed to load driver: swrast
        GLX_MESA_multithread_makecurrent, GLX_MESA_query_renderer, 
    OpenGL renderer string: Gallium 0.4 on AMD CYPRESS
    and mesa package says build failure on the Launchpad page...

    Comment


    • Originally posted by dungeon View Post
      Yeah -mtune=generic works slow recently for some 32bit usecases on radeon, so at least -mtune=pentiumpro seems to be needed to bring back the speed.
      I disabled -mtune=generic, since it seems there is no progress on upstream bug. Please test and let me know if it is faster now.

      Comment


      • Originally posted by oibaf View Post
        I disabled -mtune=generic, since it seems there is no progress on upstream bug. Please test and let me know if it is faster now.
        Yep, issue gone, thanks

        Comment


        • dri3 is now present and running since todays update of ubntus X11 server and drivers to 1.16.

          Comment


          • Originally posted by oibaf View Post
            I disabled -mtune=generic, since it seems there is no progress on upstream bug. Please test and let me know if it is faster now.
            Yeah use that as temporary workaround because it is better (not the best) for most users/apps, but it is not fixed - 32bit glretrace still shows the issue so i guess some other (lets hope minority ) 32bit apps out there will show the issue too .

            I promised i will open a separete bug for that, but didn't have a time and actually just forgot about it

            Comment


            • Fabio, any chance you could update linux-firmware package to include this
              https://git.kernel.org/cgit/linux/ke...74a28c2753f184

              Comment


              • updated linux-firmware

                Comment


                • Originally posted by pvautrin View Post
                  Fabio, any chance you could update linux-firmware package to include this
                  https://git.kernel.org/cgit/linux/ke...74a28c2753f184
                  Is this firmware for old RADEON 3200HD?

                  Comment


                  • Originally posted by gogo View Post
                    Is this firmware for old RADEON 3200HD?
                    Yes, it is rs780

                    Originally posted by oibaf View Post
                    I disabled -mtune=generic, since it seems there is no progress on upstream bug. Please test and let me know if it is faster now.
                    You might try doing the same for 64bit too , because i found that this also prevent unpredictable lockups

                    Comment


                    • Hi there,

                      Recently there have been problems under Ubuntu 14.04 (Unity) with RadeonSI (HD 7770). Things generally seem more sluggish than they were a few months down the road. Also, with today's update, the screen, window borders, panel, and launcher all flicker when you drag windows around the screen.

                      I have tried enabling/disabling HyperZ; doesn't seem to make a difference.

                      Purged the drivers for now; will check back in in a few days. I'm sure the problems are just getting brought in from upstream, and it's nothing in particular you're doing. Regardless, thanks for your dedication to this PPA! I've definitely gotten more good out of it than bad.

                      It's AMD's fault we have to resort to projects like this anyway.

                      Comment

                      Working...
                      X