Announcement

Collapse
No announcement yet.

Updated and Optimized Ubuntu Free Graphics Drivers

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • There was a regression in Mesa master. It's been fixed already. I guess you have to wait for the next oibaf PPA update.

    Comment


    • Originally posted by marek View Post
      There was a regression in Mesa master. It's been fixed already. I guess you have to wait for the next oibaf PPA update.


      I just wanted to say that AMD will have a huge advantage on Linux if Nine succeeds. So work faster on your open drivers for new GPUs and someone merge Nine already.

      Comment


      • Originally posted by BestGameNews View Post
        I am using Ubuntu 14.04, i installed this PPA, now my system have no unity bar.

        Code:
        [email protected]:~$ glxinfo | grep OpenGL
        OpenGL vendor string: X.Org
        OpenGL renderer string: Gallium 0.4 on AMD REDWOOD
        OpenGL core profile version string: 3.3 (Core Profile) Mesa 10.4.0-devel (git-4ca203f 2014-08-28 trusty-oibaf-ppa)
        OpenGL core profile shading language version string: 3.30
        OpenGL core profile context flags: (none)
        OpenGL core profile profile mask: core profile
        OpenGL core profile extensions:
        OpenGL version string: 3.0 Mesa 10.4.0-devel (git-4ca203f 2014-08-28 trusty-oibaf-ppa)
        OpenGL shading language version string: 1.30
        OpenGL context flags: (none)
        OpenGL extensions:
        OpenGL ES profile version string: OpenGL ES 3.0 Mesa 10.4.0-devel (git-4ca203f 2014-08-28 trusty-oibaf-ppa)
        OpenGL ES profile shading language version string: OpenGL ES GLSL ES 3.0
        OpenGL ES profile extensions:
        [email protected]:~$


        Switching tabs not working (alt+tab), once a screen go background, getting back to it is vvery difficult, now now i made chrome always on top.

        When i try reverting to default open source driver, i get error

        Code:
        [email protected]:~$ sudo ppa-purge ppa:oibaf/graphics-drivers
        [sudo] password for boby: 
        Updating packages lists
        PPA to be removed: oibaf graphics-drivers
        Warning:  Could not find package list for PPA: oibaf graphics-drivers
        [email protected]:~$
        What should i do ? sos ...---...
        I read at Ubuntu Forums that you switched to Catalyst in meantime... anyway this issue was fixed in the PPA in the 12 hours ago build.

        Also, the PPA can be reverted only if it's still enabled. When you disable it ppa-purge cannot revert the packages.
        Last edited by oibaf; 08-29-2014, 02:04 PM.

        Comment


        • @oibaf Thanks for the reply. First time using ppa-purge, i re-added the repo and done ppa-purge it worked properly. I learned many new stuff by trying this PPA, i will try again after taking some rest

          Comment


          • Hi again everyone.

            I created a PPA that is simply oibaf's PPA + Gallium Nine. It is scheduled to automatically update twice a day.

            https://launchpad.net/~commendsarnex...tu/galliumnine

            Comment


            • Originally posted by sarnex View Post
              Hi again everyone.

              I created a PPA that is simply oibaf's PPA + Gallium Nine. It is scheduled to automatically update twice a day.

              https://launchpad.net/~commendsarnex...tu/galliumnine
              Deleted, use obiaf's nine ppa!

              Comment


              • google-earth stops woring mesa 10.4

                At some point after oibaf upgraded to mesa 10.4 google earth has stopped working, it crashes upon start up with these errors
                Code:
                [0904/215110:ERROR:net_util.cc(2195)] Not implemented reached in bool net::HaveOnlyLoopbackAddresses()
                [0904/215112:ERROR:nss_ocsp.cc(581)] No URLRequestContext for OCSP handler.
                [0904/215112:ERROR:nss_ocsp.cc(581)] No URLRequestContext for OCSP handler.
                [0904/215112:ERROR:nss_ocsp.cc(581)] No URLRequestContext for OCSP handler.
                [0904/215112:ERROR:nss_ocsp.cc(581)] No URLRequestContext for OCSP handler.
                [0904/215112:ERROR:nss_ocsp.cc(581)] No URLRequestContext for OCSP handler.
                [0904/215112:ERROR:nss_ocsp.cc(581)] No URLRequestContext for OCSP handler.
                [0904/215112:ERROR:nss_ocsp.cc(581)] No URLRequestContext for OCSP handler.
                [0904/215112:ERROR:nss_ocsp.cc(581)] No URLRequestContext for OCSP handler.
                [0904/215112:ERROR:nss_ocsp.cc(581)] No URLRequestContext for OCSP handler.
                [0904/215112:ERROR:nss_ocsp.cc(581)] No URLRequestContext for OCSP handler.
                [0904/215112:ERROR:nss_ocsp.cc(581)] No URLRequestContext for OCSP handler.
                [0904/215112:ERROR:nss_ocsp.cc(581)] No URLRequestContext for OCSP handler.
                [0904/215113:ERROR:nss_ocsp.cc(581)] No URLRequestContext for OCSP handler.
                [0904/215113:ERROR:nss_ocsp.cc(581)] No URLRequestContext for OCSP handler.
                [0904/215113:ERROR:nss_ocsp.cc(581)] No URLRequestContext for OCSP handler.
                [0904/215113:ERROR:nss_ocsp.cc(581)] No URLRequestContext for OCSP handler.
                Google Earth has caught signal 11.
                It was working with mesa 10.3 before. The gpu is intel ironlake. OS is Ubuntu 14.04 (purging the ppa and it works again with stock Ubuntu driver) Anyone has similar problem?

                Comment


                • Today's update fixed it.

                  Comment


                  • There is currently an issue with 32bit apps suffering some big slow downs:

                    https://bugs.freedesktop.org/show_bu...36#add_comment

                    I have no idea how this works, but judging by the comments it has something to do with compiler and fix is up to those maintaining builds (correct me if I'm wrong). If you could take a look at this Oibaf, that'd be awesome

                    Comment


                    • Originally posted by gutigen View Post
                      There is currently an issue with 32bit apps suffering some big slow downs:

                      https://bugs.freedesktop.org/show_bu...36#add_comment

                      I have no idea how this works, but judging by the comments it has something to do with compiler and fix is up to those maintaining builds (correct me if I'm wrong). If you could take a look at this Oibaf, that'd be awesome
                      Yeah -mtune=generic works slow recently for some 32bit usecases on radeon, so at least -mtune=pentiumpro seems to be needed to bring back the speed.
                      Last edited by dungeon; 09-06-2014, 05:19 AM.

                      Comment

                      Working...
                      X