Announcement

Collapse
No announcement yet.

Updated and Optimized Ubuntu Free Graphics Drivers

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Originally posted by gutigen View Post
    Unity seems to be broken on Ubuntu 14.04 and 14.10 since yesterdays update (Ubuntu loads after login, but Unity is invisible).
    Which driver/card?

    Comment


    • Originally posted by reCAPTCHA View Post
      Which driver/card?
      Right, forgot... it's 7770, so Radeonsi.

      Comment


      • Originally posted by sarnex View Post
        Hi everyone. I created a PPA for the patched wine required to use Gallium Nine and the D3D9 State Tracker

        https://launchpad.net/~commendsarnex...ive/ubuntu/ppa

        Enjoy
        Thank you very much. Was waiting for someone to do this.

        Comment


        • As discussed here I disabled gallium-nine due to regression in nouveau OpenGL.

          Comment


          • Originally posted by gutigen View Post
            Unity seems to be broken on Ubuntu 14.04 and 14.10 since yesterdays update (Ubuntu loads after login, but Unity is invisible).
            I booted my laptop and experienced this a little bit ago; just did a dist-upgrade though and it's fine after a reboot.

            Comment


            • Originally posted by Espionage724 View Post
              I booted my laptop and experienced this a little bit ago; just did a dist-upgrade though and it's fine after a reboot.
              https://bugs.freedesktop.org/show_bug.cgi?id=83148

              Comment


              • does it install lib3dadapter9.so libs ? because im getting this error while wine compile ...

                configure: libd3dadapter9 development files not found. Native Direct3D9 won't be supported.

                Trying a wine already compiled (from sarnex's ppa) throw same error (libd3dadapter9 missing) while running a game

                Comment


                • Originally posted by rhaego View Post
                  does it install lib3dadapter9.so libs ? because im getting this error while wine compile ...

                  configure: libd3dadapter9 development files not found. Native Direct3D9 won't be supported.

                  Trying a wine already compiled (from sarnex's ppa) throw same error (libd3dadapter9 missing) while running a game
                  Read 3 posts up .

                  Comment


                  • Originally posted by oibaf View Post
                    Read 3 posts up .
                    wow i read last 8 pages and didnt notice i hope gallium-nine can be rea-dded soon ...

                    is there any possibility to add those library manually or using a .deb installer? I already tried following this guide https://github.com/chrisbmr/Mesa-3D/...rs/nine/README
                    but no luck ...

                    Comment


                    • I am using Ubuntu 14.04, i installed this PPA, now my system have no unity bar.

                      Code:
                      [email protected]:~$ glxinfo | grep OpenGL
                      OpenGL vendor string: X.Org
                      OpenGL renderer string: Gallium 0.4 on AMD REDWOOD
                      OpenGL core profile version string: 3.3 (Core Profile) Mesa 10.4.0-devel (git-4ca203f 2014-08-28 trusty-oibaf-ppa)
                      OpenGL core profile shading language version string: 3.30
                      OpenGL core profile context flags: (none)
                      OpenGL core profile profile mask: core profile
                      OpenGL core profile extensions:
                      OpenGL version string: 3.0 Mesa 10.4.0-devel (git-4ca203f 2014-08-28 trusty-oibaf-ppa)
                      OpenGL shading language version string: 1.30
                      OpenGL context flags: (none)
                      OpenGL extensions:
                      OpenGL ES profile version string: OpenGL ES 3.0 Mesa 10.4.0-devel (git-4ca203f 2014-08-28 trusty-oibaf-ppa)
                      OpenGL ES profile shading language version string: OpenGL ES GLSL ES 3.0
                      OpenGL ES profile extensions:
                      [email protected]:~$


                      Switching tabs not working (alt+tab), once a screen go background, getting back to it is vvery difficult, now now i made chrome always on top.

                      When i try reverting to default open source driver, i get error

                      Code:
                      [email protected]:~$ sudo ppa-purge ppa:oibaf/graphics-drivers
                      [sudo] password for boby: 
                      Updating packages lists
                      PPA to be removed: oibaf graphics-drivers
                      Warning:  Could not find package list for PPA: oibaf graphics-drivers
                      [email protected]:~$
                      What should i do ? sos ...---...

                      Comment

                      Working...
                      X