Announcement

Collapse
No announcement yet.

AMD Preps To Upstream More AMDKFD HSA Kernel Driver Changes

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • AMD Preps To Upstream More AMDKFD HSA Kernel Driver Changes

    Phoronix: AMD Preps To Upstream More AMDKFD HSA Kernel Driver Changes

    AMD has sent out 14 new patches today for the AMDKFD HSA kernel driver in material that should be targeting Linux 4.16...

    http://www.phoronix.com/scan.php?pag...y-4.16-Patches

  • #2
    Finally....in 2018. After the initial "Fusion" era and the early APUs after the ATI purchase to the setting up of the HSA Foundation not to mention all these years of OpenCL. 2018-2020 is going to be QUITE exciting in Linuxland !!

    Comment


    • #3
      Originally posted by Jumbotron View Post
      Finally....in 2018. After the initial "Fusion" era and the early APUs after the ATI purchase to the setting up of the HSA Foundation not to mention all these years of OpenCL. 2018-2020 is going to be QUITE exciting in Linuxland !!
      Yes, it has been a very long road waiting for this compute stuff to happen. I can only hope that this (or something like it) becomes the standard and is available widely!

      Comment


      • #4
        Seeing these changes coming up, this past weekend I moved from radeon to amdgpu. As I see it, without writing custom code, the real way to see my 7850 come into it's own is when OpenCL starts using HSA / AMDKFD. However when I try to look at this, I see a host of extra stuff involved, and don't know what's necessary and what's not. This is Gentoo, so I'm building mesa-17.1.10 with the opencl USE flag, and llvm-3.9.1-r1 and clang-3.9.100 have the LLVM_TARGETS include AMDGPU. The virtuals for opencl don't mention 1.2 or 2.x, which I thought were the relevant versions. However when I specifically try to pull in amdgpu-pro-opencl-17.40.492261 I also get ocl-icd-2.2.11 - which is the first number that looks like something I'd expect. But I still don't know if any of the other versions are correct.

        Does someone have a description of the software stack and versions necessary to get OpenCL running on HSA / AMDKFD? (on Gentoo, if that wasn't obvious)

        Comment

        Working...
        X