Announcement

Collapse
No announcement yet.

OpenGL 4.2 Support Could Soon Land For AMD Cayman GPUs On R600g

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • #11
    Originally posted by xpris View Post
    So my HD5850 get it yes?
    Yes,
    https://en.wikipedia.org/wiki/List_o...ocessing_units
    lists your chip as DP capable in hardware, so you already should have OpenGl 4.x advertised by the driver (at least 4.0). According to mesamatrix everything else in r600 is finished up to 4.1.

    Fan rotation is a different chapter but if it is always at 100%, no matter the load (you can check w. radeontop), then you might want to file a bug report. Maybe some vendors rewired something or used different chips around the main chip on the board?
    Stop TCPA, stupid software patents and corrupt politicians!

    Comment


    • #12
      If someone would have asked me this time last year i would have guessed the R600G would have reached OpenGL 4.5 before the end of 2017.
      2016 things happened very fast with graphics extensions and OpenGL versions getting ticked of at a high paste, then radv vulkan driver happened so R600G more or less stalled.
      Now that radv is in such a good shape i am pleased to see r600g development speeding up again and extensions getting ticked of.
      My r600 hardware works great except Alien Isolation that needs ARB_compute_shader extension from OpenGL4.3, i guess that one will take some time still.
      Without ARB_compute_shader it looks like this.
      https://www.youtube.com/watch?v=n35hwmN3VmQ

      Comment


      • #13
        I don't even own an old card, but I think this is amazing! You guys really set the bar high for other operating systems. 👍 💯

        Comment


        • #14
          Originally posted by Nille_kungen View Post
          If someone would have asked me this time last year i would have guessed the R600G would have reached OpenGL 4.5 before the end of 2017.
          2016 things happened very fast with graphics extensions and OpenGL versions getting ticked of at a high paste, then radv vulkan driver happened so R600G more or less stalled.
          Now that radv is in such a good shape i am pleased to see r600g development speeding up again and extensions getting ticked of.
          My r600 hardware works great except Alien Isolation that needs ARB_compute_shader extension from OpenGL4.3, i guess that one will take some time still.
          Without ARB_compute_shader it looks like this.
          https://www.youtube.com/watch?v=n35hwmN3VmQ
          I think Dave has patches already for compute and SSBO support, which I assume will likely get upstreamed soon since he's merging all the other code. That would provide full 4.3 support and should work for almost all games, if you have the native double support or bypass it.

          Comment


          • #15
            Alien:Isolation with r600g would be fantastic.
            Originally posted by Jabberwocky View Post
            You guys really set the bar high for other operating systems.
            On Windows, Alien:Isolation works fine with Evergreen/NI cards.

            Comment


            • #16
              Originally posted by chithanh View Post
              Alien:Isolation with r600g would be fantastic.
              On Windows, Alien:Isolation works fine with Evergreen/NI cards.
              Do you know what extensions are required for it to work? I can't access their forums because it's down: http://forums.alienisolation.com/for...80-game-engine

              Comment


              • #17
                Can we have this for barts? Pretty please with sugar on top.

                Comment


                • #18
                  Originally posted by torsionbar28 View Post
                  Article says not for HD5000 series due to no fp64. Your 5770 does not have fp64 capable hardware, so it will never support OpenGL 4.2.
                  Not true! OpenGL 4.2+ is supported with those cards with the Windows drivers and old fglrx drivers for Linux, just not the current MESA drivers. On Windows I have OpenGL 4.5 working with an HD5670

                  Comment


                  • #19
                    Originally posted by Jabberwocky View Post

                    Do you know what extensions are required for it to work? I can't access their forums because it's down: http://forums.alienisolation.com/for...80-game-engine
                    I wrote it a few posts earlier
                    Originally posted by Nille_kungen View Post
                    My r600 hardware works great except Alien Isolation that needs ARB_compute_shader extension from OpenGL4.3, i guess that one will take some time still.

                    Comment


                    • #20
                      Originally posted by Rallos Zek View Post
                      Not true! OpenGL 4.2+ is supported with those cards with the Windows drivers and old fglrx drivers for Linux, just not the current MESA drivers. On Windows I have OpenGL 4.5 working with an HD5670
                      true. fglrx and windows driver provide sofware emulation for fp64. did you read article?

                      Comment

                      Working...
                      X