Announcement

Collapse
No announcement yet.

OpenGL 4.2 Support Could Soon Land For AMD Cayman GPUs On R600g

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • OpenGL 4.2 Support Could Soon Land For AMD Cayman GPUs On R600g

    Phoronix: OpenGL 4.2 Support Could Soon Land For AMD Cayman GPUs On R600g

    David Airlie is looking to land OpenGL image support in the R600 Gallium3D driver that would be enabled for Radeon HD 5000 "Evergreen" GPUs and newer. For the HD 6900 "Cayman" GPUs, this would be the last step taking it to exposing OpenGL 4.2 compliance...

    http://www.phoronix.com/scan.php?pag...-Image-Patches

  • #2
    fp64 is only 'waiting' for these former steps.
    https://cgit.freedesktop.org/~airlie...pu_shader_fp64 and other trees from David
    Last edited by nuetzel; 11-15-2017, 11:24 AM. Reason: Make it more clear. - But Dave mailed it already.

    Comment


    • #3
      > fp64 is only 'waiting' for these former steps.

      what steps?

      Comment


      • #4
        My HD5770 has been looking forward to the moment ....

        Comment


        • #5
          Originally posted by tsuru View Post
          My HD5770 has been looking forward to the moment ....
          Article says not for HD5000 series due to no fp64. Your 5770 does not have fp64 capable hardware, so it will never support OpenGL 4.2.

          Comment


          • #6
            for people with non-fp64 gpu, MESA_GL_VERSION_OVERRIDE and MESA_GLSL_VERSION_OVERRIDE will allow GL4.2 apps to work, and so on once we get GL4.3 done.

            soft fp64 will happen eventually, but I'd like to finish up the hw features first.

            Comment


            • #7
              I'm still using a Radeon HD 6970, so I'm very happy about this. Thanks, David Airlie (and everyone else involved)!

              Comment


              • #8
                Very good to read. Even though I also have a few more modern chips I highly welcome this addition for my older chips. Be it my HD 5670 or some Laptop-E-350 (that couldn't be upgraded), or one of my older chips.
                Stop TCPA, stupid software patents and corrupt politicians!

                Comment


                • #9
                  So my HD5850 get it yes? My gpu support fp64. It is supported not only in HD6900 but also on HD5800+ (HD5830/5850/5870/5970).

                  Anyway I have still strange issue on DRM/Radeon when my GPU fan working on 100% speed and this issue not exist on fglrx or even on Windows...

                  Comment


                  • #10
                    Originally posted by xpris View Post
                    So my HD5850 get it yes? My gpu support fp64. It is supported not only in HD6900 but also on HD5800+ (HD5830/5850/5870/5970).

                    Anyway I have still strange issue on DRM/Radeon when my GPU fan working on 100% speed and this issue not exist on fglrx or even on Windows...
                    Afaik yes though get involved with pre-release testing to make sure it's properly exposed on your hardware if it's there

                    Comment

                    Working...
                    X