Announcement

Collapse
No announcement yet.

UVD Video Decode Patches For AMDGPU With GCN 1.0 / Southern Islands

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • UVD Video Decode Patches For AMDGPU With GCN 1.0 / Southern Islands

    Phoronix: UVD Video Decode Patches For AMDGPU With GCN 1.0 / Southern Islands

    One of the missing features if you are using a GCN 1.0 "Southern Islands" graphics card and want to use the AMDGPU DRM driver rather than Radeon DRM is that UVD video decoding is currently unsupported. But there's new patches to fix that...

    http://www.phoronix.com/scan.php?pag...-AMDGPU-SI-UVD

  • #2
    Brilliant news!

    Comment


    • #3
      What's left for parity after this gets merged?
      ## VGA ##
      AMD: X1950XTX, HD3870, HD5870
      Intel: GMA45, HD3000 (Core i5 2500K)

      Comment


      • #4
        testing...

        Testing should be all that is left...

        And that isn't a small job...

        Comment


        • #5
          Originally posted by grigi View Post
          Testing should be all that is left...
          you could skip testing if you have no intention to fix found issues

          Comment


          • #6
            So great to see the conversation between the developers in the mailing list.
            It looks like new firmware from AMD is needed.

            Comment


            • #7
              I'm just hoping that they get the system hang issues in amdgpu for SI fixed as well. At least with 4.13 using AMDGPU on SI (PITCAIRN) leads to eventual system hangs after the monitors go to sleep occasionally for me. I.e. leave for work, and there's a chance that when I get home my system is hung.

              Comment


              • #8
                Originally posted by oskar-n View Post
                It looks like new firmware from AMD is needed.
                It's not really "new firmware" AFAIK - it's just that we put a header on the front of each file these days and amdgpu expects it, so the existing microcode image needs one of those headers tacked onto the front.

                Comment


                • #9
                  Yeah, but there's also a comment from Christian later in that series that implies that new firmware that handles 40-bit addressing was never released and is required.

                  Comment


                  • #10
                    Nice to see there is still support for these "old" cards. I am still using my HD 7950 and i have not plans to change it soon.

                    Originally posted by Veerappan View Post
                    I'm just hoping that they get the system hang issues in amdgpu for SI fixed as well. At least with 4.13 using AMDGPU on SI (PITCAIRN) leads to eventual system hangs after the monitors go to sleep occasionally for me. I.e. leave for work, and there's a chance that when I get home my system is hung.
                    amdgpu for SI is still unstable, the vulkan part at least. Every time I try to play Retroarch using the vulkan backend i have a system hang.

                    Comment

                    Working...
                    X