Announcement

Collapse
No announcement yet.

amdgpu change pci 2 to 3

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • amdgpu change pci 2 to 3

    Hello,
    by default amdgu only use pci gen2, i want switch to gen 3, but i dont know how.

    amdgpu 2.4.82-1, linux-4.13-r4, mesa 17.3-dev and motherboard 2 slot pcie x16 gen3

    lspci -vv:
    LnkCap: Port #0, Speed 8GT/s, Width x16, ASPM L0s L1, Exit Latency L0s <64ns, L1 <1us
    ClockPM- Surprise- LLActRep- BwNot- ASPMOptComp+
    LnkCtl: ASPM Disabled; RCB 64 bytes Disabled- CommClk+
    ExtSynch- ClockPM- AutWidDis- BWInt- AutBWInt-
    LnkSta: Speed 5GT/s, Width x16, TrErr- Train- SlotClk+ DLActive- BWMgmt- ABWMgmt-
    DevCap2: Completion Timeout: Not Supported, TimeoutDis-, LTR-, OBFF Not Supported
    DevCtl2: Completion Timeout: 50us to 50ms, TimeoutDis-, LTR-, OBFF Disabled
    LnkCtl2: Target Link Speed: 5GT/s, EnterCompliance- SpeedDis-


    cat /sys/kernel/debug/dri/0/amdgpu_pm_info
    power level 2 sclk: 116500 mclk: 120000 vddc: 1225 vddci: 975 pcie gen: 2


    modinfo amdgpu:
    amdgpu.pcie_gen2= (i set 0, nothing change)
    amdgpu.pcie_gen_cap= (i dont know what set)
    amdgpu.pcie_lane_cap= (i dont know what set)



    if you know how.

  • #2
    Mainline kernel do have partially implemented amdgpu driver. Use this kernel:
    https://cgit.freedesktop.org/~agd5f/...-next-4.14-wip

    Comment


    • #3
      Tested same result, i dont understand.
      Someone can test if: amdgpu.pcie_gen2=0/1 any effect ?
      cat /sys/kernel/debug/dri/0/amdgpu_pm_info

      Maybe its SI problem, my card is hd 7850.
      (All amdgpu case selected in graphics in kernel)

      And second problem, for clock, sclk: 116500 mclk: 120000 vddc: 1225
      I have overclocked bios gpu, voltage and sclk is just (and i have more perf is work), but mclk is locked (old) stock max freq, bios modified memory is 1375 or 14x0 i dont remember.

      I think somewhere in kernel the memory clk is locked 120000 value, like this for old kernel:
      https://gist.github.com/Francesco149...e17d3c13257929
      I cant apply because its old kernel not same for now.
      Last edited by kripteks; 08-09-2017, 12:56 AM.

      Comment


      • #4
        amdgpu.pcie_gen2 option doesn't do anything. That option is just a leftover from radeon for manually forcing the pcie speed. When dpm is active it should switch between pcie speeds dynamically based on GPU load.

        Comment


        • #5
          Problem is never change, stay always 2.

          Comment


          • #6
            Some news:
            i have buy new x79 board (not noname (asus)) and its working perfectly to 8/gt pci3 automaticaly, so i think is the old x79 have bios force limit to pcie2 5/g (i send mail for support but answer stopped its other story).

            I have no check the overclocking gpu/mem statues (maybe today i check that and edit post), i have new card 7970 (bad performance, 20% more than 7850 but i think is lower performance comparate theorique stats cards).




            @debianxfce
            amd 4.14-wipe last change: 2017-08-28.
            linux-next-0913 last change more recent.

            The changes from 4.14-wipe is included in linux-next-0913 or 4.14-wipe is more recent ?

            (4.15-wipe is the last most recent i think i go compile this.)

            And for non debug kernel (in your posts in forum), how i can do that ?
            Is menu (make menuconfig): kernel hacking > uncheck "Kernel debugging" ? or other/more ?


            Thanks.
            Last edited by kripteks; 09-13-2017, 08:26 AM.

            Comment


            • #7
              Originally posted by kripteks View Post
              Some news:


              @debianxfce
              amd 4.14-wipe last change: 2017-08-28.
              linux-next-0913 last change more recent.

              The changes from 4.14-wipe is included in linux-next-0913 or 4.14-wipe is more recent ?

              (4.15-wipe is the last most recent i think i go compile this.)

              And for non debug kernel (in your posts in forum), how i can do that ?
              Is menu (make menuconfig): kernel hacking > uncheck "Kernel debugging" ? or other/more ?


              Thanks.
              Use make xconfig (it needs autoconfig and qt4-dev- packages). Disable EXPERT then you can disable KERNEL_DEBUG. xconfig shows dependencies.kernel 4 .15-wip is the latest, it came after my post.
              https://cgit.freedesktop.org/~agd5f/...-next-4.15-wip

              Comment


              • #8
                Well i test clocks: same 7850, memory overclocking not work.
                Bios flashed gpu 925 to 1050 and memory 1375 to 1575 voltage 1.20, result:
                power level 0 sclk: 34400 mclk: 137600 vddc: 1200 vddci: 875 pcie gen: 3
                power level 2 sclk: 105000 mclk: 137600 vddc: 1200 vddci: 875 pcie gen: 3

                ps: bios overclocking result is correct in windows 1050, 1575, 1.2
                Last edited by kripteks; 09-13-2017, 01:31 PM.

                Comment

                Working...
                X