Announcement

Collapse
No announcement yet.

amd-mainline-hybrid builds for Fedora (amdgpu)

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • cde1
    replied
    Originally posted by debianxfce View Post

    Here you are: http://www.filehosting.org/file/deta...ig-4.16.0-rc7+

    Tell me when I can delete it. You are not using a non debug 1000Hz timer kernel. Cpu frequency scaling slows down, disable it and control you hw with bios. My kernel config is for gaming.
    Thanks, I've downloaded it.

    Leave a comment:


  • cde1
    replied
    Originally posted by debianxfce View Post

    Creating a custom kernel image package is easy, fun and very useful. Then you can tune the kernel for your computer. A custom 1000Hz timer non debug kernel is much faster than distributions kernels. Here is how to do it in Debian, differences with other distributions is not so many. https://www.youtube.com/watch?v=G3AxgH2bbsE
    Hello debianxfce,

    I just yesterday built a minimalist kernel to test WattMan, haven't done so since at least a year or so. Was a bit perplexed by some options, could you please share your own .config? I'm interested to see what works best for you. I've also pasted mine: https://hastebin.com/upitepejoh.ini , feel free to comment on it.

    Leave a comment:


  • jpenguin
    replied
    I haven't had HDMI sound since your last kernel, someone is updating this for ubuntu- but I don't want to go back there; I can't wrap my head around the kernel compilation steps https://github.com/M-Bab/linux-kernel-amdgpu

    EDIT: The instructions are scaryer than building the acual kernnel, it works! Took awwhile though, even on my ryzen 1700X. I don't have to plug in my USB sound card
    Last edited by jpenguin; 05-19-2018, 10:32 PM.

    Leave a comment:


  • hopelessone
    replied
    also after it for Fedora 27..

    Leave a comment:


  • MDKnight
    replied
    Mystro256 I was wondering if you plan on packaging the mainline hybrid kernel for Fedora 27 at some point.

    Leave a comment:


  • Deuterium Oxide
    replied
    Since I can't seem to find the edit function, I'll just reply to myself - Elegance!

    After a little back-and forth, I just went ahead with the copr che/mesa and che/llvm - It turned out to work just swanky, provided I enabled both the 32 and 64 bit versions. With only the 64 bit repo, a lot of dependencies were missing but upon inspection those were mostly of 32-bit packages.

    Anyhow, my Vega 56 is now chugging along just swanky, though getting freesync seems beyond my modest capabilities

    Leave a comment:


  • Deuterium Oxide
    replied
    Mystro256 - I much appreciate your work on packaging a patched kernel for Fedora 26, thank you!

    However, I've run into some snags: I'm attempting to use the amd-mainline-kernel to run my brand spanking new Vega 56. Running glxgears, I get the expected:

    Code:
    amdgpu: LLVM 5.0 is required, got LLVM 4.0
    And the slightly more mysterious:

    Code:
    do_winsys_init: DRM version is 3.18.0 but this driver is only compatible with 2.12.0 (kernel 3.2) or later.
    In any case, the Vega stuff is present in LLVM 5 - My feeble google-fu seems has not revealed to me how to best go about running a later version of LLVM than the default F26 one (4.0.1). Trying che/llvm and che/mesa seems to require removing a lot of dependencies that sound highly likely to break stuff, and just doing a "make install" might be pretty hard to clean up after. Any tips on how to go ahead?

    Leave a comment:


  • Mystro256
    replied
    Originally posted by finalzone View Post

    Yes, 4.12.8 staging kernel runs on my system with extra parameter "amdgpu.cik_support=1 radeon.cik_support=0".
    It seems amdgpu CIK is not enabled by default unlike the AMD mainline kernel.
    Mainline should have SI and CIK enabled by default IIRC. Unfortunately I can't reproduce this issue. I would guess making a bug report on freedesktop's bugzilla or message agd5f directly.

    Leave a comment:


  • finalzone
    replied
    Originally posted by Mystro256 View Post
    Are you able to run the latest 4.12.8 staging kernel? No one has complained, so I assume that one still works too.
    Yes, 4.12.8 staging kernel runs on my system with extra parameter "amdgpu.cik_support=1 radeon.cik_support=0".
    It seems amdgpu CIK is not enabled by default unlike the AMD mainline kernel.

    Leave a comment:


  • Mystro256
    replied
    Originally posted by finalzone View Post
    Attempting to run kernel 4.12.8-20170825 led to a boot stuck with message "unable to access UEFI db".
    Thanks, I haven't had time to test it after it was rebased to 4.12, I plan to look into it this weekend.

    Are you able to run the latest 4.12.8 staging kernel? No one has complained, so I assume that one still works too.

    Leave a comment:

Working...
X