Announcement

Collapse
No announcement yet.

Trouble wtth a Radeon 7750, Ubuntu 16.04.2, kernel 4.11 and Ryzen.

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Trouble wtth a Radeon 7750, Ubuntu 16.04.2, kernel 4.11 and Ryzen.

    Howdy folks.

    Running Ubuntu 16.4.2 LTS (due to scientific tools) on a 4.11 kernel. - only customised so that Ryzen will work properly on my Gigabyte m. board.

    I need someone with more experience with xorg than me. I have the following system:
    lspci -nnk | grep -i vga -A3

    09:00.0 VGA compatible controller [0300]: Advanced Micro Devices, Inc. [AMD/ATI] Cape Verde PRO [Radeon HD 7750/8740 / R7 250E] [1002:683f]
    Subsystem: Gigabyte Technology Co., Ltd Cape Verde PRO [Radeon HD 7750/8740 / R7 250E] [1458:2551]
    09:00.1 Audio device [0403]: Advanced Micro Devices, Inc. [AMD/ATI] Cape Verde/Pitcairn HDMI Audio [Radeon HD 7700/7800 Series] [1002:aab0]
    Subsystem: Gigabyte Technology Co., Ltd Cape Verde/Pitcairn HDMI Audio [Radeon HD 7700/7800 Series] [1458:aab0]
    Which is all detected, but for some reason the radeon won't load. Tried both obaif, and papa.

    Tried to use /etc/X11/xorg.conf to override the settings, to see if it would load, but no success.

    https://pastebin.com/Rq7zyJ4s Dmesg.I

    https://pastebin.com/YQceq8qz X.log


    I previously had AMD-GPU-pro installed but I uninstalled it. I tried looking for any remaining blacklisting, but can't find any.

    The problem came after I switched motherboards, from MSI to gigabyte, and had to recompile a new kernel to get out of IRQ 7 loop.


    I get an error if I try to configure X,

    https://pastebin.com/7F6yjGRw


    Seems to me it tries to load the radeon driver, but doesn't follow through, and drops it. And then switches to VESA. But hey, this ain't my specialty.

    Any help is appreciated.

    Kind regards

    Brut.

  • #2
    Well, post kernel config since it is custom build, maybe you didn't enable something there.

    Comment


    • #3
      Hi Dungeon.

      Thanks for taking the time to help.

      Here is the .config. I assume it's the one you want. If not please let me know.

      Kind regards.

      B.

      Comment


      • #4
        Looks fine, so no idea... ther must be radeon something in dmesg and since that is not there prob is with kernel something, maybe initramfs prob or well something blacklisting it.
        Last edited by dungeon; 05-08-2017, 03:44 PM.

        Comment


        • #5
          Thanks for the effort, I guessed as much as well. Problem is I can't figure out what the cause is. I looked through the blacklist files, and nowhere is radeon or amdgpu listed. I have 3 other pc with almost identical setups and kernels, just newer gfx cards, and they don't have this problem. I guess I am up for a complete reinstall, if there is no one else with some good suggestions.

          Kind regards

          B.

          Comment


          • #6
            If you have a BIOS option to disable IOMMU please try that. Something definitely looks odd - there aren't even any drm messages.

            Comment


            • #7
              Originally posted by bridgman View Post
              If you have a BIOS option to disable IOMMU please try that. Something definitely looks odd - there aren't even any drm messages.
              https://pastebin.com/NJcmudSs dmesg after iommu was disabled. Some red flags came up, is this the cause?


              57] [Firmware Bug]: AMD-Vi: IOAPIC[17] not in IVRS table
              [ 0.040061] [Firmware Bug]: AMD-Vi: IOAPIC[18] not in IVRS table
              [ 0.040062] [Firmware Bug]: AMD-Vi: No southbridge IOAPIC found
              [ 0.040063] AMD-Vi: Disabling interrupt remapping


              Comment


              • #8
                They are all AMD-Vi messages and I would expect AMD-Vi to be affected by turning off IOMMU, so at first glance at least I don't think that was the problem.

                I was going to try bringing up my Ryzen systems with stock Ubuntu 17.04 as a first step - might be worth giving that a try ?

                Comment


                • #9
                  Thanks for the effort.
                  I guess I'll reinstall 16.04.2 again, I need Neurodebian and other neuroimaging tools for ubuntu for work, so 17.04 is no joy yet. I might try to shuffle some of the gfx cards from the other computers. And gigabyte mboards s*** when it comes to out of the box linux support. Having to compile the kernel with some GPIO parameter off, to get it to work, is only fun when you have a Ryzen and remember the J16 parameter....

                  Kind regards.

                  B.

                  Comment


                  • #10
                    Try Debian Stretch neuro packages are available for that...

                    Of course that is not stable yet, cos of bugs Debian X maintainers actually decided to revert back to legacy X setuid Xorg by default for Stretch... maybe Michael should write a news about

                    Comment

                    Working...
                    X