Announcement

Collapse
No announcement yet.

Vulkan on mesa

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Vulkan on mesa

    I have R5 M330 and integrated R3 mullins and I can't try out Vulkan demos. After trying to run dota2 with -vulkan flag i get error "Failed to initialize Vulkan. Plase make sure that your GPU supports Vulkan.". When trying to run vulkaninfo, I get this error:
    /build/vulkan-WFoCfr/vulkan-1.0.42.0+dfsg1/demos/vulkaninfo.c:1523: failed with VK_ERROR_INITIALIZATION_FAILED

    Is my hardware unsupported or am I going something wrong?
    Last edited by paupav; 04-19-2017, 10:25 AM.

  • #2
    MULLINS is a CIK (Sea Islands) part. You need a kernel compiled with CONFIG_DRM_AMDGPU_CIK and use amdgpu kernel driver instead of radeon.

    Comment


    • #3
      Ok, I have 4.10.0-19, i believe it has CIK enabled because lspci -v shows it as available for both R3 and R5:
      Kernel driver in use: radeon
      Kernel modules: radeon, amdgpu

      I can't blacklist radeon driver. I've tried adding radeon.blacklist=yes in grub, adding "blackilist radeon" to /etc/modprobe.d/blacklist.conf, but it is still using radeon module.

      Comment


      • #4
        Originally posted by paupav View Post
        Ok, I have 4.10.0-19, i believe it has CIK enabled because lspci -v shows it as available for both R3 and R5:
        Kernel driver in use: radeon
        Kernel modules: radeon, amdgpu

        I can't blacklist radeon driver. I've tried adding radeon.blacklist=yes in grub, adding "blackilist radeon" to /etc/modprobe.d/blacklist.conf, but it is still using radeon module.
        Append modprobe.blacklist=radeon to the kernel command line in grub.

        Comment


        • #5
          Make a custom kernel and check your xorg.conf files. See
          https://www.phoronix.com/forums/foru...in-living-room

          Comment


          • #6
            Originally posted by agd5f View Post

            Append modprobe.blacklist=radeon to the kernel command line in grub.
            This worked , i thought that syntax was radeon.blacklist=yes
            But, It seems that Dota 2 doesn't work with amdgpu

            Thank you!

            Comment


            • #7
              Do you have a copy of Mesa with radv enabled in the build ? If not then you still won't have Vulkan support.

              AFAIK Dota2 does work with radv.

              Comment


              • #8
                After updating Mesa from Oibaf's repository it seems to be working, thank you

                Comment

                Working...
                X