Announcement

Collapse
No announcement yet.

OpenArena, 100 fps with default graphics, but 60fps with HD6450 installed.

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • #11
    Lets compare R3/HD 8400 that would be similar to that DDR3 HD 6450 on that older OpenArena:

    http://openbenchmarking.org/result/1...RI-OLDARENA700

    83 fps with mesa... lets reboot to test FGRLX on D8...

    http://openbenchmarking.org/result/1...RI-1703198RI84

    So we have/had there 102 fps on fglrx...

    Hmm, i have one install as pure 32bit OS on on disk... lets try it there also
    Last edited by dungeon; 03-19-2017, 04:46 PM.

    Comment


    • #12
      I knew i am up to something, get even 142 fps on 32bit OS

      http://openbenchmarking.org/result/1...RI-1703196RI22

      Eldest the greatest ... so anything in range of 75 to 150 fps results for HD 6450 won't surprise me

      Comment


      • #13
        Be careful to compare apples to apples. Those boards could be configured with either DDR3 or GDDR5 memory. DDR3 is substantially slower than GDDR5.

        Comment


        • #14
          Originally posted by agd5f View Post
          Be careful to compare apples to apples. Those boards could be configured with either DDR3 or GDDR5 memory. DDR3 is substantially slower than GDDR5.
          Yep GDDR5 model could be up to plus 40% here and there. I was careful since Michael's model was indeed DDR3... for the OP's model i dunno of course





          http://www.phoronix.com/scan.php?pag..._radeon_hd6450

          HD 8400 from top Jaguar APU should be somewhere like 6450 DDR3 model and indeed it performs in range like that with mesa. But somehow with FGLRX when running under 32bit OS openarena behave more like 6450 GDDR5 model and even better than that

          I tried running 32bit binary under multiarched 64bit OS and there 32bit binary is still much slower than on pure 32bit OS, so likely some indirect software slowmo happen there, but is quite large going from 100 to 140 fps
          Last edited by dungeon; 03-20-2017, 04:42 PM.

          Comment


          • #15
            And finally i can conclude that phoronix-test-suite just breaks blob profiles when on 64bit OS

            On 32bit OS same bench, same config, same demo i maded out running total manually gives 145 fps which is in range of pts's 142 so that is considered OK or in range of standard acceptable deviation... But on 64bit OS 64 binary gives now 140 fps and not 100 like with pts Without profiles by renaming binaries 32bit has 102 fps and 64bit has 112 fps actually... blah.

            On average that is it, pts just do something very weird when run on 64bit OS, breaks profiles somehow and even runs slower than without profile, WTF!

            But let me recheck mesa on 64bit again without pts...
            Last edited by dungeon; 03-20-2017, 06:17 PM.

            Comment


            • #16
              Originally posted by dungeon View Post
              But let me recheck mesa on 64bit again without pts...
              OK isn't profiles, but more general as it does something weird on 64bit for both drivers - Mesa = 83 fps with pts, same thing without pts i get 117 fps

              So 32bit OS somehow does not hit this PTS's issue

              Comment

              Working...
              X