Announcement

Collapse
No announcement yet.

AMDGPU vs. Radeon GCN 1.0/1.1 Benchmarks With Linux 4.10

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • AMDGPU vs. Radeon GCN 1.0/1.1 Benchmarks With Linux 4.10

    Phoronix: AMDGPU vs. Radeon GCN 1.0/1.1 Benchmarks With Linux 4.10

    With the Linux 4.10 kernel there remains experimental Kconfig switches for being able to build the Linux kernel with GCN 1.0 "Southern Islands" and GCN 1.1 "Sea Islands" support in the newer AMDGPU DRM driver rather than the mature Radeon DRM driver. For your viewing pleasure today are benchmarks of a few GCN 1.0/1.1 GPUs when testing the Linux 4.10 Git kernel with Radeon DRM and then the experimental AMDGPU DRM driver while both kernel drivers were tested in conjunction with the same Mesa 13.1-dev snapshot as of this week.

    http://www.phoronix.com/vr.php?view=23969

  • #2
    I'm also happy with my 290 on amdgpu only, for month already.

    Comment


    • #3
      During the AMDGPU testing in dmesg after testing I did see a number of GPU faults reported, but as shown from the results, they didn't appear to negatively impact the performance.
      There is an impact actually, just on slower CPU interrupts are likely more noticable... of course worse case is if continuosly happen in some case, probably might lead even up to 25% less perf

      On article in whole, beside that Hawaii half-issue... it is boring
      Last edited by dungeon; 01-04-2017, 12:28 AM.

      Comment


      • #4
        I've got a R9-290X using stable Padoka 13.0.2... should I use 13.1 with linux 4.9-10 with amdgpu? Am I missing out on anything? I never had the same problems as Mike with the radeonsi driver.

        I have noticed though that running Unigine tests extensively or Metro redux for some length of time crashes my system. But I've played Mad Max (20hrs) and Tomb Raider (completely) and never had a crash with those games!? Just Unigine tests and Metro Redux.
        Last edited by DanglingPointer; 01-04-2017, 01:45 AM.

        Comment


        • #5
          Originally posted by DanglingPointer View Post
          I've got a R9-290X using stable Padoka 13.0.2... should I use 13.1 with linux 4.9-10 with amdgpu? Am I missing out on anything? I never had the same problems as Mike with the radeonsi driver.
          Well, maybe Michael should try that stable Padoka

          I have noticed though that running Unigine tests extensively or Metro redux for some length of time crashes my system. But I've played Mad Max (20hrs) and Tomb Raider (completely) and never had a crash with those games!? Just Unigine tests and Metro Redux.
          There is one tiny patch that stabilze things, which is not yet in that 13.0.x stable:

          https://cgit.freedesktop.org/mesa/me...8c4f370be98dea

          But there are other potentional issues in git as always , you can inform yourself about those if you visit bugzilla, etc...

          Comment


          • #6
            Michael How do you test with CS:GO? I try and I only get a message about VAC. How do I get the actual benchmark to work? Thanks in advance.

            Comment


            • #7
              Originally posted by LinuxID10T View Post
              Michael How do you test with CS:GO? I try and I only get a message about VAC. How do I get the actual benchmark to work? Thanks in advance.
              Hmm? There should be no VAC for linux at all. Can you tell what the message says?

              Comment


              • #8
                Originally posted by dungeon View Post
                On article in whole, beside that Hawaii half-issue... it is boring
                Looks like pitcairn is in better shape then before. So it's no boring for pitcairn owners too

                Comment


                • #9
                  Originally posted by FishPls View Post

                  Hmm? There should be no VAC for linux at all. Can you tell what the message says?
                  For anyone who wants to see, here is a link. Same thing happens on all computers tested, this is not a one off.

                  http://imgur.com/a/zWb50

                  Comment


                  • #10
                    It partially ended up being a PTS problem. I removed and purged PTS and then it worked. And by worked I mean The Benchmark worked but the message still remained

                    Comment

                    Working...
                    X