Announcement

Collapse
No announcement yet.

Compiz-fusion and the 8.9 driver?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • bundyo
    replied
    Originally posted by TheIcebreaker View Post
    Which distro u using. Are you on F9??
    If yes from which repository did you install 7.8
    Or did you compile from source.
    openSUSE 11, Compiz installed from CyberOrg's repository.

    Leave a comment:


  • fred
    replied
    Thank's a lot

    If the Mandriva QA are on it I'm optimistic that they will find
    a solution

    Since you are the one working on this ticket don't forget to mention

    that if you try XGL instead of AIGLX for some unknown reason the system switch to the radeonHD driver (without changing xorg.conf ????) I know I have checked!

    I know it's sound weird but that's what it does

    this bug is reproducible with mandriva 2008.1 and 2009 cooker and that kde 4.1 with 2009 cooker is extremely slow and unresponsive! this bug is reproducibles with the 8.8 and 8.9 driver.

    Leave a comment:


  • NickBrown
    replied
    https://qa.mandriva.com/show_bug.cgi?id=44373

    This appears to not work with 8.8 or 8.9 and compiz of compiz-fusion.

    Leave a comment:


  • fred
    replied
    Ok here an update

    I tested the 8.7 8.8 8.9 driver on two machine one with a hd3780 and hd 2600 pro AGP

    Both system are running Mandriva Linux 2008.1

    with the 8.7 driver compiz work great but the log out bug is present (X crash)
    with 8.8 and 8.9 no compiz KDE 4.1 is also extremely slow

    In all case 3D acceleration work fine without Compiz.

    So what change in the 8.8 and 8.9 driver that could cause this issue.

    PS: xorg.conf is exactly the same whit all those version

    Leave a comment:


  • enzobelmont
    replied
    it's working fine except for blur plugin in compiz, it doesn't work anymore.

    Leave a comment:


  • fred
    replied
    @ Legume

    Yes the libGL.so.1 link to libGL.so.1.2

    to the TheIcebreaker I'm running mandriva 2008.1 and fglrx usually work really well.

    I'm going to revert to the 8.8 and 8.7 driver to see which one work with compiz (I never tested the 8.8 driver) Then I will try to compare both Xorg.conf to see if anything is change.

    Leave a comment:


  • legume
    replied
    Originally posted by fred View Post
    nope still no compiz joy

    I really don't know how to fix this one
    Maybe it related to the fact that I have a hd2600 agp card?
    Long shot -

    ls -l /usr/lib/xorg/

    and make sure that the libGL.so.1 symlink points to libGL.so.1.2

    Leave a comment:


  • TheIcebreaker
    replied
    Originally posted by bundyo View Post
    Mine was crashing X too but its working fine now, after I upgraded Compiz to version 0.7.8.
    Which distro u using. Are you on F9??
    If yes from which repository did you install 7.8
    Or did you compile from source.

    Leave a comment:


  • fred
    replied
    nope still no compiz joy

    I really don't know how to fix this one
    Maybe it related to the fact that I have a hd2600 agp card?

    Leave a comment:


  • Tarmael
    replied
    I was getting a similar problem. Compiz worked, however as soon as I did anything full screen it crashed, then kept crashing.

    I tried running:
    Code:
    sudo aticonfig --set-pcs-str="DDX,EnableRandr12,TRUE"
    As listed in the article on the driver and it worked fine after that.

    Good luck,

    Bas.

    Leave a comment:

Working...
X