No announcement yet.

Compiz-fusion and the 8.9 driver?

  • Filter
  • Time
  • Show
Clear All
new posts

  • #11
    Another thing: after that i was getting the same crashes when was started. Disabling Textured2D option seems to resolve that and i suspect it will resolve your problem with Compiz 0.7.6 too. Maybe ATI broke that option somehow with the last release.


    • #12
      Hmmm how do you disable Texture2D?


      • #13
        In /etc/X11/xorg.conf usually If you don't have such an option, then it should be disabled already. It was the problem for me for sure, now my X is stable.


        • #14
          Hm, I have the same problem too. I tried lots of different Xorg.Conf configurations, nothing makes a diff..
          With 8.8, it complained about missing extension. In 8.9, it just hangs the X Server.
          KDE 4 desktop effects don't work as well.


          • #15
            I'm really by this situation and since I occasionally sell computer with Linux I would really like Compiz-fusion to work on my main rig![/QUOTE]


            Have you checked your xorg.conf to insure that the "Extensions" section was re-written by the 8-9 driver install? Specifically, make sure you still have:

            Section "Extensions"
            Option "Composite" "true"
            Option "DAMAGE" "true"

            Also, AIGLX is enabled by default in the recent drivers. Check to make sure with:

            grep -e ==.*AIGLX /var/log/Xorg.0.log

            If not, try setting:

            Section "ServerFlags"
            Option "AIGLX" "True"

            Good Luck


            • #16
              I was getting a similar problem. Compiz worked, however as soon as I did anything full screen it crashed, then kept crashing.

              I tried running:
              sudo aticonfig --set-pcs-str="DDX,EnableRandr12,TRUE"
              As listed in the article on the driver and it worked fine after that.

              Good luck,



              • #17
                nope still no compiz joy

                I really don't know how to fix this one
                Maybe it related to the fact that I have a hd2600 agp card?


                • #18
                  Originally posted by bundyo View Post
                  Mine was crashing X too but its working fine now, after I upgraded Compiz to version 0.7.8.
                  Which distro u using. Are you on F9??
                  If yes from which repository did you install 7.8
                  Or did you compile from source.


                  • #19
                    Originally posted by fred View Post
                    nope still no compiz joy

                    I really don't know how to fix this one
                    Maybe it related to the fact that I have a hd2600 agp card?
                    Long shot -

                    ls -l /usr/lib/xorg/

                    and make sure that the symlink points to


                    • #20
                      @ Legume

                      Yes the link to

                      to the TheIcebreaker I'm running mandriva 2008.1 and fglrx usually work really well.

                      I'm going to revert to the 8.8 and 8.7 driver to see which one work with compiz (I never tested the 8.8 driver) Then I will try to compare both Xorg.conf to see if anything is change.