Announcement

Collapse
No announcement yet.

AMD Catalyst 8.9 Gets WINE Fix, RandR 1.2 Support

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Melcar
    replied
    Originally posted by flami View Post
    hum I got another nice "feature" ^^:
    flikering lines on the top right part of my screen when I run anything that involves 3d

    Im going back 8.8 , Ill be back soon (tm)

    Distortion you mean, as in horizontal lines across the screen? That's nothing new. Even with vsync. on you can notice some level of distortion.
    It also happens with video playback, but that I think is another separate issue.

    Leave a comment:


  • Odur
    replied
    Originally posted by rbmorse View Post
    Works fine, here (Ubuntu 8.04) with my HD 3870.

    But, I'm not doing anything interesting.
    I too got a HD3870, and I can't switch users without getting a hard lock. Would you mind testing that?


    I wrote this about 20 minutes ago in bug report #112518 at Launchpad:
    I too got this bug and haven't found a solution yet.

    Dist: Kubuntu 8.04.1 Fully upgraded
    Graphics card: PowerColor (ATI) HD3870 SCS3
    Tested drivers: fglrx 8.3 through 8.9

    Symptoms: When switching user the screen goes black and the system is totally unresponsive, including the keyboard. Not even caps-lock trigges the caps-lock light. The only thing that works is the reset button and to hold the powerbutton until it shuts down. Shutdown or restart works without problem (I have fixed the problem with atieventsd, see bug 118605).
    If i use the vesa or radeonhd drivers everything is ok. But then I got no 3D acceleration, which I think would be nice...

    This bug is really annoying to me, as we are switching users a lot on this computer. It started when I bought this card. I got a ATI X600 before, and that didn't suffer from this bug at all.

    Anything else I could provide to help solving this bug, or at least get it triaged?

    Leave a comment:


  • flami
    replied
    Originally posted by flami View Post
    Well now "OffscreenRenderingMode fbo" works in wine again, so no stuff thats not supposed to on the screen appears in the bottom left, but I cant minimize or switch desktop anymore . I can interact with the desktop ( e.g. open something in the taskbar ) , but i cant see anything . It flickers for a second where i see the desktop , then wine's all over the place again .

    ( debian lenny , mobility x700 )
    hum I got another nice "feature" ^^:
    flikering lines on the top right part of my screen when I run anything that involves 3d
    ...
    Im going back 8.8 , Ill be back soon (tm)
    back to 8.8, fbo doesn't work anymore , but i can switch to the desktop from wine.
    those flickering lines ... I don't know , there still are some in ppracer, but theres less and they are not as big anymore. in wine they disappeared
    But before i upgraded to 8.9 I never had them.

    Leave a comment:


  • dokers
    replied
    AGP?

    Anyone try this driver with the AGP 3850 card yet? I haven't had success since the 8.05 driver? I'm on Hardy Heron. If I get a chance I'll try it in the next day or 2.

    Leave a comment:


  • flami
    replied
    hum I got another nice "feature" ^^:
    flikering lines on the top right part of my screen when I run anything that involves 3d

    Im going back 8.8 , Ill be back soon (tm)

    Leave a comment:


  • Kano
    replied
    Good idea to check this:

    ls -l /dev/dri/card0
    crw-r----- 1 root root 226, 0 2008-09-18 18:01 /dev/dri/card0

    Leave a comment:


  • storma
    replied
    Originally posted by Kano View Post
    That driver is fully crap for several reasons:

    a) Using Debian etch + Xorg 7.1.1

    OpenGL accelleration only works as root! The xorg.conf entry

    Section "DRI"
    Mode 0666
    EndSection

    Seems to be fully ignored. Absolutely unusable!
    Check your permissions on /dev/dri/card0

    Leave a comment:


  • Kano
    replied
    @Pfanne

    The errors I describe are independent of the GPU used. The PointSprites are missing since driver release 8.41.7, that's nothing new, I mentioned that 13 month ago already. And when the only change from one driver to the next is a extremely bad new error then you would not get angry, right? I am responsible for lots of ATI users who use Kanotix and I create patches for ATI drivers on my own if possible. But if the base is so bad then this is completely lost time. If a huge company can not even fix issues introduced over a year ago they lost completely. But to make you happy: the card i used is X700 Pro (RV410) chipset - one of the chipsets with the worst open source driver experience!

    Leave a comment:


  • flami
    replied
    Well now "OffscreenRenderingMode fbo" works in wine again, so no stuff thats not supposed to on the screen appears in the bottom left, but I cant minimize or switch desktop anymore . I can interact with the desktop ( e.g. open something in the taskbar ) , but i cant see anything . It flickers for a second where i see the desktop , then wine's all over the place again .

    ( debian lenny , mobility x700 )
    Last edited by flami; 18 September 2008, 11:36 AM.

    Leave a comment:


  • rbmorse
    replied
    Works fine, here (Ubuntu 8.04) with my HD 3870.

    But, I'm not doing anything interesting.

    Leave a comment:

Working...
X