Announcement

Collapse
No announcement yet.

AMD Releases Updated Catalyst Pro / FirePro Unified Driver For Linux

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • AMD Releases Updated Catalyst Pro / FirePro Unified Driver For Linux

    Phoronix: AMD Releases Updated Catalyst Pro / FirePro Unified Driver For Linux

    It looks like that AMD is going to continue maintaining their Catalyst-based Linux driver until the new AMDGPU-PRO driver architecture is up to scratch. That is, support for FirePro workstation users at least caring about stable support on Enterprise Linux distribution. A new Catalyst Pro / FirePro Unified driver for Linux was released this week...

    http://www.phoronix.com/scan.php?pag...ePro-July-2016

  • #2
    I wasn't aware that AMD was still maintaining this non-AMDGPU-PRO based alternative for FirePro users
    Back in may there was update there too and couple days back again... so yep they maintaining it.

    Comment


    • #3
      it is also for laptop ? i have W4190 in HP zbook 15u g3 ( HD520 IGP)

      Comment


      • #4
        AMD also still maintaining embedded Catalyst driver for Linux.

        So, If I good remember is working way to install both driver (catalyst pro and catalyst for embedded) and use it on basic desktop GPU,

        Comment


        • #5
          Originally posted by polo View Post
          it is also for laptop ? i have W4190 in HP zbook 15u g3 ( HD520 IGP)
          I guess not, should be for workstation GCN cards only... basically if your chip already worked with classic Catalyst, then it isn't supported with Catalyst Pro. There is clear separation what hardware is supported on which driver.

          Well unofficialy, users might try hackety hack to made this driver work on consumer hardware ... who knows it might fix something for those too

          Comment


          • #6
            Well it's professional cards, they need stability, I imagine there will be AMDGPU drivers for them later on but they probably just need a lot more refinement first. I imagine they're doing the consumer class first because well, better guinea pigs

            Comment


            • #7
              which cards it supports?

              Comment


              • #8
                Originally posted by Azrael5 View Post
                which cards it supports?
                I guess primarily those

                https://knowledge.autodesk.com/sites...Maya2017.pdf#4

                But OK, more ... anything from FirePro family - W/S/R/Sky as written there:

                http://support.amd.com/en-us/kb-arti...ase-Notes.aspx

                If you want details i can search for pciids inside driver? Lets do that too...

                So winners might have following numbers:

                1002:67A0
                1002:67A1
                1002:6608
                1002:6649
                1002:6780
                1002:678A
                1002:6828
                1002:682C
                1002:6808
                1002:6809
                1002:6821
                1002:692B
                There is GCN 1.0, 1.1 and 1.2 hardware there... Polaris Pro Q4 workstations should go somewhere else i guess
                Last edited by dungeon; 07-31-2016, 01:13 PM.

                Comment


                • #9
                  Originally posted by dungeon View Post

                  I guess primarily those

                  https://knowledge.autodesk.com/sites...Maya2017.pdf#4

                  But OK, more ... anything from FirePro family - W/S/R/Sky as written there:

                  http://support.amd.com/en-us/kb-arti...ase-Notes.aspx

                  If you want details i can search for pciids inside driver? Lets do that too...

                  So winners might have following numbers:



                  There is GCN 1.0, 1.1 and 1.2 hardware there... Polaris Pro Q4 workstations should go somewhere else i guess
                  I've tried to install it but without success I assume this driver doesn't support hd3850 vga card.

                  Comment


                  • #10
                    Originally posted by Azrael5 View Post
                    I've tried to install it but without success I assume this driver doesn't support hd3850 vga card.
                    Well that is pretty old consumer card (with i guess that you didn't permuted some numbers?) last driver for that was 13.1... dropped by actually 12.6 but steam is steam
                    Last edited by dungeon; 07-31-2016, 03:40 PM.

                    Comment

                    Working...
                    X