No announcement yet.

Xorg freezes the system with radeon driver on X1650 Pro

  • Filter
  • Time
  • Show
Clear All
new posts

  • #11
    That's part of the problem, it doesn't leave a log.. :/
    I tried compiling radeonhd, but I failed :/
    Where should I file a bug on radeon not working?

    Also, btw, I tried the latest Ubuntu alpha livecd, which is supposed to use the new Xserver and mesa, and it also hangs the PC, and I have to reboot.


    • #12
      Start at and scroll down to "Reporting problems, asking questions and getting help". That will give you links to the bug tracking system and mailing list (radeon questions normally start at the xorg mailing list).

      If you are filing a bug, product = xorg and component = Driver/Radeon. You can also try the #radeon IRC but a lot of devs are travelling or on vacation right now.

      It's interesting that the Ubuntu live CD hangs - that worked fine on my X1950 Pro. Not sure what to make of that yet. Is Alpha 4 still the latest ?
      Last edited by bridgman; 09-07-2008, 12:23 PM.


      • #13
        Is there a chance this will be fixed when X Server 1.5 is released officially, with Xorg 7.4?


        • #14
          Here, with the pakages from Debian Sid, my Radeon X1650 works without any problem. I use xserver-xorg-video-radeon, mesa 7.1 and xorg-server 1.5 from experimental.

          Host/Kernel/OS  "Defiant" running Linux 2.6.27-rc5-towo-2 i686 [ Debian GNU/Linux sid ]
          CPU Info        (1) Intel Pentium 4 1024 KB cache flags( sse3 ) clocked at [ 2992.449 MHz ]
                          (2) Intel Pentium 4 1024 KB cache flags( sse3 ) clocked at [ 2992.449 MHz ]
          Videocard       ATI Radeon X1650 Pro  X.Org 1.5.0  [ [email protected] ]
          Network cards   Intel 82562EZ 10/100 Ethernet Controller, at port: cf40
          Processes 123 | Uptime 6:35 | Memory 482.3/2025.0MB | HDD ATA ST3200826A,ATA WDC WD1600JB-75G,SAMSUNG HM160JC Size 520GB (35%used) |
          GLX Renderer Mesa DRI R300 20060815 AGP 4x x86/MMX/SSE2 TCL | GLX Version 1.3 Mesa 7.1 | Direct rendering Yes | Client Shell | Infobash v3.01


          • #15
            Looks like the latest from Ubuntu is Alpha 5; I haven't tried that. You might want to try Alpha 4 since I know that is working for a lot of R5xx users.


            • #16
              Could the problem be related to the make? Mine is PowerColor..


              • #17
                It's possible but I doubt it. I assume the board works OK with the vesa driver (but low res and really slow) ?

                The radeon driver doesn't have the ability to use shadowfb instead of HW acceleration on cards where HW accel is supported, but there is a "NoAccel" option IIRC - might be worth trying that with the radeon driver to help figure out if the crash is related to int/odesetting or to acceleration.

                I think the syntax is : Option "NoAccel" "true"


                • #18
                  Is it AGP card?

                  if so try Option "AGPMode" "1"

                  or "4"


                  • #19
                    It works with VESA, and no, it's not an AGP card.

                    I will try that NoAccel.


                    • #20
                      you only have libgl compiled with the software rasterizer driver.

                      You have to use aur or abs to build libgl and add r300 and radeon drivers into the configuration.

                      build() {
                        cd ${startdir}/src/Mesa-${pkgver}
                        patch -Np1 -i ${srcdir}/mesa-7.1-link-shared.patch || return 1
                        export CFLAGS="${CFLAGS} -ffast-math"
                        ./configure --prefix=/usr \
                          --with-dri-driverdir=/usr/lib/xorg/modules/dri \
                          --with-dri-drivers=swrast,r300,radeon \
                      Last edited by Execute_Method; 09-09-2008, 11:03 PM.