No announcement yet.

Broken app how do I find what's responsible?

  • Filter
  • Time
  • Show
Clear All
new posts

  • ovoskeuiks
    Solved with the following
    export LD_PRELOAD=/usr/lib/gcc/i486-linux-gnu/4.3.2/

    Leave a comment:

  • ovoskeuiks
    started a topic Broken app how do I find what's responsible?

    Broken app how do I find what's responsible?

    Hi All,
    I've been running libavg on ubuntu using nvidia hardware for some time now. I've recently purchased a couple of panel PC's with RS690 graphics and have been unable to get them to work with libavg. I want to resolve the issue but can't work out what part of the system is causing the problem and therefore don't really know who to ask for help.

    I've tried this with ubuntu 8.04.1 and 8.10, I run the server version and install xorg and python-libavg or alternatively libavg from SVN. libavg runs fine using indirect rendering on a basic install but the performance is obviously terrible with 100% CPU usage. Using the instructions from this forum I installed the updated Drivers, DRM modules and MESA code on the 8.04.1 install which got Direct Rendering working with about 800FPS in glxgears (DR works out of the box on 8.10) however once I have DR working everything using libavg breaks with an immediate seg fault. I've done core dumps and the library at the end of the trace is libstdc++.

    The potential culprits are:
    The radeon driver (Although this seems unlikely)
    The MESA DRI modules, eg libgl1-mesa-dri
    The DRM Modules
    The compiler
    The library libstdc++

    What I would like is some help in finding out who to talk to and submit bug reports etc. to help solve this issue. What do I need to do/know to inform the correct people. I'm happy to post any information that might be helpful but I thought better to find out what is useful rather than dumping logs and error reports all over the place.

    Any help at all would be most apprecaited