Announcement

Collapse
No announcement yet.

Carrizo driver issue

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • #21
    Originally posted by debianxfce View Post

    Yes, but use the " character, see the example: pcistub="pci-stub.ids=1002:6718,1002:aa80". After editing, use the commands: sudo update-grub and sudo reboot.
    done... i've updated grub, and i've restarted pc... nothing changed, always same temperatures

    Comment


    • #22
      Originally posted by debianxfce View Post

      Have you played with performance governors and checked that fan blows. If it is a year old pc, it is time to open the case and clean dust away.
      i've already cleaned fan and heatsink, high temperature is due to opensource driver.
      infact on windows, temperature are lower

      EDIT: cpu governor is already ondemand
      EDIT2: fan is already ok, infact when temperature increase, cpu fan increase rpm
      Last edited by Dea1993; 06-21-2016, 07:04 AM.

      Comment


      • #23
        Originally posted by debianxfce View Post

        If you are using Carrizo apu only, that uses cpu fan, so it is nothing to do with the mesa amdgpu driver.
        APU has also integrated gpu, then mesa amdgpu driver affect temperature

        Comment


        • #24
          Originally posted by debianxfce View Post

          You can make a custom kernel 4.7, enable CONFIG_DRM_AMD_POWERPLAY and see what happens. Carrizo apus are low power and in a worst case they use as much power as Kaveri, see http://www.extremetech.com/mobile/207229-207229
          My desktop A8-7600 Kaveri Apu is idling at 37 Celcius.when room temp is 22 and TDP is 65W. I can switch TDP from BIOS, 65W or 45W.,
          i'm already using amdgpu.powerplay=1 parameter on boot...
          if i disable this (ok kernel 4.7rc4) temperature increase.
          now with powerplay enabled and cpufrequtils installed, cpu temperature is better, but after installing cpufrequtils, i don't know why system seems a bit slower.
          furthermore temperature still not normal, sometimes continues to reach 60° and more, then cpu fan increase RPM and temperature decrease, other time temperature reach also 70°.
          hope to see improvments with linux 4.8 or AMDGPU-PRO

          Comment


          • #25
            looking the dpm stato of card0 (APU) i see that this is set to "performance"
            Code:
            cat /sys/class/drm/card0/device/power_dpm_state
            performance
            if i give this command
            Code:
            echo balanced > /sys/class/drm/card0/device/power_dpm_state
            the dpm state not change

            Comment


            • #26
              Originally posted by debianxfce View Post
              CONFIG_DRM_AMD_POWERPLAY is not enabled in the kernel configuration by default, so command line parameters has no effect. Do cpufreq-info show that conservative governor is used, see:
              https://wiki.debian.org/HowTo/CpuFrequencyScaling


              I did found only abnormal temperatures that has nothing to do with the linux amdgpu driver:
              https://www.reddit.com/r/Dell/commen...rheat_problem/
              i'm using conservative governor... but not fix the problem.
              temperature still reach 63° also if i'm not stressing cpu.

              maybe the problem can be that i can't change dpm state of card 0??
              if i run this command on terminal i don't receive errors
              Code:
               
               echo balanced > /sys/class/drm/card0/device/power_dpm_state
              instead if i open this file on gedit, and i put "balanced" instead of "performance", gedit tell me that the attribute is not valid

              Comment


              • #27
                Originally posted by debianxfce View Post

                It is implemented and I would use the option battery instead of balanced, see:
                https://github.com/torvalds/linux/bl...mgr/cz_hwmgr.c



                sysfs is a interface to the driver, not a text file.
                but archlinux wiki says that i can configure it with "echo balanced/battery/performance" options

                Comment


                • #28
                  Originally posted by debianxfce View Post

                  In debian you use the file /etc/sysfs.conf, see: https://packages.debian.org/sid/utils/sysfsutils
                  so what i must do to set dpm state to balanced?

                  ------------

                  i can force "power_dpm_force_performance_level" (default is auto)
                  with the command
                  Code:
                  echo low > /sys/class/drm/card0/device/power_dpm_force_performance_level
                  then the
                  cat /sys/kernel/debug/dri/64/amdgpu_pm_info
                  output is
                  Code:
                   index: 0 sclk: 300 MHz
                  
                   vddnb: 4450 vddgfx: 3200
                  
                   uvd    disabled
                  
                   vce    enabled
                  
                   index: 0 vce ecclk: 300 MHz
                  
                   [GPU load]: 2 %
                  instead if i set this on auto, sometimes reach these values

                  Code:
                   index: 5 sclk: 720 MHz
                  
                   vddnb: 4450 vddgfx: 4500
                  
                   uvd    disabled
                  
                   vce    enabled
                  
                   index: 0 vce ecclk: 300 MHz
                  
                   [GPU load]: 1 %


                  EDIT:
                  when gpu is not idle... temperature start increasing
                  Code:
                   index: 4 sclk: 626 MHz
                  
                   vddnb: 4200 vddgfx: 4150
                  
                   uvd    disabled
                  
                   vce    enabled
                  
                   index: 0 vce ecclk: 300 MHz
                  
                   [GPU load]: 30 %
                  gpu was 30% and temperature was more than 60°

                  then the problem is the integrated gpu that isn't controlled fine from the driver.
                  Last edited by Dea1993; 06-22-2016, 06:40 AM.

                  Comment


                  • #29
                    Originally posted by debianxfce View Post

                    This command should be given as root:
                    echo balanced > /sys/class/drm/card0/device/power_dpm_state If it works you can put that command to /etc/rc.local (edit the file as root).
                    of course i'm already root
                    but this command can't change the state of dpm

                    Comment

                    Working...
                    X