Announcement

Collapse
No announcement yet.

Carrizo driver issue

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • #11
    Originally posted by Dea1993 View Post
    amdgpu.dpm=1

    seems that the temperature are better and seems that firefox has no more freeze.
    i'm not sure if it is only a case or this really help.
    dpm is enabled by default already.

    Comment


    • #12
      Originally posted by agd5f View Post

      dpm is enabled by default already.
      i know but forcing enable dpm, seems that temperature are lower and cpu fan less noisy.
      maybe is only a case or only a my impression

      Comment


      • #13
        For me Ubuntu 16.04 + kernel 4.6 work fine, temperatures are normal and fan noise is also normal. I'm not passing any special parameters to during boot. (Only problem is shitdown issue, it doesn't poweroff on shutdown, it was with defaut Xenial kernel also)
        Dea1993 check with vga_switcheroo (https://help.ubuntu.com/community/HybridGraphics) may be dGpu is also running. BTW I've iGpu only.

        Comment


        • #14
          Originally posted by safknw View Post
          For me Ubuntu 16.04 + kernel 4.6 work fine, temperatures are normal and fan noise is also normal. I'm not passing any special parameters to during boot. (Only problem is shitdown issue, it doesn't poweroff on shutdown, it was with defaut Xenial kernel also)
          Dea1993 check with vga_switcheroo (https://help.ubuntu.com/community/HybridGraphics) may be dGpu is also running. BTW I've iGpu only.
          dGPU already dynOFF
          Code:
          0:IGD:+:Pwr:0000:00:01.0
          1:DIS: :DynOff:0000:04:00.0
          Originally posted by Dea1993
          now i'm using amdgpu driver with this kernel parameter

          amdgpu.dpm=1

          seems that the temperature are better and seems that firefox has no more freeze.
          i'm not sure if it is only a case or this really help.
          i correct, not solve the problem, temperatures continue to reach also 67° also if i'm not stressing PC


          EDIT: the last kernel 4.7 rc1 seems that has solved the problem of temperature. Now temperature are normal and cpu fan is no more noisy
          Last edited by Dea1993; 06-01-2016, 03:49 PM.

          Comment


          • #15
            Perhaps the bug/regression in the lenovo_ideapad module is the reason for not powering off during shutdown.
            https://bugzilla.kernel.org/show_bug.cgi?id=107481

            Comment


            • #16
              Originally posted by Dea1993 View Post
              EDIT: the last kernel 4.7 rc1 seems that has solved the problem of temperature. Now temperature are normal and cpu fan is no more noisy
              problem of temperature still not solved.
              furthermore now i'm using gnome shell on fedora, and with AMDGPU driver and kernel 4.7, Gnome Shell is really slow, with no smooth animations.
              i've tested also a notebook with an intel HD3000, and this is really smooth.

              AMD driver still not good, is not possible that i can't use the DE that i want, because driver are bad.
              i think that this notebook will never work nice with linux... so i think that my next notebook will have again an intel CPU, because AMD has too problems:
              1) bad performance on games (intel HD5200 is slower than my radeon r6, but on linux has more fps)
              2) sometimes has high temperature (also 70° only using a browser)
              3) bad user experience with some DE

              Comment


              • #17
                Originally posted by debianxfce View Post

                A10-8700p specs:
                http://www.notebookcheck.net/Carrizo....147654.0.html
                -> weak r6 gpu

                R7 360M specs:
                https://www.techpowerup.com/gpudb/2686/radeon-r7-m360
                -> faster GCN 1.0 gpu -> works with radeon driver

                So use radeon driver and blacklist amdgpu
                i can't blacklist amdgpu driver, because APU (primary GPU, use this driver) furthermore, also dGPU is using AMDGPU driver (i don't know why, but this is the output of lspci -vv)
                Code:
                04:00.0 Display controller: Advanced Micro Devices, Inc. [AMD/ATI] Topaz XT [Radeon R7 M260/M265] (rev ff) (prog-if ff)
                    DeviceName: AMD Radeon (TM) R7 M260
                    !!! Unknown header type 7f
                    Kernel driver in use: amdgpu
                    Kernel modules: amdgpu
                system see this gpu as a 260m.

                furthermore, also if r6 is "slower" than dgpu r7 m360, is really faster than an intel HD5200.


                QUOTE=debianxfce;n879412]
                Fedora and gnome are buggy and slow, use Debian testing Xfce that is faster, stable and freely configurable. It is a rolling release os too, update every day or never but no need to reinstall and wait stupid os releases.

                [/QUOTE]
                now i'm using debian testing xfce, i've also updated kernel to 4.7rc4, but temperature still too high.
                is a problem of driver, not a problem of distro or DE.
                are AMD open source driver that are shit for carrizo APU.
                i hope that newer kernel version will be better, i'm tired of this situation

                Comment


                • #18
                  Originally posted by debianxfce View Post

                  Reason is shitty bioses in laptops, the hardware seems to be dependent on software drivers. In my Asus A88-XM-E motherboard, I have set Bios to control fans and cpu frequency. In linux you have tools to control fans and cpu frequency. Amdgpu does not support crossfire, so set R7 360M off via Bios or linux pci interface.
                  dGPU is already off

                  Code:
                  sudo cat /sys/kernel/debug/vgaswitcheroo/switch
                  [sudo] password di andrea:
                  0:IGD:+:Pwr:0000:00:01.0
                  1:DIS: :DynOff:0000:04:00.0

                  Comment


                  • #19
                    Originally posted by debianxfce View Post

                    I would try something like:
                    http://superuser.com/questions/91481...rd-on-os-level
                    "
                    If that's not enough or if you use the same module for the GPU (integrated or second adapter) you actually use, bind the one you want to disable to pci-stub driver. Best way to do this is from kernel command line at boot. Just add pcistub="pci-stub.ids=..." followed by vendorID:deviceID codes you can find with lcpci -nns (your bus number from above) pcistub="pci-stub.ids=1002:6718,1002:aa80"
                    "

                    Can you monitor R7360M temperature with Xsensors to make sure it is off. Carrizo apus are low power and low temperature while r7 dgpu is not. Listen or measure that the laptop fan is spinning fast.
                    this is the output of lspci -nn
                    Code:
                    04:00.0 Display controller [0380]: Advanced Micro Devices, Inc. [AMD/ATI] Topaz XT [Radeon R7 M260/M265] [1002:6900] (rev ff)
                    if i launch
                    xsensors
                    i've this results

                    acpitz: 57°
                    k10temp: 53°
                    fam15h_power: (this tab is empty)
                    amdgpu: 0.0°

                    i think that k10 is cpu/apu
                    amdgpu is r7 m360 (so is really off then i think that isn't necessary that i follow your guide)
                    fam15 and acpitz i don't know what are

                    Comment


                    • #20
                      Originally posted by debianxfce View Post

                      Amdgpu driver does not monitor temperature of R7 250 in my A8-7600 Kaveri apu, Xsensors shows 3 C, so I would try using pci-stub in the kernel command line. Also study the linux tools to contol your fan and cpu frequency. Kernel does have performance governors.

                      Acpitz can be a sensor near cpu, so there is something generating more heat, maybe your R7 360m. One option is to open the case and use indoor/outdoor digital temperature meter and put the sensor on top of the R7.
                      this is lspci -nn
                      Code:
                       
                       04:00.0 Display controller [0380]: Advanced Micro Devices, Inc. [AMD/ATI] Topaz XT [Radeon R7 M260/M265] [1002:6900] (rev ff)
                      so my vendorID:deviceID are

                      1002:6900

                      what i must do?

                      can i insert
                      pci-stub.ids=1002:6900
                      into /etc/default/grub?

                      Comment

                      Working...
                      X