No announcement yet.

Current Situation of the Open-Spource Driver & AMD Hainan Card (on Fedora)

  • Filter
  • Time
  • Show
Clear All
new posts

  • Current Situation of the Open-Spource Driver & AMD Hainan Card (on Fedora)

    Hello Everyone,

    After using Linux since 3 Years now, I wanted to share my experience with the Open Source driver on my machine with you.

    First of, I am using an MSI GX70 with a AMD A10-5750M CPU, a AMD Radeon HD 8650G (Richland) integraded GPU and a AMD Radeon HD 8970M (Neptune XT)dedicated GPU.
    I got my maschine without an OS so I installed first Fedora 19. I think everyone, how followed the open source news, that the Radeon driver didnt work and so I had to use Catalyst.
    With the release of Fedora 20, and the kmod Catalyst package was orphaned, I had to stay on Fedora 19 because I kind of like Gnome 3 and since Version 3.10, Gnome wont work with Catalyst.
    But then came the first ray of hope for the open source driver with Fedora 21. Or at least on the Live-CD. After the Fedup to Fedora 21 and later a fresh install I had a very wired problem with the Open Source driver. I had to boot into recovery mode, than reboot to the latest kernel to get the sytem running. But with kernel 3.17.9 i think, was this problem solved. But only up to kernel 3.18.8. All newer Kernel wont work. The system will boot, bootlogo, the bootlogo will finish, and after 5 sec the system will get killed and reboots.

    Now to the Sitatuion of my Graphic Cards.
    The integraded GPU (the 8650G) worked well on Fedora 21 without any problems. But the dedicated GPU had and still has huge problems. On kernel 3.17-3.18 the system didn't even recognized the HD 8970M. The HD 8970M sould be an AMD HAINAN card, and the open soucre driver has support for Hainan so I have no clue were the problem lies.

    The situation I have right now.
    With all kernels after 3.18.8, the boot will fail as described above. The bug report center logs the error, but it says that there are hardware errors. But i think, its not the fault of the hardware but more the fault of the radeon driver/kernel/mesa/xorg.
    I also tried the latest Kernel (4.2 rc4) and mesa 10.7git from rawhide (I am right now on Fedora 22), but that also didn't solve anything. But in the boot log it tried to load the Pitcairn files for the HD 8970M. The pci id of the card is 01:00.0 0300: 1002:6801.
    So I still have to use Catalyst D:

    So thats it for now. If someone from you has some information what could be done or any ideas, i would be happy to read them.


  • #2
    6801 is pitcairn, not hainan. I'd suggest filing a bug ( and attaching your xorg log and dmesg output. Does appending radeon.runpm=0 on the kernel command line in grub help?


    • #3
      Oh good to know, because the marketing name of the hd 8970m is Solar System, and on other sides, regarding the name in the driver, it says hainan so i was a bit confused.
      Just one question: should I report it with the latest stable kernel (4.0) or on 4.2 or both?


      • #4
        Just one bug report is fine regardless of the kernel version.