Announcement

Collapse
No announcement yet.

Videos tearing

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • legume
    replied
    Originally posted by mirak63 View Post
    and I get a screen corruption when going in windowed mode in opengl video output
    Try the virtual work around -

    http://www.phoronix.com/forums/showp...3&postcount=20

    Leave a comment:


  • legume
    replied
    Originally posted by vitalyb View Post
    legume
    Setting large cache for Matroska definitely helps, not sure about mp4/qt, though. Try -cache 8192
    Thanks - it doesn't help in this case though.

    Leave a comment:


  • cheung
    replied
    try
    $ gmplayer -vo xv -mc 1 -ni

    It does work to play Full-HD video,but these is still no UVD support.


    MPlayer 1.0rc2-4.3.1-DFSG-free (C) 2000-2007 MPlayer Team
    CPU: AMD Athlon(tm) 64 X2 Dual Core Processor 4800+ (Family: 15, Model: 107,
    Stepping: 1)
    CPUflags: MMX: 1 MMX2: 1 3DNow: 1 3DNow2: 1 SSE: 1 SSE2: 1
    Compiled with runtime CPU detection.
    mplayer: could not connect to socket
    mplayer: No such file or directory
    Failed to open LIRC support. You will not be able to use your remote control.
    Selected font is fixed-width.
    Selected font is fixed-width.

    ================================================== ========================
    Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family
    Selected video codec: [ffh264] vfm: ffmpeg (FFmpeg H.264)
    ================================================== ========================
    ================================================== ========================
    Opening audio decoder: [faad] AAC (MPEG2/4 Advanced Audio Coding)
    FAAD: compressed input bitrate missing, assuming 128kbit/s!
    AUDIO: 48000 Hz, 2 ch, s16le, 128.0 kbit/8.33% (ratio: 16000->192000)
    Selected audio codec: [faad] afm: faad (FAAD AAC (MPEG-2/MPEG-4 Audio)
    decoder)
    ================================================== ========================
    AO: [alsa] 48000Hz 2ch s16le (2 bytes per sample)
    Starting playback...
    VDec: vo config request - 1440 x 1088 (preferred colorspace: Planar YV12)
    VDec: using Planar YV12 as output csp (no 0)
    Movie-Aspect is 1.32:1 - prescaling to correct movie aspect.
    VO: [xv] 1440x1088 => 1440x1088 Planar YV12

    ================================================== ========================
    Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family
    Selected video codec: [ffh264] vfm: ffmpeg (FFmpeg H.264)
    ================================================== ========================
    ================================================== ========================
    Opening audio decoder: [faad] AAC (MPEG2/4 Advanced Audio Coding)
    AUDIO: 48000 Hz, 2 ch, s16le, 188.6 kbit/12.28% (ratio: 23578->192000)
    Selected audio codec: [faad] afm: faad (FAAD AAC (MPEG-2/MPEG-4 Audio)
    decoder)
    ================================================== ========================
    AO: [alsa] 48000Hz 2ch s16le (2 bytes per sample)
    Starting playback...
    VDec: vo config request - 1920 x 1080 (preferred colorspace: Planar YV12)
    VDec: using Planar YV12 as output csp (no 0)
    Movie-Aspect is 1.78:1 - prescaling to correct movie aspect.
    VO: [xv] 1920x1080 => 1920x1080 Planar YV12 [fs]

    Leave a comment:


  • vitalyb
    replied
    legume
    Setting large cache for Matroska definitely helps, not sure about mp4/qt, though. Try -cache 8192

    Leave a comment:


  • legume
    replied
    Originally posted by vitalyb View Post
    legume
    Try -vf scale option. It won't scale anything and should not convert color space either... Virtually it does nothing but CPU usage is much lower sometimes. Have no idea why.
    Thanks - I tried and it did fix usage for a small youtube mp4, but it doesn't change things for some bbc quicktime/264 demos I tried.

    I know these particular demos were OK with gl on an older mplayer + old fglrx on my old card (X1600). I wonder which one of the three regressed.

    Leave a comment:


  • vitalyb
    replied
    legume
    Try -vf scale option. It won't scale anything and should not convert color space either... Virtually it does nothing but CPU usage is much lower sometimes. Have no idea why.

    Leave a comment:


  • mirak63
    replied
    this is still not fixed apparently

    and I get a screen corruption when going in windowed mode in opengl video output
    Last edited by mirak63; 08-21-2008, 05:04 AM.

    Leave a comment:


  • mirak63
    replied
    I still have no video tearing, with -vo gl
    but the 1080p videos are too slow, even on a quadcore q9300

    that's really unacceptable to need to go on windows to watch videos
    Last edited by mirak63; 08-18-2008, 01:43 PM.

    Leave a comment:


  • legume
    replied
    Originally posted by Guilo View Post
    Hi all !

    mplayer -vo gl:force-pbo

    works great : no tearing and fast decoding.
    Hope it can help
    Cool glad you found a solution.

    I tried it and using a recent mplayer couldn't get it to take the command without doing -

    mplayer -vo gl:ati-hack,force_pbo

    Unfortunately it still didn't stop ffmpeg h264 + -vo gl* eating pointless amounts of CPU in vo for me.

    Leave a comment:


  • Guilo
    replied
    Solution, at last

    Hi all !

    I just wanted to tell that I had found a solution while reading mplayer doc :

    (no)force−pbo

    Always uses PBOs to transfer textures even if this involves an extra copy. Currently this gives a little extra speed with NVidia drivers and a lot more speed with ATI drivers. May need −noslices and the ati−hack suboption to work correctly.
    so :

    mplayer -vo gl:force-pbo
    works great : no tearing and fast decoding.

    Hope it can help

    Leave a comment:

Working...
X